Bluetooth headset not recognized by Bluedevil in openSUSE 11.4


I’ve got an Arctic P311 bluetooth headset and am now trying to pair it with my openSUSE 11.4, KDE system. But it seems, like Bluedevil doesn’t recognize it properly:](

With my Nexus S mobile phone and also with Mac OSX, pairing was no problem.

What I’d like to achieve, is that the system plays sound over the BT headset and also receives audio from the builtin microphone.

How to proceed, so that KDE / Bluedevil / openSUSE 11.4 “plays well” with the P311?


I’m no expert here, but hopefully someone more knowledgeable will chip in later

Your attached image shows that ‘hcitool scan’ returns the MAC address of your headset is that correct? Have you tried pairing via hcitool?

hcitool cc 00:1A:7D:60:67:1F

Yes, hcitool (and also bluedevil) return the correct MAC address.

ask@ewzw032:/etc/bluetooth> hcitool cc 00:1A:7D:60:67:1F
Can't create connection: Operation not permitted
ask@ewzw032:/etc/bluetooth> sudo hcitool cc 00:1A:7D:60:67:1F

I need to be root to build the connection? The 2nd command returned nothing, so it’s to be assumed that it worked out allright.