Blank screen after grub2

My computer was working fine. Until the monitor just wouldn’t come on any more. It was old, had a vertical blue pixel line, and it was time to order a new one. In the mean time, I had an old monitor, but it only had a VGA and DVI port. My computer only has an integrated HDMI and Display Port. So I got an HDMI to DVI adapter which is supposed to work both directions.

When it boots with this temporary monitor, it shows the grub2 menu, but at a low resolution. If hitting enter, or waiting the 7 seconds, the screen goes blank, but you can hear the operating system loading. If I put “nomodeset” on the “linux” grub line, it will load into low resolution desktop. I think it was something like 640x360 when I checked. If I then reboot, it will then load into 1920x1080 desktop.

I tried a number of other things, which I don’t remember exactly, but none worked. Some such as grub_gfxmode=1920x1080x32, and plymouth.enable=0. The plymouth was the last I tried, and it was a blank screen. I have the power button to pop up the logout screen. By operating blindly, I then press the left arrow twice to the reboot, press enter, and the system reboots. It comes up, shows no grub menu nor any other thing, then after about 7 seconds, it loads into proper desktop at 1920x1080.

It’s like it’s not sensing the proper video settings, and showing the screen into never-never land. But after rebooting, it senses the right video, but then grub has problems displaying. Do you think it’s the HDMI to DVI adapter causing issues? I’m a little concerned that the new monitor may have trouble. However, my old HDMI monitor did work fine and the new one has an HDMI port. But I’d like to understand what’s going on for any future situations.

When displaying correctly:

>sudo lspci -nnk | grep -A3 VGA
[sudo] password for root: 
07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne [Radeon Vega Series / Radeon Vega Mobile Series] [1002:1638] (rev c9)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8809]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

Something which may not be relevant, is when originally upgrading my computer system some time ago, I had no monitor display of anything. Only until I took out the CMOS battery and held the power button down for awhile, did it start working okay. But I’m guessing the BIOS may have been set to an external graphics card for factory testing.

inxi -GSaz --vs provides a more complete picture of graphics hardware and software configuration than lspci.

How old is the motherboard battery now? Some BIOS get weird when voltage gets too low. UEFI BIOS with limited legacy mode support can be cantankerous when used with some displays, not unusually working better, or at all, with one cable type rather than another.

Nomodeset is a workaround. It never fixes anything FOSS, mainly provide a limited function means to make repair.

If errant behavior seems limited to periods when X isn’t running, such as on the VTs, the video mode to be there used can be specified rather than auto-detected using video=. Except when employing the intel DDX X driver, this video= option does not impact normal GUI operation. Most of the time, there is some delay after the Grub menu vanishes before this mode takes effect. video= can be used for manipulating font sizes on the VTs, using a lower resolution than optimal/native to make fonts larger.

My experience with HDMI to DVI adapters has been good, much better than other video converters. Unless yours is simply defective, I doubt it’s your problem.

My experience with Plymouth is limited to removing it when I have forgotten to prevent it from installing. I like to see what’s happening during startup, without touching keyboard or pointing device.

I just got the motherboard a month or so ago.
Hopefully the new monitor works. I don’t really understand about the video modes. By installing the system with one monitor, then switching monitors, do I have to update something for the new monitor?

> inxi -GSaz --vs
inxi 3.3.23-00 (2022-10-31)
System:
  Kernel: 5.14.21-150500.55.52-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.55.52-default
    root=UUID=9286d86c-b492-45d5-b9f3-b70c446be727 nosplash preempt=full
    quiet security=apparmor mitigations=auto
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7 dm: SDDM
    Distro: openSUSE Leap 15.5
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2
    process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-1 empty: DP-1
    bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 28.0 C
  Display: x11 server: X.Org v: 1.21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: AOC 2343 serial: <filter>
    built: 2012 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 5.14.21-150500.55.52-default) direct render: Yes
type or paste code here

When the new display arrives, shut down the computer, disconnect the old, connect the new, then boot up. If the new is also native 1920x1080, then everything should be OK without any need to fuss with settings or software. If the new is higher resolution, and also higher display density, you’ll not need to do such things, but you may want to to avoid back and/or neck strain from leaning forward to see all the time. With Plasma that shouldn’t take much effort, unless you want to keep using the old along with the new. Disparate display densities can require some effort to get the right settings combinations you can work with comfortably. 2K plus full HD usually isn’t very difficult, but full HD + 4k can be rather frustrating.

The new monitor arrived and works okay! I unplugged the adapter and used the same HDMI cable, and it booted up as expected. So I wonder why the temporary monitor didn’t work. Could it have some issues? I got it used from someone else and maybe they had problems with it. Or could it be just old and sending the wrong info to the operating system?

The new monitor is 1920x1080, so same settings as my old non-working one, and same as the temporary one. But I don’t understand what you said about Plasma and setting something so I don’t have to lean forward.

The temporary display was old. Old often means broken, especially when acquired at little to no cost. Also, the HDMI-to-DVI converter could be defective. If your new display has no DVI input you can test with, find a friend who has a PC with a DVI out port, and test it with his display or TV. If it fails there too, try to get your money back from its vendor.

It’s inapplicable, as your new display was a simple replacement with another of same specifications, not an “upgrade” to a 4k screen. With the pixel density increase a 4k, or sometimes even a 2k, represents, comes a shrinkage of screen objects, that until adjusted for via software, induces users to lean forward to be able to make out all the 1/4-size screen objects. :slight_smile:

Ah. Kind of like in the old days when monitors or Windows increased resolution from 320x and all your desktop icons shrank.

Thanks for your help and information. The new monitor is working great. And it looks so much better than my old one. New computer, new monitor, life is good.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.