Black screen on Tumbleweed installation

Currently using Ubuntu on my computer, no problem, but want to try openSuse (again, it was my preffered distro years ago, before it was leap/tw), I created my USB flash bootable disk, boots normally, starts to install; I get to see the bottom green bar loading. After it (apparently) finishes loading, it halts at a black screen. I’ve tried pressing ESC to see if I catch an error, but no error is displayed, it reaches step 7/7 (iirc) and then black. Keyboard’s caps and num leds turn on and off but it just doesn’t load anything after this point.
The installer’s help mentions something about trying “Install --ACPI Disabled” but I don’t know how to select this option.
Is there any known solution to this issue?

@darolu Hi and welcome to the Forum :smile:
At the grub install either select text mode install or if you press e to edit the install entry and at the linux or linuxefi option add nomomdeset and press F10 to boot the installer.

I suspect your graphics card(s), perhaps provide some hardware details?

Hello, thank you for your quick response.
I read about pressing ‘e’ to edit the install entry, however I push ‘e’ and nothing happens. I don’t recall seeing that linuxefi option but I’ll try to do that in a few minutes.

Here are my hardware details (is an old system), lemme know if you need more details:

System:
  Host: danjr Kernel: 5.19.0-41-generic x86_64 bits: 64 Desktop: GNOME 42.5
    Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-990FXA-UD3 v: x.x
    serial: <superuser required> BIOS: Award v: F5 date: 10/13/2011
CPU:
  Info: 6-core model: AMD FX-6100 bits: 64 type: MT MCP cache: L2: 6 MiB
  Speed (MHz): avg: 1404 min/max: 1400/3300 cores: 1: 1400 2: 1400 3: 1424
    4: 1400 5: 1400 6: 1400
Graphics:
  Device-1: AMD Barts PRO [Radeon HD 6850] driver: radeon v: kernel
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: vesa unloaded: fbdev,modesetting
    gpu: radeon resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD BARTS (DRM 2.50.0 / 5.19.0-41-generic LLVM 15.0.7)
    v: 4.5 Mesa 23.2.0-devel (git-f094c8a 2023-05-16 jammy-oibaf-ppa)
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.19.0-41-generic running: yes
  Sound Server-2: sndio v: N/A running: yes
  Sound Server-3: PulseAudio v: 15.99.1 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 50:e5:49:c2:30:bf
Drives:
  Local Storage: total: 2.28 TiB used: 227.34 GiB (9.7%)
  ID-1: /dev/sda vendor: A-Data model: SU630 size: 447.13 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DL003-9VT166 size: 1.82 TiB
  ID-3: /dev/sdc type: USB vendor: SanDisk model: Cruzer Force
    size: 28.65 GiB

Found the No ACPI option. I had to press F-5 (kernel options):

@darolu Hi, so the install completed? Or is are you just wanting to run a live USB?

Yes, I can run the installer now. Fortunatelly all I had to do is press F5 to see the installation options mentioned in the installation’s help (F1). In this case, the “ACPI Disabled” one.
Thanks for the replies, I appreciate it.

1 Like