BIOS boot hangs on ASUS EEE PC 100

Hello, guys.

I’ve got a boot problem with ASUS EEE PC 1000 (BIOS 0803).
First time it boots normally. It shutdowns normally always.

Second time: it sometimes boots normally and sometimes hangs with black screen. No BIOS messages, just indication of SSD-disk access. I can power off it by holding POWER BUTTON. But next time I see black screen again.

The only resolution plug out battery, then plug in it.
First time after plug-out-in cycle it boots normally.

How-to reproduce: boot, shutdown, boot, shutdown, boot hangs every 2-3 attempt.

Does anyone had similar issue?
Any ideas what to try?

Thanks for attention, Sergey.

Fixed via Yast:

  1. Run System->Sysconfig Editor
  2. Set

Now 5 reboots/powerdowns with no problem.

Do you know why this solved the problem ?
Can you explain ?
Is there the same problem for every eeepc ?

I don’t understand details. It just works for me. :slight_smile:

I’ve just installed 11.1 on my EEE 901, and have almost exactly the same problem. Every 2-3 boots, I get a blank screen with all the panel leds lit. The only cure is to take the battery out. The Sysconfig solution above does not work for me. I’ve tried doing a complete new install, and that doesn’t work either. I read on another forum that someone had found that adding “noresume” to their menu.lst solved their problem, but again, this didn’t work for me.

The only clue I have is from /var/log/boot.msg. The first few lines are as follows:

“Inspecting /boot/
Cannot find map file.
No module symbols loaded - kernel modules not enabled.”

When I look in /boot, is present.

Can anyone help, please? The machine is unusable in its present state.

Many thanks in anticipation!

I’ve heard that sound module should be unloaded on 901 before poweroff.

Add line
/sbin/rmmod snd-hda-intel
at the end of /etc/init.d/halt.local

Hope it helps.

Thanks, Sergey, but I’m sorry to say that this didn’t cure it.

I’ve tried every solution I have read about, and a few of my own, without much success. The best so far seems to be to start up and shut down with the power adapter unplugged, then connect it after the machine has booted. Weird!

I’ve read a few posts on other forums (Ubuntu, Mandriva) where other people are having similar problems. There seems to be a view that the problem is in the the kernel that ships with 11.1 ( and the latest version ( fixes it. Does anyone know anything about this?