Bildschirm richtig einstellen - Grafikkarte NVIDIA Corporation G96GL [Quadro FX 580]

Guten Tag,
vorhin habe ich ein Upgrade von Suse 13.1 auf Suse 13.2 gemacht. Nun ist die Anzeige wie folgt

https://paste.opensuse.org/12754515

Wie kann ich die Anzeige richtig konfigurieren? Unter Systemeinstellungen kann ich nur

https://paste.opensuse.org/20416433

1280*1024

einstellen. Für meinen 42,5 cm breiten und 23,5 cm hohen Fujitsu Breitbildschirm benötige ich aber eine andere Auflösung (1440*900?), die ich nicht einstellen kann.

Welches ist eigentlich der richtige Treiber für die o.g. Grafikkarte? Hatte zuerst g03…nivida und danach g04…nividia installiert, aber komme mit beiden nicht richtig zurecht.

Vielen Dank für Support!

Und warum gerade 13.2?
Das wird seit fast 2 Wochen nicht mehr unterstützt (es wurde 2014 veröffentlicht…).

Momentan unterstützte Versionen sind Leap 42.1 und 42.2.

Nun ist die Anzeige wie folgt

SUSE Paste

Ich kann auf diesem Bild leider kein Problem erkennen.

Wie kann ich die Anzeige richtig konfigurieren? Unter Systemeinstellungen kann ich nur

SUSE Paste

1280*1024

einstellen. Für meinen 42,5 cm breiten und 23,5 cm hohen Fujitsu Breitbildschirm benötige ich aber eine andere Auflösung (1440*900?), die ich nicht einstellen kann.

Das Einstellungsmodul offeriert die Auflösungen, die der Grafiktreiber meldet (und der sollte normalerweise den Monitor fragen).

Warum das so ist (und auch welcher Treiber vewendet wird), sollte eigtl. im Xorg Logfile ersichtlich sein.
Bitte poste also die Datei /var/log/Xorg.0.log .

Andererseits sollte der Monitor auch beliebige andere Auflösungen korrekt darstellen können, und das Bild entsprechend skalieren.
Da hilft evtl. ein Blick in die Einstellungen des Monitors.
Allerdings ists natürlich vorteilhaft die “native” Auflösung des Monitors zu verwenden.

Welches ist eigentlich der richtige Treiber für die o.g. Grafikkarte? Hatte zuerst g03…nivida und danach g04…nividia installiert, aber komme mit beiden nicht richtig zurecht.

Laut nvidia Homepage sollte die Karte von G03 unterstützt werden (aber nicht mehr von G04).

OK, dann installiere ich wieder G03. Danke!

Wie stelle ich die Auflösung auf 1600900 ein? Diese Auflösung wird mir derzeit unter Systemeinstellungen - Anzeige einrichten nicht angeboten, so dass ich bis dahin 12801024 verwende. Muss ich dazu eine xorg.conf konfigurieren und falls ja, wie?
Danke vorab.

LG

Poste:

zypper se -si nvidia
uname -a
cat /proc/cmdline
grep -i 'blacklist nouveau' /etc/modprobe.d/*
/sbin/lspci -nnk | grep -EiA3 'vga|3d|display'

Benutze für die Ausgabe (immer incl der kompletten Eingabezeile) für jeden Befehl ein separates Code-Tag, so wie ich es gemacht habe.

Und bitte antworte nicht in ein Zitat, könnte sonst übersehen werden (ist mir gerade passiert), besser ist, nur bis zur Frage zitiere, danach normal antworten und neu zitieren.

Wie gesagt: Bitte poste die Datei /var/log/Xorg.0.log, damit man sieht was los ist.

Wenn die Auflösung des Monitors nicht angeboten wird, gibts irgendwo ein Problem.

Und hier die Antwort auf deine Antwort in dem Zitat:

    23.032] (WW) NVIDIA(0): The NVIDIA Quadro FX 580 GPU installed in this system is
    23.032] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
    23.032] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
    23.032] (WW) NVIDIA(0):     information.  The 361.42 NVIDIA driver will ignore this
    23.032] (WW) NVIDIA(0):     GPU.  Continuing probe... 

Das ist nicht der G03 Treiber. Und auch nicht im Repo vorhanden…

Also poste bitte die Ausgaben der obigen Befehle.

zypper se -si nvidia
Loading repository data...
Reading installed packages...

S | Name                      | Type    | Version                | Arch | Repository             
--+---------------------------+---------+------------------------+------+------------------------
i | nvidia-computeG02         | package | 304.131-39.1           | i586 | nVidia Graphics Drivers
i | nvidia-gfxG02-kmp-default | package | 304.131_k3.11.6_4-38.1 | i586 | nVidia Graphics Drivers
i | nvidia-gfxG02-kmp-desktop | package | 304.131_k3.11.6_4-38.1 | i586 | nVidia Graphics Drivers
i | nvidia-gfxG02-kmp-pae     | package | 304.131_k3.11.6_4-38.1 | i586 | nVidia Graphics Drivers
i | x11-video-nvidiaG02       | package | 304.131-39.1           | i586 | nVidia Graphics Drivers
uname -a
Linux linux-ehkd 3.16.7-53-desktop #1 SMP PREEMPT Fri Dec 2 13:19:28 UTC 2016 (7b4a1f9) i686 i686 i386 GNU/Linux

cat /proc/cmdline
root=/dev/disk/by-id/ata-ST3250318AS_9VY5LX2D-part2 resume=/dev/disk/by-id/ata-ST3250318AS_9VY5LX2D-part1 splash=silent quiet
grep -i 'blacklist nouveau' /etc/modprobe.d/*
/etc/modprobe.d/nvidia-default.conf:blacklist nouveau
/etc/modprobe.d/nvidia-desktop.conf:blacklist nouveau
/etc/modprobe.d/nvidia-pae.conf:blacklist nouveau
/sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96GL [Quadro FX 580] [10de:0659] (rev a1)
        Subsystem: NVIDIA Corporation Device [10de:063a]
        Kernel modules: nouveau

https://paste.opensuse.org/3994369

Ja, genau das ist mir auch passiert. Ich hab den Link zum Xorg log übersehen.

Allerdings ist das ja nicht mehr unbedingt aktuell.
Also bitte nochmal die momentane Version…

Das ist aber auch nicht G03.

Und warum gleich 3 Versionen des Kernelmodules?
Außerdem sind das die Pakete für 13.1, nicht 13.2.

Poste bitte mal deine Repoliste:

zypper lr -d

SUSE Paste

Das System verwendet den generischen VESA Treiber, da das nvidia Kernelmodul nicht geladen werden kann.

[/var/log/Xorg.0.log

https://paste.opensuse.org/3994369](https://paste.opensuse.org/3994369)

zypper lr -d
#  | Alias                              | Name                                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                       | Service
---+------------------------------------+---------------------------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------+--------
 1 | download.nvidia.com-opensuse       | nVidia Graphics Drivers                                 | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.1/                                 |        
 2 | download.opensuse.org-13.1-non-oss | Aktualisierungs-Repository (Nicht-Open-Source-Software) | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                         |        
 3 | download.opensuse.org-non-oss      | Haupt-Repository (NON-OSS)                              | No      | ----      | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/              |        
 4 | download.opensuse.org-oss          | Haupt-Repository (OSS)                                  | No      | ----      | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                  |        
 5 | download.opensuse.org-update       | Hauptaktualisierungs-Repository                         | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                 |        
 6 | ftp.gwdg.de-suse                   | Packman Repository                                      | No      | ----      | No      |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                  |        
 7 | openSUSE-13.1-1.10                 | openSUSE-13.1-1.10                                      | No      | ----      | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                  |        
 8 | packman                            | packman                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_13.2/             |        
 9 | qgis                               | qgis                                                    | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_13.1/ |        
10 | repo-13.2-non-oss                  | openSUSE-13.2 Non-OSS                                   | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/              |        
11 | repo-13.2-oss                      | openSUSE-13.2 OSS                                       | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                  |        
12 | repo-13.2-update-non-oss           | openSUSE-13.2 Updates Non-OSS                           | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                         |        
13 | repo-13.2-update-oss               | openSUSE-13.2 Updates OSS                               | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                 |        
14 | repo-debug                         | openSUSE-13.1-Debug                                     | No      | ----      | No      |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.1/repo/oss/            |        
15 | repo-debug-update                  | openSUSE-13.1-Update-Debug                              | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1/                           |        
16 | repo-debug-update-non-oss          | openSUSE-13.1-Update-Debug-Non-Oss                      | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1-non-oss/                   |        
17 | repo-source                        | openSUSE-13.1-Source                                    | No      | ----      | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/           |        
18 | repo-update                        | openSUSE-13.1-Update                                    | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                 |        
19 | repo-update-non-oss                | openSUSE-13.2-Update-Non-Oss                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/     


Ich habe noch einen weiteren Rechner, den ich vorhin an meinen Bildschirm angeschlossen habe. Der konnte perfekt 1600*900 anzeigen mit dem Treiber g02 von NVIDIA unter Suse 13.1.
Zudem möchte ich bald alle Rechner von 13.1 bzw. 13.2 gerne via CD+Netzwerkinstallation auf LEAP 42.2 upgraden, wenn ich es schaffe …

Tja, das ist für 13.1.
Damit wirst du unter 13.2 nicht viel Freude haben…

Also entferne das Repo und alle installierten nvidia Pakete (und auch kernel-pae und kernel-default falls installiert, würde ich vorschlagen), dann konfiguriere das nvidia Repo für 13.2 und installiere den (G03) Treiber neu.

sudo zypper rr 1
sudo zypper rm nvidia-computeG02 x11-video-nvidiaG02 nvidia-gfxG02-kmp-default nvidia-gfxG02-kmp-desktop vidia-gfxG02-kmp-pae kernel-default kernel-pae
sudo zypper ar -f http://download.nvidia.com/opensuse/13.2/ nvidia
sudo zypper in x11-video-nvidiaG03

Danach sollts hoffentlich funktionieren… :wink:

PS: die restlichen 13.1 Repos könntest du auch entfernen um die Liste übersichtlicher zu machen.
Das aber nur am Rande, da sie sowieso deaktiviert sind ists eigtl. egal.

Funktioniert! :wink:

Vielen Dank!