Big problem with black screen on Dell laptop (ATI)

Hello there,

Earlier today I was facing a problem when I was trying to install jdk with netbeans. I had an “no x11 found” and “cant initialize UI” error. After a lot of googling I found no solution but then I found a random post about the new AMD 11.11 (I think) drivers for linux that improve opensuse and fedora latest releases.

I had a feeling that it wasn’t going to have a good end. So when I rebooted, I had a black sreen.

My laptop is very problematic when it comes to graphics. Before opensuse I had kubuntu and had some problems there too. In windows, after starting a game, chances are the laptop is gonna shut down completely within a matter of minutes (there are reports about this laptop-only problem in the last 10 or so years lol).

Any help will be MUCH appreciated since I have some deadlines and I have to work in linux (currently in windows).

PS: I use opensuse 12.1 with gnome 3.1 (iirc). My graphics card is ATI Mobility 4500 series (no specific model for some reason).

Before I provide a suggestion - first some general Operating System independent advice (ie applicable to MS-Windows, Windows7, BSD, MacIntosh, and GNU/Linux (all distributions)). If one has a pressing deadline or upcoming meeting, do NOT do anything to change one’s PC configuration. At times I’ve waited for 6 months before installing driver updates or kernel updates or other updates, just because I did not want to take ANY chance of anything going wrong because I had many important meetings and deadlines, in succession, coming up … anyway … 'nuff said.

I assume BEFORE you installed the AMD 11.11 (that you think) drivers that you were using the Radeon open source driver with no xorg.conf file and no edits in the 50-device.conf file. I don’t know what you did (if anything) wrt KMS (kernel mode setting).

If you boot to text mode (press ‘3’ (no quotes) when grub menu 1st appears and select a nominal boot) and log in as a regular user, you can type:

rpm -qa '*fglrx*'

and see what if any AMD catalyst rpms were installed (which will have ‘fglrx’ in the file name). Remove those rpms with something like

rpm -e yyyyyyyyyyyyyyyyyyyyyyy

where ‘yyyyyyyyyyyyyyyyyyy’ is the rpm name that you need to delete. So type that rpm name there. You of course need root permissions (which is why I typed the ‘su’ first).

Once those rpms are removed, you can restart with root permissions with:

shutdown -r now

If a regular reboot fails, try a failsafe reboot.

Now , once you have rebooted and hopefully your desktop back, give some thought as to WHY this problem occured. Did you disable kernel mode setting before trying to install the proprietary AMD driver ?

As always I appreciate help, especially from people that I don’t know and never gonna meet in my life :smiley:

On the subject, I guess you mean -qa, not qa. Also, I can’t find find any file with fglrx.

Apart from installing the driver, I made no changes in my computer before this problem occured.

Yes its ‘-qa’ like I noted.

So then you did not install the proprietary driver.

Did you attempt to boot with the ‘failsafe’ boot option in grub? Or alternatively with the boot code ‘nomodeset’ or with the boot code ‘x11failsafe’ ?

No no :stuck_out_tongue: I am actually a noobie here and I don’t know what most of the things you said do. Apart from installing the amd driver I didn’t do anything else (and yes I am sure I installed it).

If the command that I gave you yields nothing:

rpm -qa '*fglrx*'

Then it is unlikely that you have the proprietary AMD driver installed. What you could do is paste a copy of the file /var/log/Xorg.0.log to the paste website SUSE Paste and press ‘create’. It will give you an updated website address where your ‘paste’ is located. Post the web site address here. We can look at it.

You may find that difficult to do with out a GUI. So try go get a basic GUI first.

To do that try to boot to fail safe - for that you just need to look at the initial grub boot selection splash menu that comes up. Fail safe is one of the boot options. You can select that.

Or when the grub boot selection splash menu comes up you can type ‘nomodeset’ such that a ‘nomodeset’ (no quotes) appears in the options line and then press enter and you should boot to either an FBDEV or radeonhd graphic driver. Or instead of ‘nomodeset’ type ‘x11failsafe’ and that should boot to an FBDEV or VESA graphic driver.

Booting in fail safe worked! I just got a message “Gnome 3 failed to load”, however my ui is mostly working (I don’t have a hot corner and a menu bar in my left). This is the log: SUSE Paste

Ok, … in failsafe your PC is using the ‘FBDEV’ driver which is a very slow driver. It would be nice if we can get this working with a different driver. Can you reboot, and do NOT use nomodeset. This will fail. We want that as it will record the needed information in a log file. Then restart and boot again, and the second time select the ‘fail safe’ boot mode. Then look for the file “/var/log/Xorg.0.log.old” (note the .old … I forgot to mention that last time). Please copy the contents of /var/log/Xorg.0.log.old file to SUSE Paste and press ‘create’ and post here the URL. That Xorg.0.log.old file may have some error messages which explain what driver was attempted and why it failed.

SUSE Paste this is it, although it says it that the file has some character errors.


I can see there were problems loading the fglrx driver in the log:

    23.560] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    23.577]    compiled for, module version = 8.91.4
    23.577]    Module class: X.Org Video Driver
    23.689] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    23.712] (--) fglrx(0): Chipset: "ATI Mobility Radeon HD 4500 Series" (Chipset = 0x9553)
    23.712] (--) fglrx(0): (PciSubVendor = 0x1028, PciSubDevice = 0x02be)
    23.809] (WW) fglrx(0): board is an unknown third party board, chipset is supported
    23.810] (WW) fglrx(0): Hasn't establisted DRM connection
    23.810] (II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x20000000)
    23.810] (WW) fglrx(0): No DRM connection for driver fglrx.
    24.062] (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    24.062] (WW) fglrx(0): ***********************************************************
    24.062] (WW) fglrx(0): * DRI initialization failed                               *
**    24.062] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible ***
    24.062] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
    24.062] (WW) fglrx(0): ***********************************************************
    24.160] (WW) fglrx(0): Textured Video not supported without DRI enabled.
    24.404] (EE) fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
    24.404] (EE) fglrx(0): XMM failed to initialize
    24.404] (WW) fglrx(0): No XV video playback available
    24.404] (II) fglrx(0): Enable composite support successfully
    24.404] (WW) fglrx(0): Option "VendorName" is not used
    24.404] (WW) fglrx(0): Option "ModelName" is not used

It looks to me that you had a bad installation of the driver. The driver likely needs to be installed again in a correct manner.

Please, what model Laptop is this ? Is this by chance a Laptop with multiple graphic devices ?

Also, while I see the fglrx driver attempting to be loaded, but I can not understand why the command

rpm -qa '*fglrx*'

provided no output. It should show an rpm with ‘fglrx’. So it would REALLY help if you described how you tried to install the AMD (Catalyst) proprietary graphic driver, because I can not see that driver functioning without the rpm.

Could you please describe to me EXACTLY how you went about installing the AMD proprietary (Catalyst) graphic driver (known as ‘fglrx’) ?

Please also advise if as part of the AMD proprietary (Catalyst) graphic driver installation process if you disabled Kernel Mode Setting (KMS) via YaST (or via other method) ? One typically can disable KMS by navigating to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted. So you should recall if you did this. The openSUSE-12.1 release notes advises this is necessary for some users in some cases.

Don’t forget to advise as to what model Dell Laptop this is ?

I downloaded the drivers from here: AMD Catalyst™ Proprietary Display Driver

I normally run the file and chose automatic installation (note that I didn’t get an “a fglrx installation already exists” or something.

I used the rpm command you showed me but again with no luck.

My laptop is Dell is Studio 1555.

Also, I didn’t disable KMS (don’t even know what it is).

I’m not familiar with that …

I also get my driver from there, and I run the script with

sh --buildpkg < opensuse version goes here >

where I insert the appropriate version numbers … which creates the fglrx rpm that I then install.

I think you need to run that installer again and UNINSTALL the fglrx driver. Clearly it did NOT install properly. Then I think you need to ensure you have the necessary support packages such as the kernel-source and kernel-syms appropriate for your kernel.

Also, I think you should disable KMS (kernel mode setting) like I discribed.

KMS is mentioned in the openSUSE release notes. With KMS enabled, the kernel will automatically try to set the graphic mode/configure the graphic driver (Kernel mode setting) based on the hardware it detects. Sometimes it makes a mistake. So one can then disable KMS and let X window itself try to automatically set the graphic mode / configure the graphic driver. I described how tot do that above. And if if that fails one can hand edit files such as xorg.conf and 50-device.conf.

But first,

  • uninstall amd graphic driver
  • ensure kernel-source and kernel-syms installed
  • disable KMS ( One typically can disable KMS by navigating to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted. ) reboot afterward
  • re-install amd graphic driver

Good luck.