bfgminer (bitcoin mining)


Id like some help setting up bfgminer
Ive been following this guide:

And expect a few minor changes because its slightly outdated (pretty much download links and versions numbers) i did everything it tells.

yet whenever i run bfgminer (even with the -S opencl:auto tag) or guiminer i get a segmentation fault.

OpenCL seems to be installed correctly, because prior to this, the error message i had was from guiminer saying i had no opencl devices in an alert window. now i dont even get to that.

i ran aticonfig --initial, blacklisted the opensource radeon driver and this is my fglrxinfo output:

audric@linux-soqy:~/poclbm> fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 5700 Series
OpenGL version string: 4.4.12874 Compatibility Profile Context 14.10.1006

any help please?

Without any knowledge about bitcoin mining (I’ve only read some descriptions),
I took a brief look at your reference, and it appears only to be about OpenCL.

You may or may not know that OpenCL is a somewhat widely used scripting environment that supports a number of special situations including GPU processing which is what your reference more or less focuses on.

For starters, GPU architecture and related APIs are relatively fast moving.
Another is that I don’t know if your app is really a GPU app or not.

Bottom line is that you’ll likely need some detailed info on what kind of app your bitmining is (ie Is it a GPU app?) and then you’ll likely need some instruction relevant to both your specific GPU and the app versions.

And, note that at least in the nVidia world, you need to closely inspect the features of your GPU driver to verify it supports GPU processing, I assume the same should be true in the AMD/Radeon world.



yes sorry i should have provided more information at first.

Im aware whats OpenCL and gpumining but thanks. As for the mining software in particular, its the very first word of the topic title, bfgminer.

I come with updates.

So apparently the segmentation fault was due to the fact my icds were misplaced. so i added them (it seems) by taking a shot in the dark doing files likes this in opt/vendors/OpenCL



i have done this for amdocl64.icd, amdoclcl64.icd, aticalc.icd, aticaldd.icd, and aticalrt.icd. All the icds i could make of the libs provided by the amd sdk.

also, two shortcuts were automatically made by installing the sdk:

they both point to /opt/amd-opencl-icd-VERSION.MINOR/lib/

when i did that, bfgminer told me it couldnt find/read, so i made it for him by downloading and adding it from the source:
into my bfgminer folder. it worked.

after that, unfortunately, i have yet another error, this is the new and latest output:

 5s:144.9 avg:153.1 u:  0.0 Mh/s | A:0 R:0 S:0 HW:1 U:0.0/m BS:0
 ST: 2  DW: 0  GW: 1  LW: 6  GF: 0  NB: 1  AS: 0  RF: 0  E: 0.00
 Connected to diff 1.02k with stratum as user audricd.worker2
 Block: ...f42311a9 #323092  Diff:34.7G (248.1Ph/s)  Started: [21:37:34]
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 OCL 0:  59.0C  45%    | 128.5/153.1/  0.0Mh/s | A:0 R:0 HW:1 U:0.00/m

 [2014-09-29 21:37:30] Probing for an alive pool
 [2014-09-29 21:37:34] Network difficulty changed to 34.7G (248.1Ph/s)
 [2014-09-29 21:37:34] Stratum from pool 0 detected new block
 [2014-09-29 21:37:34] Disabling extra threads due to dynamic mode.
 [2014-09-29 21:37:34] Tune dynamic intensity with --gpu-dyninterval
 [2014-09-29 21:37:34] OCL 0 (thread 1) being disabled
 [2014-09-29 21:37:54] OCL 0: invalid nonce - HW error

it seems its definitely a step forward as the gpu appears to be detected

also I forgot to mention we are talking about a ati 5780 1gig, the rest of the rig is a amd phenom quad 3ghz, 4gigs of ram ddr2.

im making progress but im stuck again.