Best converter for old fpx camera images?

Showing my age! I find that many of my early digital pictures are in .fpx format from a Kodak camera. They were copied onto CDs and now I need to see them.
Please could somebody advise how I may convert these to .jpg format and include in my digiKam database for future viewing and reference.

Did you try to find something on the ineternet?

I found e.g. this:

Freeware for individuals, Linux download, mentions fpx (on another page).

Hi Henk,
Many thanks for the speedy reply. I have spent a while on the net and have downloaded and run the XnView_MP AppImage. This opened OK and found my CD directory and files but the .fpx files are not recognised. There was a list of file types which did not include .fpx so either it has been dropped or I am doing something wrong. Tried to join the XnView forum but the registration failed on the Catchpa saying the domain was not recognised. No idea what that is about so will try from another machine.

Thanks again for your help. I will also have a look at Irfan View which might be available on Linux and also ImageMagick. I may even have to go to the dark side and try a windoze version but will let you know how I get on.
Many thanks again,

You can try the GraphicsMagick also

Hi and many thanks for this. Your suggestion is just what I need; GraphicsMagick is supposed to support .fpx but it requires FlashPix SDK.

I may need more help here. How may I obtain and use the above mentioned SDK please?


According to ImageMagick supports FPX with the FlashPIX SDK. However, running

identify -list format

on my machine shows that this is not installed by default.

This might be what you’re after…
Outside the limits of my knowledge unfortunately, so just based on what a quick search turned up.

Short story so far is that fpx library was not installed and not picked up by configuring with


when I tried to configure ImageMagick because the libfpx is not installed. No surprise there and with some reading I am going to try using libfpx from ImageMagick so I have downloaded the source code and am going to try building it on this machine.

This exercise is being done after I have already run ./configure on the ImageMagick source and failed. How can I “start over” with ./configure when I have installed the fpx library (libfpx). Can I just run it over the existing files or should I delete some files and if so which?
Still on bottom of learning curve here so guidance would be appreciated.

You might be best advised to seek that support from the ImageMagick forum…

Hi Deano and yes. Many thanks, I have it now.
Bigger issue than I thought but I think I am making progress.
The answer, I am sure is with that application. Just trying to get it going in oSTw.

You didn’t say where and in what form you obtained your source.

As is typical nowadays…
Github is a common place to obtain source.
Clone the libfpx source and follow the instructions, looks basic (no need to ./configure unless you want something unusual)


Hi Tsu,
Sorry I didn’t confirm but I did the libfpx library from the github site to which you refer and I have built and installed it without any problems. Sadly I have not done so well with ImageMagick but have to leave it now until the weekend. Too much work on here.
Many thanks for your support.

There are plenty of solutions,
Including free online converters…

Although I’m always up to trying to make something work, if you’re more interested in the practical, “it just works” option, there are many to choose from


I understand and thanks. I did of course search both on Linux and the dark side and many fall down with the .fpx format. Others are only available in older windoze OSs in 32 bit and sadly I have thrown most of the old stuff away so I am rather enjoying the challenge and learning experience.

PS. Your message on email prompted an an interesting experience. In the email of your previous post, the message reads:-

As is typical nowadays…
Github is a common place to obtain source.
Clone the libfgx source and follow the instructions, looks basic (no need to ./configure unless you want something unusual)

In your previous post you will see the quotation is shown correctly as it appears on line. I wonder how the email became corrupted?

Just to wrap up this thread, I sought help from both ImageMagick and GraphicsMagick. The underlying problem is with the libfpx libraries which have not received much support and are now deprecated by some. This was not good news as my old fpx pictures are much wanted and I am sure others will be in the same position particularly as older operating systems are no longer available and 32 bit machines will no doubt follow.

The advice I received is that the most recent work on libfpx was done for ImageMagick and I sourced the download for libfpx from github. I installed this and then built and installed GraphicsMagick (GM) with the libfpx libraries installed. The jpg libraries were within the default build so once installed this gave me what I needed. I was able to do all this on Tumbleweed and am not aware of any serious errors.

Running GM to convert my .fpx files to jpg gave me reasonable images.
For example a .fpx image which was shown as being 549.0 KiB converted to a file of 130.7 KiB. I assume this is an artefact from the multiple content of the .fpx format and will need to follow this up to understand more.

The jpg picture image from the GM converted file, when viewed with gwenview, was shown with an Image Size of 1,024 x 1,535 (1.6MP). I suspect the quality is as good as I can expect from an ancient Kodak camera from 20 years ago. Hope this is of use to others and thanks for the support along the way.


fpx is supposed to be a bitmap format while a jpg is a vector-based graphic.
So, just the conversion by itself would greatly decrease the file size, and that’s before considering the possible jpg compression that might be set in your converter.

Glad to hear of your success,
IMO it should also have been possible to use an online service, typically online services don’t require anything specific on your client computer.


Not correct. JPG files are compressed raster image files, and not vector-based format.

You’re absolutely right.
Don’t know what I was thinking, of course SVG is the only commonly used vector based format and is well known for that.


Had a senior moment and then found this thread which I confess I had forgotten. My reason for revisiting is that the jpeg files I created a year ago had no metadata copied from the fpx files so I had no dates. I was hoping to be able to at least get these data. I had been working on a laptop and found the downloads for GraphicsMagick but could not resurrect and anyhow the app has been updated.
All good except that when I try running compile and check to ensure I had fpx plugin installed, it was not. I used the command

./compile --with-fpx

I guess that was not correct. Two questions, how to get the right and do I have to enable another library or is it done by the compilation?