Best calculator for KDE?

Is there a calculator like gcalctool for KDE? I want a calculator that shows the equation in progress. For example, gcalctool will show this as I type:

You obviously looked at KCalc and noticed it’s different from gcalctool. If it’s really a big deal to see the equation in progress, why don’t you use gcalctool? You can easily run GNOME apps under KDE…? I run Evolution, for example, without problems.

I just found an awesome solution! Speedcrunch
Check it out here: SpeedCrunch - fast and usable calculator

Abakus also looked interesting, but I didn’t try it yet (and might not get around to it given how well Speedcrunch works).

Just went over to my Ubuntu desktop and installed Qalculate. Wow! Both Speedcrunch and Qalculate are really impressive.

Qalculate! - the ultimate desktop calculator

Is Qalculate available in the standard openSUSE 11.2 repositories? I didn’t find it.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 4 days 9:13, 3 users, load average: 0.34, 0.19, 0.13
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Thank you! That’s a great link.
Which version do I install for openSUSE 11.2 64bit KDE? I’m thinking it must be this one:
but there are lots of very similar choices.

People seem to advise against using 1-click installs. So I added the repository manually. Should I leave it enabled? Change the priority?

Does the following look correct? I’m having a hard time seeing which repository Qalculate was installed from, based on this output.

me@thinkpad:~> sudo zypper in qalculate
root’s password:
Retrieving repository ‘Packman’ metadata [done]
Building repository ‘Packman’ cache [done]
Retrieving repository ‘Updates for openSUSE 11.2-0’ metadata [done]
Building repository ‘Updates for openSUSE 11.2-0’ cache [done]
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following NEW packages are going to be installed:
cln libqalculate4 qalculate

3 new packages to install.
Overall download size: 1.6 MiB. After the operation, additional 8.5 MiB will be
Continue? [y/n/?] (y): y
Retrieving package cln-1.3.1-56.1.x86_64 (1/3), 528.0 KiB (1.7 MiB unpacked)
Retrieving: cln-1.3.1-56.1.x86_64.rpm [done (266.8 KiB/s)]
Installing: cln-1.3.1-56.1 [done]
Retrieving package libqalculate4-0.9.6-1.1.x86_64 (2/3), 780.0 KiB (3.4 MiB unpacked)
Retrieving: libqalculate4-0.9.6-1.1.x86_64.rpm [done (15.2 KiB/s)]
Installing: libqalculate4-0.9.6-1.1 [done]
Retrieving package qalculate-0.9.6-1.1.x86_64 (3/3), 357.0 KiB (3.3 MiB unpacked)
Retrieving: qalculate-0.9.6-1.1.x86_64.rpm [done (60.8 KiB/s)]
Installing: qalculate-0.9.6-1.1 [done]

OK, this answers at least one of my questions:

me@thinkpad:~> zypper wp qalculate
Loading repository data…
Reading installed packages…
S | Name | Type | Version | Arch | Repository
i | qalculate | package | 0.9.6-1.1 | x86_64 | Community_openSUSE_11.2_KDE_43
v | qalculate | package | 0.9.6-1.1 | i586 | Community_openSUSE_11.2_KDE_43

Now that I have it installed, how do I run it? In Ubuntu when I installed Qalculate, the installer created a menu item. That didn’t happen in openSUSE. And trying to launch it from the command line doesn’t work either.

> qalculate
If ‘qalculate’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf qalculate
> cnf qalculate
qalculate: command not found

I didn’t expect it to be so difficult to get qalculate running on openSUSE…

Did I install the right package?
Does this version come with a GUI?
Why didn’t it create a menu item?
How do I launch the GUI?
Do I need to change/remove the repository settings now that I have installed it?
Sorry for all the questions, but I’d like to learn this stuff.

I have not been able to find qalculate-kde for openSUSE 11.2
Can anyone help? Thanks

(Will Fedora RPM’s work?

The qalculate package is just the command line version. It can be invoked by qalc from the CL

There is also a KDE4 plasmoid interface

Go to Yast-Software-Software Management and search for qalculate
after you add the KDE:KDE4/community repsoitory

You will find kde4-plasmoid-qalculate package

Once installed you will find it in the wigets library just add it to you activity (desktop)

I saw the plasmoid version, but that UI is very limited compared to the normal UI. I would really like to get the normal GUI like I have on Ubuntu.

May be a geeky option, but python command shell can be used as a calculator) If you have it opened in yakuake terminal, it is always easily accessible by F12 hotkey

I found the perfect calculator for my needs - qalculate (0.9.6, latest version).

The only problem is that I can’t find the KDE GUI version for openSUSE 11.2.

bump bump .

The problem is likely that qalculate-kde is a KDE3 frontend, and SuSE has dropped KDE3; for a better answer, you’d have to ask the packager.

“qalculate” from the build service seems to be just libqalculate; it doesn’t even use the qalculate-kde source.

You can try the FC RPMs, but my experience is that any package with nontrivial dependencies rarely works cross-distro because of differing package names (Requires: foo, or libfoo2?) and library versions.

Probably you’ll have to build from source. This will also either mean updating the libqalculate rpms to 0.9.7, or patching the config script to not use cln-config. And, of course, you’ll have to sort the build dependencies, which aren’t too bad.

Having just done this, I can at least tell you that in the end, it works. My version is missing the lavender tint and elegant font of the screenshots, but apart from a little comparative austerity, seems to work fine.

openSUSE has NOT DROPPED KDE3. It’s in the repos.

As said here, the GUI is the plasmoid.

KDE3 is no longer shipped with opensuse, per the release notes. The fact that there are KDE3 repositories on the build service is certainly true, though last I knew no one had been found to maintain them. In any event, I was only speculating as to why the KDE frontend supplied by the author of qalculate is not packaged-I am neither the author nor the packager, so I don’t know for certain.

The plasmoid you refer to:

  1. Does not have a fraction of the functionality of the KDE3 frontend
  2. Cannot be used outside of KDE4 (obviously)
  3. Is a plasmoid, which is itself horribly inconvenient (for me, anyway!)

I have no idea what OP’s requirements are; I was just trying out qalculate to see if I liked it better than speedcrunch, noticed that neither of the GUI frontends were packaged for 11.2, and found this thread. If a plasmoid with limited functionality is helpful, great: kde4-plasmoid-qalculate is available on the build service. If someone doesn’t find that useful, as I do not, then both qalculate-kde and qalculate-gtk build pretty cleanly from source on 11.2.

Thanks. My requirements seem the same as yours. The plasmoid doesn’t cut it.

In order for me to build from source, I’d need detailed step-by-step help because I tried already and got stuck.

I think I’m just going to switch to SpeedCrunch. So much time has gone by that I cannot remember the specific features of Qalculate that were so important to me at the time. If a problem comes up that reminds me why I must have Qalculate, I’ll come back and try to build from source.

I ended up making an RPM for qalculate-kde (and updating the libqalculate one in the process). I couldn’t think of the right place to put it, so it’s on mediafire:

Includes x86 RPMs and the SRPMs. If someone wants to put them someplace more orthodox, that’s great.

I didn’t do an RPM for qalculate-gtk because I didn’t like it as well as the KDE frontend.