Belkin F5D6050 no longer working on 11.3

I have a Belkin F5D6050 adapter, which (despite being only 11b) was working better than my 11n adapter on 11.1 [The 11n stopped working today after I ran an upgrade; I have got it working - in a fashion under 11.3 - see RTL819SU not working with ifup (needs ifup-dhcp first)]

I can’t connect to my AP. The significant output from dmesg appears to be:

[19991.327361] wlan1: authenticate with 1c:af:f7:26:01:bc (try 1)
[19991.524037] wlan1: authenticate with 1c:af:f7:26:01:bc (try 2)
[19991.724034] wlan1: authenticate with 1c:af:f7:26:01:bc (try 3)
[19991.924031] wlan1: authentication with 1c:af:f7:26:01:bc timed out

FYI the info from

Also I am using the same configuration (and AP) as my 11n adapter which does work:

diff ifcfg-wlan*
< NAME='RTL8191S WLAN Adapter'
> NAME='F5D6050 802.11b Adapter'

It may be a bit academic, but is there any reason why this particular adaptor should have stopped working (especially as it used to run Out the Box without having to download any extras)?

Some other useful bits:

iwlist scan:

wlan1     Scan completed :
          Cell 01 - Address: 1C:AF:F7:26:01:BC
                    Frequency:2.432 GHz (Channel 5)
                    Quality=1/100  Signal level=1/100  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Extra: Last beacon: 336ms ago
                    IE: Unknown: 00083438533431385442
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030105
                    IE: Unknown: 2A0100
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1AEE1117FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: 3D1605050700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4307000000
                    IE: Unknown: 0706474220010D10
                    IE: Unknown: DD1E00904C33EE1117FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: DD1A00904C3405050700000000000000000000000000000000000000


Bus 003 Device 012: ID 0d5c:a002 Belkin F5D6050 802.11b Adapter

(So it does, basically work - it just can’t connect to the AP)

From what I can see, this NIC uses an Atmel chipset which doesn’t seem to be very well supported.
Are you using network manager to configure it? Do you have the firmware installed?
Does this command show any output?

dmesg |grep firmware

If so, install the firmware. If not, carry on.

zypper install atmel-firmware

(I believe this is the package. If not, use yast to search for atmel)

Yes, thanks, firmware is all installed (I don’t think iwlist would work without it?). I’ve had the adapter for years on various distros (including an earlier version of SuSE - maybe 6 or 7?) As I said it all worked fine for 11.1. And I’ve also tried Network Manager as well as ifup. Get the same error for both.

Now, I went straight from 11.1 to 11.3; I’ve run a check on 11.2 and get the same issue. I read on another thread some suspicions about legacy (hmm - I remember when it was cutting edge) adapters not being supported so well. What I suspect I need to do is downgrade my kernel (or upgrade my kernel for 11.1) or (sigh) just throw it away!

I think I’ll be taking the latter option!