BD-R/BD-R DL burning seems problematic on OpenSUSE 13.2 / K3b

Unfortunately I’ve found out BD-R/BD-R DL burning is buggy with K3b, at least when used with the default growisofs backend.
I have seen the following 3 bugs:

  1. When trying to burn image file to BD-R/BD-R DL disc, k3b does not recognize the empty medium and thus refuses to burn. I’m not sure if it happens with DVD or not.

  2. Growisofs fails burning BD-R DL discs at 50%. It won’t begin to burn the second layer. Probably the same bug as here:

  3. Growisofs fails BD-R/BD-R DL at the finalizing stage. Data might be or might not be okay:

I haven’t seen #3 in the K3b GUI because I used growisofs from the command line when I encountered that bug. There is a workaround for that bug here: (haven’t tried that myself, yet anyway).

The process which I’m using now to burn BD-R/BD-R DL discs is to make the image using k3b (I like the user interface) and burn it with Xfburn. Xfburn uses libburn, not growisofs. Another option might be to install cdrecord (removing wodim/cd-record-compat is recommended with BD-R use I read) and changing K3b to use that instead of growisofs. I haven’t tried the cdrecord workaround because I like to first make images then burn… but because #1 I cannot do that in K3b.

The growisofs bug seems to have been around for a long time. Should I post it at the OpenSUSE bugzilla?
Not that I expect it to be fixed anytime soon… Seems BD-R burning isn’t really well tested with any software. Hardware is probably rare as people is just using ext HD’s and flash nowadays. :slight_smile:

Edit. Just for clarification, these are just data BD’s I’m burning, no video stuff. Using external Samsung SE-506CB drive.

I’ll take the last part back. I’ve had too many coasters burning the images using Xfburn and xorriso too. It is strange that none of the Linux native tools are really reliable.

Currently I use in Wine (works perfectly without any tricks - the developer of this software even made some fixes for Wine usage) for burning the images to disc. And with a 100% success rate so far!

I can’t really afford to waste anymore of those expensive discs so I’ll stick with what works. Just a tip for anyone wrestling with the same problem :wink:

I’ve never burned BRD’s but I’ve burn hundreds of DVD’s/CD’s on multiple OS’s and in my experience most of the issues I had wore hardware related newer software/OS. I’ve had 2 DVD burners die on me still don’t know why.
Not all disks are created equal, you should check and see if there is a bios update for your burner and if your burner supports those disks (see their media code).
If your hardware supports the media the burning app only sends commands to it what to do, if you don’t force large speeds it doesn’t really matter what app you use for burning they all should do the same thing.

DVD burners sell for under $30 assume at least 50% for profit, packaging, distribution, etc. making it a >$15 cost to make. Exactly how long do you think a complex mechanical device is going to last that cost less then $15 to make??? The amazing thing is that they work at all!!! :open_mouth:

now they’re around $30, when I got my first burner it was around $200.

I understand entropy but it still bugs me when a well taken care of peace of hardware dies for no reason what so ever.
except old age lol

I’ve burned lots of CD’s and DVD’s as well. And in Linux OS’s as well since I started my Linux journey on Mandrake-something. And never really had any problem with them. CD/DVD burning just works. Of course there’s crappy drives and crappy mediums but that’s just the nature of the technology I guess.

Thing is, bluray is a bit different, because optical discs are not used that much any more. People stream, use cloud, NAS, usb storage, whatever. Thus it seems the software is not really that well tested. The 3 issues numbered in my first post are most likely not drive/media problems as you will find out by checking the links.

I’ve had some burns go bad in the middle of the writing, when there is no layer changing etc, those might be drive/media issues. Or power issues, as the drive I have draws it’s power only from the USB port.

I have LG Blu-ray burner BH12LS30, with latest firmware, and I’ve tried to burn several BD50 ISO images with K3b without success. Application recognizes empty media but when I open ‘Burn image’ dialog and show it a path to a BD50 ISO image it says ‘Seems not to be a usable image’. I’ve tried changing ‘Image type’ but it doesn’t seems to matter.

I’m using openSUSE 13.2, KDE 4.14.4 and latest K3b from Packman repo. I also tried using OSS repo version and tried many different BD50 ISO images but it’s always the same: ‘Seems not to be a usable image’.

Finally, I’ve rebooted to WinXP and burned those images using ImgBurn, without any troubles.

I had heard that ImgBurn works under Wine so I’ve installed it under openSUSE, but I’ve also installed Silicon from Packman repo, and I’m seriously considering buying Nero for Linux v4.0.0 ($19.99 :dont-know:).

I like K3b very much and I had been using it since ever, but problem with BD50 image burning is really a showstopper for me. I didn’t yet tried ImgBurn under Wine, nor Silicon app, and I’m kind of reluctant to do so because BD50 coasters are not so cheap.

Any ideas what might to be the problem?

I have constantly had BD-R disks fail at 99%. Even when the disk shows the proper directory listing, the files contain garbage data.

I have had better luck with BD-RE, but the extra cost makes this option nonviable.

This bug has existed since at least 11.4.

However, it seems that there aren’t enough people trying to burn blu-ray for this bug to have received attention.