bash up arrow key for history not working

After this last update the up arrow key for bash history in konsole stopped working.
My history file is there and looks ok, ownership is correct and new entries are added, but the uparrow key doesnt go back through previous history.
Any ideas?

Does the history work any other way, e.g. Ctrl+r (plus some typing of
things in your history) or running the ‘history’ command to list stuff?

Also, exactly which update, of what software, on which version? Knowing
your bash version might be useful:

bash -version

rpm -qi bash

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

history command lists history ok
Ctrl-R works ok too

bash -version
GNU bash, version 5.0.7(1)-release (x86_64-suse-linux-gnu)

rpm -qi bash
Name : bash
Version : 5.0
Release : 7.1
Architecture: x86_64
Install Date: Tue 30 Apr 2019 01:11:38 AM PDT
Group : System/Shells
Size : 1156145
License : GPL-3.0-or-later
Signature : RSA/SHA256, Sun 28 Apr 2019 11:10:43 AM PDT, Key ID b88b2fd43dbdc284
Source RPM : bash-5.0-7.1.src.rpm
Build Date : Sun 28 Apr 2019 11:10:22 AM PDT
Build Host : lamb04
Relocations : (not relocatable)
Packager :
Vendor : openSUSE
Summary : The GNU Bourne-Again Shell

Updated my TW and ran tests.

I cannot replicate your problem, my “up arrow” displays every historical command, and in fact I see a new feature… It seems to be displaying commands from prior logged in sessions, it’s not limited to the commands I ran only during the current console session.


My arrow keys work fine in kate and here in editing this post using firefox but not in the konsole window and not in vim either.
In vim down arrow works but not up arrow and left and right arrow keys work fine in vim and konsole too.

Try an Xterm window.
Execute a couple commands and then see if you can “up arrow” to display your previous commands.


I rebooted (one of several today in fact) to run level 3 and things work normally there
yeh, xterm is fine too (although the colors suck) I just started xterm from konsole, just typed ‘xterm’ , is that the correct way to run it (I never have used it)
So, it seems like its some kind of config issue that is common to vim and konsole

I hand edited /usr/share/konsole/Root\ Shell.profile and changed the ColorScheme to Linux.
I didnt expect it to do anything but change the colors but lo and behold the up arrow key now works as it should
This last upgrade or something at that time changed the ColorScheme because I have always had it set to Linux in both user and root shells.
I was wondering why after the reboot following the TW update the prompt color was so dim - now i know (Breeze)

You can launch xterm that way, or select it as a “System” menu option from your application launcher.

Hard to speculate what may be different on your machine, you might try “force re-instaling” Konsole. Your Vim problem may be because you’re running it within Konsole, I image vim should work without problems if you ran that in an xterm window.

zypper in -f konsole


Was ‘zypper dup’ used to update the system?

As of an hour ago I had this problem too, and it appeared when using Konsole in a new O/S account I had to create for myself (that’s another story). Using the up-arrow key cleared the Konsole window and created a new tab in an annoying and fairly useless tab-bar at the bottom of the screen, but there was no command recall. It’s as though the tab-bar was intended to replace up-arrow command recall.

The ‘history’ command worked and CTRL-r command-search worked. And the up-arrow command recall function worked normally in the existing root account.

Taking a clue from your experience I deleted my default profile from ~/.local/share/konsole and selected a colour scheme from the offered defaults, whereupon normal up-arrow operation returned. Oddly, I’m pretty sure “Linux colours” didn’t seem to be available previously. Also, I didn’t change the default font of “Courier 10 Pitch” or its size; previously I’d selected a custom font.

It seems like a bug to me…

David L.