banshee cant play m4a files

Did a recent upgrade of KDE desktop to 4.3.1.

Everything seemed to go OK, but one effect was I cant play .m4a files in banshee. Have looked at all the previous posts on this topic but with no effect.

Multi-media and Restricted Format Installation Guide - openSUSE Forums
Check your multimedia problem in ten steps - openSUSE Forums

Any ideas check that any one has would be welcomed.

Here’s what I have installed;

@babylon:~> rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort

and here is the Packman repo confirmations

@babylon:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly → PackMan :: Startseite → → → → PackMan :: Startseite → PackMan :: Startseite → PackMan :: Startseite → PackMan :: Startseite → PackMan :: Startseite

Banshee version:
@babylon:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ banshee-1-1.4.3-3.1 banshee-1-backend-engine-gstreamer-1.4.3-3.1 banshee-1-backend-platform-unix-1.4.3-3.1 banshee-1-extensions-default-1.4.3-3.1 banshee-1-lang-1.4.3-3.1
banshee-1-1.4.3-3.1-x86_64 → openSUSE Build Service
banshee-1-backend-engine-gstreamer-1.4.3-3.1-x86_64 → openSUSE Build Service
banshee-1-backend-platform-unix-1.4.3-3.1-x86_64 → openSUSE Build Service
banshee-1-extensions-default-1.4.3-3.1-x86_64 → openSUSE Build Service
banshee-1-lang-1.4.3-3.1-x86_64 → openSUSE Build Service

Since you have kde, try first to see that totem or amarok plays them.
Totem should give an error.
Try adding libmp4 from packman.

Nice one, it was a problem with the libmp4 version…wasnt from Packman repo. Re-installed and all is now working. Cheers Whych.

Check the other codecs as well. You’re/you were in a mix of Videolan and Packman packages.

As Knurpht says, you only need the libdvdcss package from vlc.
Install it, then disable the vlc repo.
In general, get everything else from packman unless there is a compelling reason not to. When done, disable the repo again, keeping only packman.

As I said all sorted, only had libdvdcss from vlc and it was disabled. Thanks again for the help