Bad shim

Good morning everybody!
I had a problem with today’s update, snapshot 20211110…
The screen went black, and won’t start with the new kernel, 5.14.14-2, when I try it says the shim is bad…
Only the kernel has not been updated, and everything works fine with kernel 5.14.14-1.
Should I worry and fix this?
If yes how do I do it?
Or, does it fix itself with the next kernel update?

There was no change to “shim” in that update. I’m not having any issue there.

Do you have Leap on the same computer? Does your “shim” come from Leap or from Tumbleweed?

Thanks for replying @nickert.

So that’s why what I did worked…
I only have Tumbleweed… I opened a terminal window, looked for kernel version installed on upgrade with "sudo zypper se -si ‘kernel*’ "… Removed kernel with “sudo zypper rm kernel-default-5.14. 14-2.1”… I restarted the machine…
I entered the terminal again and gave a “sudo zypper dup”…
Zypper installed the kernel again, and this time it worked…

I’m not sure why that worked. Or, more accurately, I’m not sure why it did not work before that.

Perhaps the bootloader menu was not properly updated, but I’m not sure why that would fail.

I guess we can leave it as an unexplained mystery.

When I rebooted TW after today’s update I was prompted to enroll/update the MOK (or some such message) by pressing any key. I did so without any issue of the reboot after the update.

That’s fine with me… Here in my land, we live well with inexplicable mysteries.