Automounting Windows 10 NTFS Drive at Bootup for Read/Write

I have a dual boot system, Leap 42.3 with KDE and Windows 10. Each OS on separate physical drive, use GRUB. In Dolphin, I can mount my Windows drive by clicking the drive listing and entering my root password. The dialog identifies my Windows drive as WD10EACS-00D (/dev/sdc4). I would like to set it up to automount at boot. What is the easiest way to do this? Label for the drive is Windows and location is /run/media/username/Windows. Based on some other posts I’ve seen on this topic, I’m guessing I need to manually edit my fstab file. I have pasted mine below. Thanks for help.

UUID=e9018ea8-f358-4981-9eec-b16cb1140cd1 swap swap defaults 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 / btrfs defaults 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /boot/grub2/i386-pc btrfs subvol=@/boot/grub2/i386-pc 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /boot/grub2/x86_64-efi btrfs subvol=@/boot/grub2/x86_64-efi 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /opt btrfs subvol=@/opt 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /srv btrfs subvol=@/srv 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /tmp btrfs subvol=@/tmp 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /usr/local btrfs subvol=@/usr/local 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/cache btrfs subvol=@/var/cache 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/crash btrfs subvol=@/var/crash 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/libvirt/images btrfs subvol=@/var/lib/libvirt/images 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/machines btrfs subvol=@/var/lib/machines 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/mailman btrfs subvol=@/var/lib/mailman 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/mariadb btrfs subvol=@/var/lib/mariadb 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/mysql btrfs subvol=@/var/lib/mysql 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/named btrfs subvol=@/var/lib/named 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/lib/pgsql btrfs subvol=@/var/lib/pgsql 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/log btrfs subvol=@/var/log 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/opt btrfs subvol=@/var/opt 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/spool btrfs subvol=@/var/spool 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /var/tmp btrfs subvol=@/var/tmp 0 0
UUID=81e610b7-8125-4fac-a274-f56d612574e9 /.snapshots btrfs subvol=@/.snapshots 0 0
UUID=F604-2228 /boot/efi vfat umask=0002,utf8=true 0 0
UUID=7f61179e-fff2-4412-96cb-5b4ca6d2bb81 /home xfs defaults 1 2

You can do so using YaST > Sustem > Partitioning. Take care, see that the file system is not “formatted”.

Oh, and my advice would be to use a different mount point. All in /run/… is reserved for Desktop mounts. E.g. in /mnt/ or somewhere in /home/username/. Some prefer yo mount in /mnt/Windows and then let the user username create a symlink to it from his/her home directory.

It would not be bad to first look at how it is mounted at the moment:

mount | grep Windows

When then YaST has created the fstab entry, you can add parameters that you may need yourself. Important are uid=value, gid=value and umask=value.

dontosaw@linux:~> mount | grep Windows
/dev/sda4 on /run/media/dontosaw/Windows type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

Thanks for the reply hcw. I tried to do what you described using the YAST partitioning utility and failed. The results of mount | grep Windows did not change after my attempt. Unfortunately, I’m still pretty ignorant to the ways of Linux. Don’t really understand the concept of a mount point. When I mount the drive now, I am prompted for and must enter my Windows login password, so I know that will have to be entered into fstab for this to work. I’m going to read up on “mount point” to try to get a basic understanding of the concept. Thanks again for your help.


I found the info at to be helpful. :slight_smile:

Well, we have:,_filesystems,_mount_points

From you first post I did not understand that you miss the basic understanding of the one and only directory tree of a running Unix/Linux system and how to create that by mounting file systems in that tree. I only thought you missed some details on how to “Automounting Windows 10 NTFS Drive at Bootup for Read/Write”.

BTW, I am rather flabbergasted by you saying

When I mount the drive now, I am prompted for and must enter my Windows login password,

I have no idea how that can be achieved. The Linux system will have no idea about your Windows password on this (using multi boot I assume) or on any other system.

Could it ve that the file system is encrypted and that the password to decrypt is asked for? But as I have no idea about Windows, this is only a wild guess. In any case I never heard or experienced that a password is asked for when a NTFS file system is mounted in Linux.

Maybe he was asked for the root password. I doubt it would be a Windows password. Also as a general rule always turn off fast boot also there may be problems if Dynamic disks are used in Windows.

If you want the partition to mount at boot it must be added to the /etc/fstab. Easiest way is via Yast partition management. By default this mounts it with root ownership (ie access) replace default with user parameter if want normal users to have access.

Note that Windows miss labels things all the time partitions are not Drives!!! But MS insists on calling partitions drives. I understand there is some historic justification but MS has made no effort to move forward.

Those that once put floppy disks in and out of floppy drives will have influence in eternity :sarcastic:

Henk and gogalthorp,
Thanks for the info. I use the same login password for Windows and openSuse, so hence the confusion regarding the password. When I installed openSuse I disconnected my Windows hard drive for “safety”. Then after install, reconnected it and used the YAST Boot Loader utility to find Windows and set up GRUB.

Let’s face it, MS does all kinds of things to promote user ignorance (i.e. hiding file extensions for know file types be default).

So, am I mounting the Windows partition on the Windows drive? Is that the right way to describe it?

My fstab file has all the drives identified by UUID, so I need to get that for my Windows drive (physical hard drive) first. The current mount point seems to work fine, so I don’t see a reason to change it, unless that is needed to make it accessible without root password. Just need to insert a line into fstab that will be read at bootup and mount the drive. I would like it to be accessible with my user account, so I don’t have to enter my root password. I’m not interested in executing anything on the Windows partition, but do want to read/write.


Of course I aborted!

When using openSUSE (or any Linux) better forget everyting about Windows. And certainly do not mix up things you do one one with things you do on the other.

No idea about this. No Windows knowledge.

You are mounting a partition with a NTFS file system on a mountpoint. A mountpoint is a (at the moment of the mounting existing) directory on the system.

That NTFS file system seems to be a full bootable Windows system (but that is from your information and has no meaning to the mounting or the Linux system).

There is no NEED to have the UUID there. You can use also use e.g. LABEL (when your file system has a label), or use the device file directly (/dev/sda4).
But it is not difficult to find that UUID:

ls -l /dev/disk/by-uuid | grep sda4

And use the following options in your entry:

rw,nosuid,nodev,relatime,user_id=<here your uid>,group_id=<here your gid>

and replace <here your uid> with your Userid (probably 1000) and <here your gid> with your default groupid (probably 100).

Nice output, but what did you do to get it?

I got it when I attempted to use YAST Partitioner to set up the automount. I think trying to use this might be less safe than just editing fstab directly. I have attached an image of my partitions as shown in YAST Partitioner. The partition with the Widows label is the one. What would I enter into fstab to have the partition mounted at bootup? If you think I should use the graphical interface, I can try again and post screenshots of what I’m selecting.



Are you sure that the NTFS partition does not have fast boot on. That leaves NTFS unmountable since Windows does not close it down full when it exits

Yes, I am sure. I went into UEFI setup and fast boot option is disabled. Furthermore, the Windows disk is set up as a standard disk (not dynamic). In any case, I can and do mount the disk in Linux. I just would like to set it up to be automatic if that is easily doable.


Fast boot in Windows not the fast boot in in UEFI, Same name but different things:O

While you are correct that fast boot in Windows will create a problem, that is not the case here, because he can mount it. The problem is he is until now not able to create a fstab entry that does what he wants.

Precisely. I don’t want to attempt to edit fstab without being pretty confident I won’t render my installation unbootable.

I wonder if you have now created an fstab entry or not. IMHO there is advice enough above.

And when in doubt, post it here for advice.

And you can always make it and then check if you can mount using it before you go for the ultimate test with a boot.

I should be able to figure it out, combining what I have learned here with what I have read elsewhere.

The basic structure is the Device ID, mount point, file system type, options, dump, pass.

for device ID I can use the device name, /dev/sda4. I have created the mount point /home/dontosaw/Windows. The file system will be NTFS. Options will be rw? Not sure about dump and pass.

/dev/sda4 /home/dontosaw/Windows NTFS rw 0 1

What do the last two numbers mean? What should I use?


It is not NTFS, but ntfs!!!

And you need certainly more options. Look at post #3 above!
In any case user_id and group_id (but not with 0, which is root, but with the uid of dontosaw and the gid of users)…
I would also add nosuid, nodev, maybe relatime.

And for those numbers you can use 0 0.