Automount Encrypted drive

Hi,
I have Leap 15.3 and 3 HDD witch are encrypted with yast.
At Boot they are automaticly mounted, i dont whant that because i need to tip Passphrase every reboot, i want it to mount manualy.
I have tried that to configure in yast but dont Work.

Do you have any ideas what can i do?

Look in “/etc/fstab” and “/etc/crypttab”

There should be entries in both places for this disk (or these disks). You need to add “noauto” to the options for these in both files. And you may then need to run “mkinitrd”.

If you are not sure what to change, then you need to give more detailed information so that people can tell you exactly what needs changing.

I put noauto in fstab (defaults,noauto)
I put noauto in crypttab with no komma
I runned “mkinitrd”
but it doesent work, only the UI passpharse have changed to be like Commandline.

Any Tips?

A hint for usage of these forums. Please do post what you have on your computer or what your system tells you. As an example, post the complete

cat /etc/fstab

and not some tiny bit of it where others may hope the rest is correct.

Also, for every new member:

There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

Apart from the fact that we can not see what you now exactly have (see my post above, this looks not OK.

There should not be any any ( and ) in /etc/fstab.

I am not sure if it is a good idea to have defaults, which includes auto, together with noauto. I do not read in man fstab what prevails.

I find my mistake in crypttab

*volume-name encrypted-device key-file options
*

It was nothing on 3rd position, now i have given:

*volume-name encrypted-device none noauto
*

And that worked.

Next question, how can i mount it now?

I am afraid you still missed how to post your computer facts here. Please do not alter the contents of what you copy/paste from the terminal window into a post between CODE tags. The fact that you use CODE tags signals that this is the unabreved, unaltered text as you see it. The people trying to help you are not clairvoyant, and this is the best alternative way to let them look over your shoulder.

Only when you have some sensitive information like password, you may replace term with e…g. ***, but hen please explain that. Else people will tel you that *** is not a good password.

When you, as system manager, created an entry in /etc/fstab with noauto, you, as system manager (thus as root) can mount it with the mount command. Is that a surprise? :wink:

Another possibility is e.g. to have it mounted by an automounter (either the classical one using /etc/auto.master or systemd.automount) on demand.

**erlangen:~ #** tail -1 /etc/fstab  
UUID=80ddb29e-4b0d-4d6c-a909-adad75f01171  /Encrypt                btrfs  user,noauto                   0  0 
**erlangen:~ #**

See also: Encrypting partitions and files | Security and Hardening Guide | openSUSE Leap 15.5