Automatic Login doesn't work

I configured my user to automatically login when I installed OpenSUSE. I also installed it with the minimal X window interface, which installed IceWM. This will be a kiosk machine with only a browser running in full screen, so I’m fine with that. However, whenever I boot I see the minimal login screen that it installed. I checked /etc/sysconfig/displaymanager, and DISPLAYMANAGER_AUTOLOGIN=“kiosk” is set properly.

OpenSUSE Leap 42.1.20160217 x86_64


Sounds like xdm, which does not support auto-login.

Install another display/login manager and set DISPLAYMANAGER accordingly, lightdm should be lightweight enough, as the name suggests…

It was XDM. I opted for LXDE because it had fewer dependencies. I had to add a line to /etc/lxdm/lxdm.conf for the autologin, but that was no big deal and it’s now working perfectly. Thanks for your help!

Just be aware that lxdm will be dropped from the distribution soon, and is to be replaced by lightdm:

Doesn’t affect Leap 42.1 of course, but it may be missing in future releases (no idea if it will be removed from 42.2 already or not).

In any case, lightdm should respect the DISPLAYMANAGER_AUTOLOGIN setting in /etc/sysconfig/displaymanager AFAIK.

Thanks for the heads up! I’ll switch over to LightDM. LXDM just seemed light(er)weight than LightDM.