Automatic but not needed screen brightness adjustments

Hello,

I’ve just changed my GPU to an AMD one, and it has started changing the brightness of my monitor without any reason. I have no ambient light sensor, and it’s a desktop (not a laptop with a battery), so I’m unable to find a reason because of what Plasma is deciding to do this.

How can I disable the backlight control?

That sounds like night light adjustment. Disable it in
Systemsettings → Colors & Themes → Night light

I’ve already disabled that.

Hello,
As per my knowledge

  1. Check AMD Settings: Open AMD Radeon Settings and look for any options related to brightness or dynamic contrast. Disable any such features.
  2. Adjust Power Settings: In your system’s power settings, ensure that no automatic brightness adjustments are enabled.
  3. Disable Adaptive Brightness: Go to your display settings and ensure that adaptive brightness is turned off.
  4. Update Drivers: Ensure that your GPU drivers are up-to-date, as newer drivers might fix this issue.
  5. BIOS/UEFI Settings: Check your BIOS/UEFI settings for any brightness control options and disable them.
    I hope this will help you,
    Thank you

Thank you for your reply.

I had a check in the energy settings to dim the screen after some time. I hope that’s it.

By the way, this may sound a little silly, but how can I get into AMD Radeon Settings? Is any package needed? I’m not precisely eager to install the PRO driver supplied by AMD because of this.