Autologin without password even if it's disabled in settings panel

Hello. I have occassions with my admin’s account (has password) when it autologins even after I disabled it. Last time it occurs after I enter the hibernation and reboot the desktop (I haven’t a key on my keyboard for waking up so sometimes I just reboot it). Also I have 2 accounts on that system (admin and user) so it is shouldn’t occurs.

Moderator: sorry, move this post to login forum part, please.

Will be moved and is CLOSED for the moment.

Moved from Applications and open again.

It is not quite clear to me what you are doing and experiencing.

Thus a few remarks/questions.

Not awakening a hibernated system, but directly booting it, gives about the same effect as interrupting the power. While hardware and software components are often designed to survive such a disaster as good ad possible, the change that something goes wrong is certainly not nil.

You say you have to “accounts, admin and user”. Does this mean that you have created two users (at installation or later) besides user "“root”? and that they have user names “admin” and “user”? Rather confusing names.
Or do you mean with the user “admin” in fact the user “root” (something I sometimes see with people having a Microsoft background)?

Do you have automatic graphical login for one of those users? When yes, which one?

BTW, it can not be true that you have two “accounts” only (that is when you mean what in Unix/Linux are called “users”). Look in /etc/passwd and see how many users are defined there.

ok, I have 2 accounts that I created: psijic - admin (created at the installation of openSUSE), user - not admin. Also there was root by default in all linuxes.
in the KDE’s settings panel I turn off autologin. So, maybe it’s a bug that it didn’t worked and I should configure it via a terminal. But what I really have - it’s that my password-protected account with administrator rights can be autologin frequently.

Please, what is an “account with administrator rights”?

As far as I know there is but one superuser and that is the one with userid 0 (and in all cases I know of, it has user name: root).

Maybe it would be illuminating if you post the contents of /etc/passwd, then we can see what you have:

cat /etc/passwd

“Automatic login” is something that is configured in the Display Manager. It’s first configuration is done during installation (a checkbox in the screen about user creation).
It depends on the DM used where and how to configure it.

How did you disable it?

As far as I know, in openSUSE, autologin is set in the file “/etc/sysconfig/displaymanager”

I have the line:

DISPLAYMANAGER_AUTOLOGIN=""

which is what disables it.

You can use
Yast /etc/sysconfig editor
to modify this.

So, the problem is that autologin option always resets after reboot.
I uncheck it this way (they have same problem).

  1. Go to KDE settings
  2. Go the “Login Screen” menu.
  3. Go the Convenience tab.
  4. Enable the “Auto-Login” checkbox.

I reboot and it’s enabled again.
Maybe it’s an another KDE bug. I can set it another way but this situation was described 2.5 years ago in that forum. So long.
And on Arch-based distros with KDE (I used Antergos, Manjaro for a couple of days before) I didn’t found that occasion.

You need to configure Auto-login in YaST->Security and Users->User and Group Management. (click on “Expert Options” and choose “Login Settings”)

Or set DISPLAYMANAGER_AUTOLOGIN=“” in /etc/sysconfig/displaymanager.

As has been written already.

Maybe it’s an another KDE bug.

No.
It’s an openSUSE specific change (and nothing new, that’s how it is since years). The point is to have this configuration centralized for all displaymanagers shipped in openSUSE.

About 30 hours ago @nrickert advised you about how it probably can be done.
Did you read that? And when yes, did you try that? And when yes, did it help?

I also note that I asked you several things like the first sentence there with a ? at the end and to post your /etc/passwd. It looks as if you haven’t read that either. In any case, I see no answers, nor an explanation why you do not answer.

Please note that people here put effort and time (their spare time) in trying to help you. So please read those posts carefully and try to answer them. Else the whole discussion will become very one-sided and people will stop reading the thread.

Hey. I read your message today, didn’t understand it clearly and next I read @nrickert’s message where he asks

How did you disable it?
and answered to it in the next message describing my actions in OS’s GUI settings. I know that I can configure anything in console but the problem is in default configuration manager that works in another distros well but here it does something unspecified. The goal is not to configure autologin by any price but to understand correctness of system settings’ GUI’s behaviour and to configure it properly for the right user experience.

Next time I read messages after mine, configure YaST’s users, check in console that it’s really that now:

DISPLAYMANAGER_AUTOLOGIN=“” in /etc/sysconfig/displaymanager.

and wrote answer to you.
Thank you all for your help but sorry, I don’t understand what problem is?

In openSUSE Yast is the central place to set system settings for all Desktops. Don’t confuse SYSTEM with Desktop All SYSTEM settings require root access. You don’t generally need to edit a config files just go to Yast

Then will try to repeat what my questions are:

1.
You say you have two users entered in the system, with user names “psijic” and “user”. You say that psijic is an “admin account”. My question is: what is an admin account? I never heard of that. So please answer the question and show what users you have by posting

cat /etc/passwd

2.
You say that you had an automatic login for one of those users (not clear which one), but disabled it again. We want to know what the situation, please show

grep AUTO /etc/sysconfig/displaymanager

3.
You say you killed your system by hibernating it first and then booting it (instead of waking up). After that something strange happens: one of the users is automatically loged in. Please explain: which user, and was this the user that was loged in when you hibernated?

Please read the above carefully and answer them one by one. And for the computer output wanted: please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

PS. These are the openSUSE forums. People here are most probably not going to explain to you how you did things in Ubuntu or other distributions. They will try to help you how to live with openSUSE.

  1. User “psijic” with admin rights (sudoer)

**cat /etc/passwd**

root:x:0:0:root:/root:/bin/bash
psijic:x:1000:100:Psijic:/home/psijic:/bin/bash 
user:x:1001:100:User:/home/user:/bin/bash
...

  1. I used previous advice to configure users/autologin in YaST and all is ok now. But I’m little dissapointed with a KDE integration in this case.
grep AUTO /etc/sysconfig/displaymanager
DISPLAYMANAGER_**AUTO**LOGIN=""
# DISPLAYMANAGER_**AUTO**LOGIN is empty.

  1. My default user - Psijic was in autologin before.

Sorry, I use tags CODE, QOTE, Link often. Is it hard to read my messages?

Thus you seem to have changed the soduers configuration from the default, giving psijic special rights. That is not something most openSUSE users will do. Whenever you think that it maybe of the slightest interest to the problem you want solved, please explain such things in detail! None of us is clairvoyant, thus we can not guess what you mean with “admin rights” (and it is still a riddle).

Thus you have no autologin anymore.
As your complaint was an autologin under certain circumstances, the normal step would now be: repeat those to see what happens. But i would not encourage you to repeat the Hibernate > Reboot sequence ever again, I assume you will now leave things as they are.

KDE is “only” a desktop environment, a bunch of closely related application programs to be run by a normal user. Autologin is a system function. Thus you should understand that autologin is to be configured on the system level, not on the desktop level. Before a GUI login is started (auto or not) it is not even known which desktop is going to be run.

That is clear now. Thanks for al the information provided now.

I think we can say now this is maybe not Solved, but that we are at the end of the discussion. In any case try to avoid the “pull the powercord” approach" by Hibernate > Reboot.

One other point for the future:
I posted above:

please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

But I am missing the prompts. Also you removed some of the output. That is not forbidden, but please mention that. People reading the CODE texts trust that you show all, unchanged and unabridged. They want to see what you see and not what you think is important to show. They want be able to draw their own conclusions and not being influenced by the conclusion you made. After all your conclusions maybe wrong, because you have the problem.
E.g. on my system:

henk@boven:~> grep AUTO /etc/sysconfig/displaymanager
DISPLAYMANAGER_AUTOLOGIN=""
# DISPLAYMANAGER_AUTOLOGIN is empty.
henk@boven:~>