Autokey and python-sip api mismatch

I am trying to get Autokey installed on Leap 15, but not having any luck. There are two repos for Leap 15 with Autokey. From the dnh repo I get this error (after also installing python-kde4 from wolfi323 repo).

**Traceback (most recent call last):**
**  File "/usr/bin/autokey-qt", line 20, in <module>**
**    from autokey.qtapp import Application**
**  File "/usr/lib/python2.7/site-packages/autokey/", line 22, in <module>**
**    from PyKDE4.kdecore import KCmdLineArgs, KCmdLineOptions, KAboutData, ki18n, i18n**
**RuntimeError: the sip module implements API v12.0 to v12.3 but the PyKDE4.kdecore module requires API v12.4**

As far as I understand the python-sip api version shipped with Leap 15 is too old. However newer versions, available from the various Qt5 repos, and the community repos (which require updating various other qt5 packages), end up requiring the deinstallation of autokey.

Installing Autokey from the Simmphonie:Python repo requires also adding a Frameworks 5 and KDE:Qt5 repo and updates a lot of packages, which end up breaking plasma since kwin crashes constantly.

I tried installing from source but ran into the same problem as above.

So my questions are : how can I install autokey? More specifically how can I install a more recent sip api version that does not break plasma or autokey? Is this just a matter of waiting for an update to the python-sip package (I notice also that there is no official python-kde4 package for Leap 15, but there is one for Tumbleweed)? It seems the only alternative is to use an updated version of plasma and frameworks, but that requires also using the KDE:Qt5 repo which is not recommended for Leap 15, and which does indeed make the system unstable. Perhaps switch all packages to versions in those repos would make things more stable?

I use autokey to map keyboard shortcuts for moving the cursor around (e.g. Alt+k to move the cursor right etc), to use in applications that don’t support alternatives to the left or right button etc. If anyone knows of an alternative program that can do this globally I would be happy to use that instead of autokey. I tried xbindkeys a while back but had no luck with it (or was too incompetent to figure it out).

On a test machine (I wouldn’t risk on a machine I value),
Since it’s a minor version upgrade requirement,
You could go to that line that’s causing the error, modify to loosen up the restriction and see if you can build something that works.

That <might> work for now,
And of course I don’t know exactly the consequences (You could be disabling new features and even security fixes).

Even if this works,
You will still want to submit a bug specific to whatever sip phone app you’re trying to build/install to


Thanks, I can certainly submit a bug (but I am not trying to build a phone app, just trying to get autokey working), but the rest is way beyond me.

As an alternative I tried installing the latest kde. Autokey works, but unfortunately kmail does not, see

Please correct me if I am wrong, but the mismatch seems to be between the python-sip and python-kde4 packages, is this something that might be fixed soon or am I basically out of luck

Someone has to go through the usual evaluation of identifying the problem exactly, then evaluating the possible consequences of any solution.
I’d expect that the usual “It Depends” applies here, maybe a fix might be quick, maybe not.


Yeah, fair enough. I was just wondering. I wish I had more time to help.

At any rate upgrading to the latest KDE got autokey working, so the problem is not so urgent for me any more.

Thanks again.