autofs slow mounting

Hi fellow openSuse users,

After installing openSuse11.1 on a few machines, I’m experiencing very slow mounts (10 to 30 seconds) through autofs.

This autofs problem seems to effect all mount points from hardware NAS devices (NetApp, Adaptec, Netgear), but not for mount points from an openSuse10.3 server. It is strange that we’ve never experienced problems with any of these NAS mount points under openSuse 9.3, 10.0, or 10.3.

The autofs options for these NAS devices are different from those for the openSuse10.3 server mount points. However, when I try using the openSuse mount parameters for these NAS devices, the problem still remains.

NetApp NAS autofs example line:
home -rw,bg,vers=3,tcp,timeo=600,rsize=32768,wsize=32768,hard,intr stg-nas1c:/vol/home/home

NetGear NAS autofs example line:
mothballed -rw,bg,vers=3,tcp,timeo=600,rsize=32768,wsize=32768,hard,intr stg-nas2:/vol1/mothballed

openSuse server autofs example line:
sysadmin -fstype=nfs,rsize=8192,wsize=8192,timeo=14,intr stg-backup2:/stg-backup2/sysadmin

The NAS parameters were recommended to us by NetApp, who should know what they are doing as this is their specialist area. NetApp are unaware of any problems their end or with the NetApp NAS device we use. The fact that all NAS devices are affected does imply that autofs has been broken at some point between openSuse10.3 and openSuse11.1.

Any idea why we’re encountering this problem and if there is a work around?


Hi Neil,

I noticed a similar behavior on OpenSuse 11.0. I think the problem is not caused by autofs. For me it looks like the mount itself causes the problem. If I manually mount a nfs share of our NetApp it takes about 25 seconds. Have you tried how long this takes on your setup ? The strange this is that I can mount our Solaris Server and other Linux NFS Servers without any problems.

For now I increased the DEFAULT_TIMEOUT in /etc/sysconfig/autofs. Default is 600 seconds so the problem happens very often.

In the past we had once a similar problem with very slow NFS mounts. It turned out that the NFS server had problems to reverse resolve the IPs to hostnames because of DNS server mess up.

I was not able to check any logs on our NetApp since our IT guy is busy …

Sorry that I can’t help you …

Hi Berni,

Thanks for your reply. I’ve just tried manually mounting volumes from our NetApp NAS and other NAS units and you are right in that the mount is slow. So it’s not AutoFS that’s slow, it is the underlying mount that’s slow.

I’ve tested some reverse lookups for the openSuse11.1 machines and they return an immediate correct response so that’s not our problem.

Looks like there is a serious mount issue. This isn’t fixed by any of the updates either. :frowning:



I think I found a solution–at least with the NFS servers I’m using (whose maps are exported with NIS). The problem appears to be with the negotiation of the mount protocol. Specifying it explicitly took my manual test mounts down from 20+ seconds to almost instantaneous. Here’s what I did:

In your /etc/sysconfig/autofs, make this modification:


Then restart autofs:

service autofs restart

Of course this assumes that all your auto NFS mounts are happy with a TCP mount protocol, but mine seem to be, even the ones that chose UDP by default. We’re using NetApp and Sun NFS servers, for what it’s worth.

Lemme know if that helps y’all!