Authentication with iPrint IPP printers


TLDR: Unable to print as there is no authentication prompt or option to authenticate.

I work at a large university, and as such support network printing from Windows, Linux and Apple operating systems. These printers are on iPrint in an OES 2015 cluster. In addition to this, we utilise PaperCut print management to provide pull-print printers for print release (known locally as ‘Follow Me Printing’).

We have no issues with this when printing from ubuntu based distros, but I cannot get this to work in openSUSE. I add the printer using the lpadmin command, which creates the printer correctly (checked in CUPS). However, when I send a print job, the job never enters the network print queue as the job is unauthenticated. In Ubuntu, you are prompted to authenticate, or can right click on the job and authenticate. In openSUSE there appears to be no such option.

I have looked in CUPS and examined the configuration in YAST, but have been unable to find a configuration option.

Any assistance would be greatly appreciated.

Sorry, all I can do is help by using google. These are old links, but may point you to the PaperCut client and tying it into iPrint:

I think Step 2 is wrong in this link, thus the link above:

If I am giving you info you already have or not helping then apologies in advance.

I’m also not familiar with using iPrint (propriety product), so I can only read/share/speculate here… anyway from this old CUPS mailing list thread I leaned the following

Unfortunately both the iPrint server software and the iPrint client
software are closed source so that even I don’t know what is going
on there internally.

All I can tell at the moment is some very basic information:

When there is no authentication required to submit a job
from a client workstation to an iPrint server, no special
software is needed on the client system - i.e. the generic
CUPS “ipp” backend is sufficient to send the job.
I assume it is even sufficient when only the data transfer
should be secured via SSL (via an ipp URI “encryption” option)
but when no explicite user authentication is required.

When user authentication is required to submit a job from a client
workstation to an iPrint server, the special Novell iPrint client
software is needed on the client system which provides in particular
a special “iprint” backend (together with a Mozilla/Firefox
browser plugin “” and a “iprint-listener” program)
which do “all what is needed” to submit the job.

I can only guess that the special Novell iPrint client software
might even establish an authentication dialog with the user?

I also note an askubuntu thread explaining how to add the proprietary iPrint client. Maybe that’s what is missing here?

Now, it might be that this isn’t needed, and that passing the correct credentials is sufficient. I would compare the working Ubuntu configuration (/etc/cups/printers.conf) in the Ubuntu machines with the openSUSE configuration. Maybe the ‘AuthInfoRequired’ option is needed for exmaple ie appending "-o auth-info-required=username,password’ via the lpadmin command.

Thank you both. Sorry for the very slow response to your attempts to health.

Thank you for the help. Since you last posted, I looked at the links provided and the advice about comparing configurations.

Regarding the iPrint client - this is not a necessary component as it works perfectly using only the lpadmin command on ubuntu. However, I did install the client but was unable to install the printer using it :slight_smile: (I will ask on microfocus forums about that).

I looked into the two CUPS configurations and compared every configuration file I could find. Unfortunately, there was very little difference between the two (both v2.2.7), and certainly nothing that stands out as causing the problem.

I applied the auth arguments to the lpadmin command as suggested. Again, this did not work and actually caused the printer to dissapear in CUPS after a single print job was sent to the queue !?

My current thought is that it may be related to our use of SSL communication on the printers. We currently have an internal CA which provides certificates for these services. Obviously these are only locally trusted. I have tried adding these to the root ca folder and updating the CAs but again has not fixed the issue. Would SUSE deal with SSL in a more stringent way than ubuntu ?

Thanks in advance for any help.

I’m at the limits of my knowledge with this, but here’s a CUPS reference on the subject…

If you really don’t think it’s working as expected, consider submitting a bug report.