Audio problem on DELL Studio 1535

Hi guyz, I have a dell 1535 for a month now and I use openSUSE 11.1 on it. Almost everything works nice, but I have some annoying problems with the audio. I have the latest alsa and my both output jacks work fine, but non of my microphones work, neither the integrated or the microphone input jack, this is a s big problem sometimes, because I work a lot and most of the time I communicate with my team via skype. Another strange thing is that sometimes, but not always, the laptop speakers make a funny sound from time to time… and also a funny thing is that most of the time I cant run amarok and watch videos at youtube at one time, sometimes youtube flash player cant gain control over the sound card and bugs. Can please help me with some of these nasty little problems? I would be very thankful! :wink:

I have the Dell Studio 15 model 1537, which is almost identical. The integrated mics do not work (I note the integrated mics also do not work on Ubuntu either, where Ubuntu comes from Dell with some versions of the laptop) but the microphone input jack DOES work. My wife has used it fairly often.

Having typed that, I do NOT use Skype, so I can’t help you with Skype mic problems.

This is not laptop specific, but a general config setup issue. Some audio api will not share the sound. Other will. You need to ensure your media player uses an audio api that shares the audio.

Some sound concepts: Sound-concepts - openSUSE

I find the alsa api will share the sound.

I guess I have a serious problem here :slight_smile: Its not only in skype… I’ve tested the external mic with other applications. It’s just dead. My paranoia made me test the headset in xp… it works normaly. The other problem also remains… its either Amarok or Firefox with youtube. I can’t have both. :smiley: If I want to use the other, have to shutdown the one that is running. Otherwise I hear no sound and the playback runs 2-3 times faster than normal. rotfl!

I suspect its your mixer settings.

Try to record with a simple terminal record application as a test. I typically use:
arecord -d 10 myrecording.wavand then I play back “myrecording.wav” with a nominal player. The “-d 10” specifies a 10 second recording.

If that does not work, do a screen dump of your mixer settings and post it here. Sometimes KDE4 users forget to properly populate their mixer.

You could also give me a complete text output of your mixer settings. One way to do that is to copy and paste into a terminal:
amixer > amixer.txt && curl -F file=@amixer.txt should paste your mixer settings to a pastebin site. Then simply post here the URL. Just the URL.

Here is the Link then… :wink: You may guess the recording results of “bla… bla bla… blaaaaaaAAA” - “…”:X

Simple mixer control ‘Mic Mixer’,0
Front Left: Capture 14 45%] -13.50dB] off]
Front Right: Capture 14 45%] -13.50dB] off]
Simple mixer control ‘Capture’,0
Front Left: Capture 0 0%] [0.00dB] off]
Front Right: Capture 0 0%] [0.00dB] off]
Simple mixer control ‘Capture’,1
Front Left: Capture 0 0%] [0.00dB] off]
Front Right: Capture 0 0%] [0.00dB] off]
Simple mixer control ‘Amp’,0
Front Left: Capture 0 0%] [0.00dB]
Front Right: Capture 0 0%] [0.00dB]
Simple mixer control ‘DAC Mixer’,0
Front Left: Capture 23 74%] [0.00dB] off]
Front Right: Capture 23 74%] [0.00dB] off]
Simple mixer control ‘Digital Input Source’,0
Items: ‘Analog Inputs’ ‘Digital Mic 1’
Item0: ‘Analog Inputs’
Simple mixer control ‘Digital Input Source’,1
Items: ‘Analog Inputs’ ‘Digital Mic 1’
Item0: 'Analog Inputs’OK, I highlighted in red some aspects that did not make sense to me. Perhaps you could check them out.

I did not compare your Dell Studio 1535 settings to my Dell Studio 1537, as your Dells settings were so far off, it did not appear worth the effort for me to haul out and setup my Dell Studio 1537. But once your mixer settings get closer to proper settings, if the mic still does not work, I’ll bring out my Studio 1537, and compare the two. Right now, your Dell has too many inappropriate settings.

How can I change those things? :shame:

In KDE, you can change them with Kmix. The KDE4 kmix has adjustable controls via a menu item.

I don’t use Gnome, but I have read of gnome users using alsamixer.

There is also the terminal command “amixer”:
amixer (Linux Reviews)
I do not use amixer command myself, so I can NOT offer any advice wrt syntax.

If you have gnome, or if you decide not to use a GUI (such as kmix) then you are on your own wrt using “amxier” and “alsamixer”.

Thaaaaanks its working very nice. lol! But none of the other 2 microphones (the one on the camera and the one next to the IR port) work. But whatever :slight_smile:

On my Dell Studio 1537, the side connector (for an external mic) works fine. But the two integrated mics on either side of the web cam do not function.

I’ve been following both the Fedora and Ubuntu forums, and also following the Dell/Ubuntu support mailing list, and no one has the integrated mics working on the Dell Studio 1535/1537 under Linux as far as I can determine. Surfing the web I note the MS-Vista users are complaining those two integrated mics on the Dell Studio 1535/1537 have horrible quality, so as near as I can determine, not much has been lost by not having the capability.

An external mic works fine, with reasonable quality.

Am… btw I dont have any audio since a couple of hours. No idea why. I had version conflicts with virtualbox since the last update. I reinstalled vbox and since than I have no audio. I made a lot of restarts… no effect :slight_smile:

Its possible you updated your kernel? The latest kernel “breaks” the audio, and one must then install some newer alsa applications to work around this breakage.

What is the ouput of:
uname -a
rpm -qa | grep alsa
If it turns out you have the latest kernel, and if your alsa is not the version that is compatible with the new kernel, I’ll post the 6 zypper commands that you need to send to update your alsa.

ivan@soundreamer:~> uname -a
Linux soundreamer #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux
ivan@soundreamer:~> rpm -qa | grep alsa


I don’t see the alsa-driver-kmp-pae. I suspect it was removed when you updated your kernel. I recommend you update your alsa to the latest “git” 1.0.19 version packaged for openSUSE.

You can do that by opening a terminal or a konsole and type “su” (no quotes - enter root password when prompted) and then with your laptop connected to the internet copy and paste (and execute) the following 6 zypper commands one at a time, in sequence in that terminal/konsole:

zypper ar multimedia
zypper install alsa alsa-oss alsa-devel alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

then restart your PC. After restarting, if no sound, go to YaST > Hardware > Sound > Other > Volume and move up your volume settings for both Master and PCM volume to 95%. Then close YaST. Then go to your mixer and adjust your PCM and Master volume.

Hopefully you will have sound back then.

Ok… greaaat I have sound. Thanks a lot! But the soundcard doesn’t care if I have headphones on jack, it always plays from the pc speakers lol!:shame:

Hmmm … I did not test that on my Dell Studio 1537 after the update. I’ll have to test mine to see the behaviour. This was a problem previous with the Dell Studio 15 laptop, that was fixed per this bug report: Access Denied

I hope it has not come back.

Can you provide the output of:
rpm -qa | grep alsa
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
so I can check to see if your update was correct.

If the “bug” is back we will need to raise a new bug report, referencing the old.

OK, I have the same problem.

I raised the following bug report on this.

Thanks! I guess we found a bug here… :stuck_out_tongue: And now we wait… :\ By the way, about the original cause of this thread, a friend of mine told me that this problem with youtube flash sound and amarok could be because of problems with pulse audio. I’m not sure what he ment, but this might be a clue. :slight_smile:

P.S.: Just for the protocol… the headphones don’t work at all. The jack is dead. Its not only a automute problem…

Restart your laptop and try.

The jack does work for me. I have sound coming out of both simultaneously. … also check your mixer.

Made a lot of restarts since then. The mixer seems ok… jacks are dead. :X