Audio Passthrough on OpenSuse 11.3


I’m been struggling to find a way to configure suse to send audio to a receiver in some cases. Details:

  • Did a fresh install
  • Using an old SoundBlaster card (which worked in my previous version of openSuse)
  • I do have digital out, but only for Amarok (start menu -> configure desktop -> multimedia -> prefer “SB Live! Platinum [CT4760P], Multichannel Capture/PT Playback (IEC958 (S/PDIF) Digital Audio Output”) and Kaffeine (.kde4/share/apps/kaffeine/xine-config -> set “audio.output.speaker_arrangement:Pass Through”).
  • I have analog sound on firefox and “test volume” on Administrator Settings -> Sound, but just can’t find a way to configure those to digital passthrough (tried to copy “audio.output.speaker_arrangement:Pass Through” to .config/ but didn’t work)
  • Mplayer is a mess for unknown reasons (smplayer crashes, mplayer gives an BadAlloc error), but doing mplayer -vo null -ao alsa <filename> and having afm=hwac3 in .mplayer/config, I get digital audio. Does not work without -ao alsa or with “regular” audio (e.g. mp3s)


rpm -qa ‘alsa’:


rpm -qa ‘pulse’:


rpm -q libasound2:


uname -a:

Linux kiba #1 SMP PREEMPT 2010-08-20 19:21:29 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf:

options snd slots=snd-emu10k1
# M71A.6S9Jn9_7V7B:CT4760 SBLive!
alias snd-card-0 snd-emu10k1

Hope someone can help me! :frowning:

Hello jorgenmz. I also use a home receiver connected to a Sound Blaster card and using Dolby Digital 5.1 and 7.1 and Pass Through works great in openSUSE. The number one thing you need to consider is that there is not just one place you can configure and get everything to work the same way. Also, you must consider what kind of media source requires Pass Through Mode. Well the answer is a DVD movie is the only media source normally that would use and require Pass Through Mode for Dolby Digital operation. Other Applications can use PCM Stereo Mode out the same digital signal cable, but they do not require Pass Through to function.

Next question you must ask yourself. How many different ways do you need to do the very same thing? By that I mean, how many DVD players do you need? I would suggest you get a couple to work and don’t worry about all the others, same goes for music players. So, I use Kaffeine/KDE3 for most of my DVD playing. Kaffeine uses the xine playing engine and parameters to work. If you use KDE 4.4 or higher, you must add in a KDE3 repository in order to load Kaffeine/KDE3. Next, if you do load the older Kaffeine into your computer, you can use your old xine configuration in order to get the latest version of Kaffeine to use Dolby Digital Pass through to work. I have an article on the subject here:

KDE 4 Phonon xine-backend Configuration

Now as for music playing I am using Amarok. As stated before it can use your digital output, but in PCM mode. Now Creative cards often have all sorts of simulated sound modes, but mostly these modes do not work in Linux. What I do with my 7.1 Sony Receiver is set it up for what they call Multi-Stereo. Which means that all speakers on the left output the stereo left channel, all speakers on the right output the stereo right channel, the center channel is a mono mix and the sub pulls off bass from both the left and right speaker. This sounds very good to me and better in my opinion for stereo playback. And due to the digital PCM output, the sound quality is very good.

If you are looking for a combination DVD player and music player that tries to be a full muti-Media solution, look at installing the program XBMC. It supports most media types, can be configured for Pass Through for movies, supports MP3 playback and has all sorts of other features. It is a little tedious to configure, but they have their own forum you can visit and get setup help with and it looks very good to me. Hey it took me a couple of hours to get it working right with the last thing I had to figure out was to get its weather temperature display to say F instead of C, which does not have much to do with movies. But, if I got XBMC to work, so can you.

In the end, my most favorite Movie player is still the old Kaffeine/KDE3 version. The main reason is its ability to use the CTRL-V and CTRL-H key strokes to resize movies on the fly while running, thus allowing you to obtain a full screen, no matter the original movie’s aspect ratio (if you don’t mind planets that look like eggs sometimes). Now I have talked about a lot of subjects here. You need to ask specific questions as to how to obtain any program I have talked about here and remember to narrow your DVD and music players needs to just a couple of good applications.

I use openSUSE 11.3 and KDE 4.4.4. You need to understand How YaST Software Repositories and Software Management work in order to add in missing applications. You did not mention your openSUSE version or Desktop version that you use. I know very little about the GNOME desktop and can’t provide much help there.

Thank You,

Thanks for responding so quickly!

Yeah, I think I got the terms wrong, sorry! :stuck_out_tongue:

What I mean is, I want everything to use my digital out connection, like in my older openSuse installation (I think it was 11.0).
I use Amarok for music, Kaffeine for DVDs and (s)mplayer for mkv’s and other kind of videos.

Amarok, Kaffeine and system sounds (e.g. when login in) work fine, but for firefox I have to change to analog. PCM files through mplayer don’t work as well.

I’m currently using Kde4 on the newest openSuse 11.3 x64.

jorgenmz Thanks for responding so quickly!

Yeah, I think I got the terms wrong, sorry! :stuck_out_tongue:

What I mean is, I want everything to use my digital out connection, like in my older openSuse installation (I think it was 11.0).
I use Amarok for music, Kaffeine for DVDs and (s)mplayer for mkv’s and other kind of videos.

Amarok, Kaffeine and system sounds (e.g. when login in) work fine, but for firefox I have to change to analog. PCM files through mplayer don’t work as well.

I’m currently using Kde4 on the newest openSuse 11.3 x64.
Hello jorgenmz and good morning. After positing my response to you, I realized that you did mention your openSUSE version in your title. So silly me. Your comment: “I’m currently using Kde4 on the newest openSuse 11.3 x64.” sounds fine as I know how to deal with this.

There several places where sound can be configured. Two of these places affect everything. One is in your mixer configuration. If you open the kmixer control on the icon tray, press the speaker and then the mixer button. In Mixer go to settings / Configure channels and drag everything from Available Channels to Visible channels. This puts all controls at your finger tips. Some, if not a lot of the controls you can add to the mixer may not do anything but some can effect just how your speakers will function. You can close the mixer for now.

Next lets go to KDE menu / Personnel Settings / General Tab / Computer Administration (at the bottom) / Multimedia. Next, check the “Show Advanced Options” option so all sound devices will show up. On the Device Preference Tree / Audio Output / for both the Music and Video I put my Analog PCM Standard Output at the to of the Output Device Preference listing. I put my my S/PDIF Digital Audio Output as number two in the listing. Some sound cards can have multiple outputs that say almost the same thing and you may have to play around with them to get the two that work at the top of the lists.

Depending on the sound card, most if not all of the outputs work all of the time, no matter the list setup. So, this list, along with the Mixer channel settings effect which outputs have priority and how your volume and other controls work. For instance, if you put the Digital Output at the top, even if your sound cards allows for volume adjustments for PCM audio going out a digital output, all volume level controls stop working since in the Pass Through mode, there is no level control possible. So, this listing preference does not make an output work or stop an output from working. It does effect level controls in the mixer.

In the mixer, which you can open again, your may have some controls that work with the S/PDIFF Digital outputs and which may have a mute button. The application of the mute function, can prevent a digital output from working. Most often there is no level associated with digital outputs. If you have more than one digital output, the mute control can determine which one does anything and which ones don’t work. You can remove the ones that don’t work and the one that does should be second in your listing for KDE multimedia.

Now, as for Pass Through mode for Dolby Digital 5.1 and 7.1 production, this ability is a function of the DVD player setup and not a sound setup in the mixer (except for the mute function) and when one DVD player is setup right does not make another player work right. The trick is to determine how to configure the Pass Through to work on any particle DVD player. So the question for DVD player is which one do you want to use and have you ever got pass through to work? I suggest you install Kaffeine/KDE3 version for this purpose. If you have not done so, ask how to do this if not done already.

As for your music player, I would stick with Amarok for now. It is hoped that when you go through all of the sound settings you can find one configuration that allows everything to work properly for you. I request that you tell me what channels do you have in the mixer and what are they called. I ask that when you go into KDE Multimedia sound setup, what Outputs do you have listed. With this info we should be able to get you working as required.

Thank You,

In my multimedia settings, I have “SB Live! Platinum [CT4760P], Multichannel Capture/PT Playback (IEC958 (S/PDIF) Digital Audio Output)” as the first option for all the items in “Audio Output” (I haven’t touched anything in “Audio Capture”). When I hover that firsr option, I get “This will try the following devices and use the first that works: 1. ALSA: IEC958:CARD=Live,DEV=0”
My second option for everything is “SBLive! Platinum (rev. 8) Standard PCM Playback”. Playing a test sound for the latter won’t send anything through digital out.

In Alsa mixer I have a plethora of things to play with. The most relevant (I guess) would be “IEC958 Coaxial”, “IEC958 (capture)”, “IEC958 Live Drive”, “IEC958 Live Drive (capture)”, “IEC958 Optical Raw”, “IEC958 TTL”, “IEC958 TTL (capture)”, “External Amplifier” and “SB Live Analog/Digital Output Jack”. Everything is set to the max value. Also tried muting/unmuting “External Amplifier” and “SB Live Analog/Digital Jack” but nothing has worked.

I’ve checked Kaffeine and while it works for 5.1 audio (DTS), it doesn’t for PCM.

(remark: I have CT4760 in System->Sound, while I have CT4760P (and the word “Platinum”) in Configure Desktop->Multimedia. I think I have a Value model, rather than a Platinum one! Wonder it that’d have something to do with all this…?)