Audio from VLC is not downmixed to stereo (possibly issue with Pulseaudio?)

I’ve just done a fresh install of openSUSE 12.1. I’ve enabled Pulseaudio as it’s generally been problem free in the past couple versions. Now, however, it seems as though maybe Pulseaudio is reporting the incorrect number of speakers or somehow not downmixing correctly. I’ve only got stereo speakers on this system, so I need anything with more than 2 channels to be downmixed in order to work correctly.

Example: If I play a DVD with 5.1 audio in VLC, the center channel seems to come out of the right speaker, and one of the rear channels comes out of the left speaker. If I load up pavucontrol while VLC is playing, I can see volume controls for 5.1 independent channels. That is, VLC is trying to output to 5.1 channels, even though I only have 2. If I play the same DVD with the same audio stream in MPlayer, it works fine and pavucontrol only shows audio being output to 2 channels (as expected).

I believe VLC is supposed to downmix if it needs to, so I would guess it is being fed incorrect information as to what the speaker configuration is. Alternately, it would be acceptable for Pulseaudio to automatically downmix the 5.1 to stereo. However, neither VLC nor Pulseaudio seems to downmix, so the resulting audio is unlistenable.

Has anyone experienced this before? What was the resolution?

Edit: Also, I’ve tried both “Analog Stereo Duplex” and “Analog Stereo Output” in Phonon. It did not make a difference, and I’m not sure what the difference is between the two. I do know that Phonon only lists two speakers, though.

Also, I’ve now disabled Pulseaudio and it works as expected. I guess for now I will leave Pulseaudio disabled. If someone has a fix, though, I’d love to hear it.

you can find more information here:
Or you can install vlc-beta from videolan OpenSuSE repository.

Any packager here ?