Attempting to compile XFCE plugins from an ubuntu distro.

I have recently installed SUSE tumbleweed XFCE on my computer. I am attempting to build a couple XFCE plugins from a different distro which is ubuntu based as I quite like them.
I am encountering some interesting errors in the attempt.

The first error is from C++:

CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Checking for module 'exo-2>=0.11'
--   Package 'exo-2', required by 'virtual:world', not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:556 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:778 (_pkg_check_modules_internal)
  panel-plugin/CMakeLists.txt:17 (pkg_check_modules)


-- Configuring incomplete, errors occurred!

I get this error from running the command

cmake .. -DCMAKE_INSTALL_PREFIX=/usr

This makes it look like I do not have exo-2 installed.
If I go into YaST I see:
https://i.imgur.com/On3TOqA.png

So I do not understand why it says that exo is not installed.

This is the block of pkg checks in my CMakeLists file:

find_package(PkgConfig REQUIRED)
pkg_check_modules(GTK3 REQUIRED gtk+-3.0>=3.22)
pkg_check_modules(exo REQUIRED exo-2>=0.11)
pkg_check_modules(garcon REQUIRED garcon-1)
pkg_check_modules(libxfce4panel REQUIRED libxfce4panel-2.0-4>=4.11)
pkg_check_modules(libxfce4ui REQUIRED libxfce4ui-2>=4.11)
pkg_check_modules(libxfce4util REQUIRED libxfce4util-1.0>=4.11)

Now funnily enough none of these actually worked. I had to use

sudo zypper install gtk3-devel

to get the gtk line to work, and neither YaST nor the SUSE package web page said that gtk3-devel even existed. Are there more secret packages I need to install? If I plug the search term for each of these into YaST I get a positive confirmation that the package is installed. Because I apparently have all these packaged if I search for their name from before REQUIRED, I tried changing the part after REQUIRED to match what YaST was spitting out but no dice.

Does anyone know how I can get this working? It’s quite frustrating that I have everything in YaST but none of it works.

Hi and welcome to the Forum :slight_smile:
Just because package X is installed does not mean the corresponding package X devel(opment) package is installed…

In your example it would be exo-devel, suggest using zypper and command line while your there and another terminal switched to root user for install…

eg;


zypper se exo
....
....

zypper in exo-devel

Thank you for the welcome! :slight_smile:

I am pleased to say your solution worked for exo. I would like to ask, how do you figure the package name?
I assumed that YaST was a front end for zypper and searched for exo-devl in it but was told no packaged existed with that name.
Is it just a matter of seeing which package you want and hoping -devl works on the end? Your suggestion + what I did with gtk seems to indicate to me that zypper has access to a totally different package list than YaST or the official online package searcher.

It looks like my edit time has expired so I will just put this in. I completely put the cart before the horse and just ran the zypper install rather than looking into the se option to see what it did. This is exactly what I was looking for. Kicking myself for not even thinking about what I was doing. I think my problem is resolved.

Hi
Good news :slight_smile: Not sure if your aware of https://software.opensuse.org/search for packages? Seems to me unless it’s some specific plugin it may already be available?

That is what I was using earlier, and became frustrated with. My first issue (which I figured out before making my post) was that I had no gtk3-devel on my system.

Consider the output of zypper se gtk | grep gtk3-devel:

i+ | gtk3-devel | Development files for the GTK+ toolkit library v3 | package

This shows that gtk3-devel is on my system (As I guessed at what it was called and hoped zypper would install it, which it did and resolved my issue.)

https://i.imgur.com/GWjGOJo.png
**By contrast, the online package search says that it doesn’t exist. **

Unfortunately the actual package I am building was a specific panel application made for that distro. I’m re-compiling the panel plugins they used to make their XFCE unique, because while I quite like how the actual panel applications worked I didn’t want ubuntu under the hood.