ATi X1950Pro works then doesn't

I have an issue wherein my ATi X1950Pro card worked initially in OpenSuSe 11 AMD_64. I performed the easy install from the OpenSuSe wiki. However after rebooting my screen apparently has my desktop twice on the left and right sides of my screen and the contents are somewhat scrambled in that I can’t tell what is what.

As late as 2 weeks ago I had installed it with the (seemingly at least) same ATI driver without any issues and it worked for a couple of days before I moved on to a couple of other distros. I have been testing to see which I like best. I had decided to settle on OpenSuSe 11 last night. (tested Ubuntu 7.10 and 8.04, Mepis 7, OpenSuSe 10.3 and an abortive attempt to get Gentoo running)

I was using KDE 3.5 desktop.

I have Ubuntu 8.04 installed right now but I want to use OpenSuSe 11. Is there a known issue with the ATI driver? Have they changed driver revisions on the link to the easy install? I have many years of experience with Windows 3.1 through Windows XP, and am in fact A+ certified, but that amounts to about nothing outside of a Microsoft environment. I need to broaden my horizons and wanted to give Linux a try.

Thanks in advance.


This question probably ought to go in the regular “Hardware” section.

The driver normally requires a reboot, so it was probably messed up all along.

Do you have a need for intensive 3d support, such as games? If not, I would just stick with the stock driver.

ATI’s linux drivers have had countless problems in the past. I gave up on them a couple of versions back when the system would lock up whenever a screen saver came up. But I did install the latest 8.8 version and it seems OK so far, but ATI’s bugs can take several days to become apparent.

What I would do if you are dead set on installing the ATI driver is download the Linux installer from the ATI site. It’ s a good lesson in using the terminal commands and getting a feel for how the OS behaves.

Here are the instructions:

And the driver:

ATI Catalyst™ 8.8 Proprietary Linux x86 Display Driver

There are some dependencies you need to install first, before the installer will build a driver for you. If you go to Yast / Software Management / Patterns and install the program groups “Linux Kernel Development” and “C++ Development” from your install disc you’ll be all set.

Otherwise, the installer will run, but you will still be using the old driver.

And don’t forget to uninstall any previous “easy install” driver through Yast. If you do a search for “fglrx” it should turn up.

Good luck!

I forget to mention that when you go to Yast to install the Linux Kernel Development and C++ Development package groups, it will try to download them from the internet first. So if you have a slow connection like mine, you may want to either disconnect or cancel the refresh process early on, because these packages are several hundred MB’s in size.