ATI Radeon HD 3650 AGP + radeon driver = screen flickers in 11.4

After realizing that all my old repositories for 11.2 had gone missing, I decided to upgrade to 11.4. I had been using fglrx in 11.2 and it had worked fine. I started having problems in 11.4 though.

I’ll admit that I tried a few times to install fglrx, in a couple different ways, and every time it had horrible performance in one way or another, and every time I couldn’t figure out how to remove it without making the system go to command line at reboot. I’m not even vaguely comfortable using a command line interface unless I have specific instructions, so I reinstalled 11.4. Several times.

I tried activating radeonhd as well.

In both radeonhd and fglrx (worse in fglrx) I had problems with scaling video and shearing. A couple times, installing fglrx from a file, my cursor disappeared. Since one of the main things I use my computer for is watching fullscreen videos, scaling is absolutely important. The radeon driver seems to function a lot better with scaling video, and other performance, but my card is not technically supposed to be one of the ones it supports. Also, every 20-30 seconds or so, the screen flickers to black and back again, which is not even vaguely acceptable.

I have a ATI Radeon HD 3650 AGP card, and I use a converter to run a CRT monitor on it.

So my question is this: has anyone had a similar experience, and if so, what would you recommend? Is there a way to make radeonhd or fglrx work better, or to stop the flickering with the radeon driver? Any help would be appreciated.

tried starting with nomodeset, actually fixed the flickering problem, but made scaling issues worse.

Starting with nomodeset should force the loading of the ‘radeonhd’ drivers.

Try going to the /etc/X11/xorg.conf.d/50-device.conf file, and remove the ’ # ’ in front of the line:

  #Driver "radeon"

such that the line looks like:

  Driver "radeon"

and save the change. Then when rebooting using the boot code ‘nomodeset’. In this case you should boot to the radeon driver, despite also having specified ‘nomodeset’.

Also try switching off special desktop effects to see if that helps.