ATI Radeon 11.1

Hello all, I have been anticipating the release of 11.1 and finally got the download. Went to boot my computer using the Live CD, and X does not start. I have an ATI Radeon 1300. I tried using F3 and Vesa and putting in “xforcevesa” for the boot options to no avail. I wouldn’t even care if I got the worst resolution I could imagine, at least then I can pull down the latest driver from ATI’s site and install. Anybody have any ideas I can use to get X going so I can install 11.1? Please let me know and I would also be glad to provide any more information.
Thank You!

Ok, if you don’t currently have a working X config, maybe you can use zypper (as long as you have internet connectivivty). Try:

zypper ar --type rpm-md ati

zypper refresh --repo ati

zypper se fglrx (to see list of packages available)

Then install the required packages, and configure with

sax2 -r -m 0=fglrx

Hope that works…

I think you intended an ati site and not a nvidia site.

Do you by chance know what that exact ati site is? I’ll give that a shot… I’m assuming try to boot to runlevel 3 and do this.

Do you think this one would do?

I think you intended an ati site and not a nvidia site.
Reply With Quote

Doh! Thanks oldcpu for picking up on this. I meant:

But you may need to wait a few days before driver is present.

See here.

That site doesn’t exist any more!

I downloaded Catalyst 8.12 driver from from drivers page, just like a Windows user would.

One point, if your card has a hotfix, you may be referred to an older version rather than the new driver.

I am not sure if that’s through oversight or decision, as working 3D hasn’t been a priority for me, often a bit of patience means things go easier.

Try using 11.0, it should work but I can’t test it because I can’t login… If I could get rid of my “Module is unknown” error so I could just login… Zypper dup - 11.0 → 11.1, login issue - openSUSE Forums

Hey, I got this working. However, it was quite a workaround and some might not be as fortunate as I am to have 2 graphics cards. But what I did was went into the BIOS, and enabled the onboard card which was an NVidia. And installed 11.1 using the Vesa driver with the Monitor plugged into the NVidia card. Once I got the OS up, I downloaded the newest ati driver for my card, installed all the dependencies and installed the driver. I then ran #aticonfig --initial and rebooted. I plugged my monitor in to the ati card and everything looked great. I then got a little crazy and tried a second monitor on that card (Dual head). The nice thing about that was, I used the Catalyst Control Center and that worked awesome with xinerama! Something I could never get working with SAX2.

So, unfortunately if you don’t have 2 cards like I did, this isn’t that great of a solution, but if you by chance do, give that a try.

I would like to mention here that installing ATI display driver for linux may your Xserver in hazardous display. My personal experience is, it works really great with Suse11, but fails in Fedora9, Mandriva09 and Ubuntu (in the same machine). The driver supports ATI1300, so if you are trying it in Suse make a backup of /etc/X11/xorg.conf file before installing ATI driver (if posiible the whole X11 folder).