ATI open suse 11.1

OK, so i downloaded beta 4, when go into yast-graphic card and monitor, i can see there is a ati radeon 1200 listed, which is my graphic card, but when i type glxinfo into terminal, there is DRI driver… thats why when i start desktop effects, they are working but there are sometimes lines across the monitor… any idea how to configure ati drivers properly in 11.1?? tried repositories but no success, i tried repositories and fglrx driver from ati suse 11, but there is an error with kernel while installing them… i read in one forum, that there is no need to install fglrx in 11.1 because compiz will work by default…i tried also ati catalyst from ati site but again nothing!!

In order to have full 3dAccel you need the ati proprietary. Go to and download the latest driver for linux that matches your card. Now, go to yast in software manage, and make shure you have installed the kernel-source package. If you have the initial kernel, without any updates, then install the kernel-source from the suse dvd/cd. (without the proper kernel-source version, the driver will not compile). In a terminal as root, execute the ati installer. Do not select custom install, just let it do it’s stuff. After the installer has finished, in the console as root type: #init 3
Now you’re in runlevel 3. It will ask you for login. Login as root, enter your password
now type: #aticonfig --initial -f

Now type: #init 6

The last command will reboot your system. When the system starts again you should have 3d acceleration. You will also get the catalyst controll center. If you can’t find it’s icon in the menu you can run it from console with this command:


If the resolution you have now doesn’t suit you then open a console login as root and type:

#kate /etc/X11/xorg.conf

A text editor will open. In the file shown go to this line:

Section “Device”
Identifier “aticonfig-Device[0]”
Driver “fglrx”

Section “Screen”
Identifier “aticonfig-Screen[0]”
Device “aticonfig-Device[0]”
Monitor “aticonfig-Monitor[0]”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1280x1024” —> modify here for your resolution

Hope this helps

I’m trying to follow these directions. I’m using openSuse 11.1 Beta 4, which I installed to my hard drive via the live CD. I installed the kernel-source package. I went to and downloaded the newest available Radeon drivers - the 8.10 release.

When I run the driver install file, I get the following error message:

Error: ./ does not support version
default:v2:i686:lib::none:; make sure that
the version is being
correctly set by --iscurrentdistro

Any help would be greatly appreciated! Thanks!

How can I know what kernel I have? and how can I upgrade it?

I got this error after trying to install the driver:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

I found somewhere else that you first have to type zypper in gcc make kernel-source libstdc++ patch on the terminal to make it able to compile. It worked after that.

I have a Gateway 450RGH Laptop with an ATI Mobility Radeon 9600. I was running the 8.42 driver under SUSE 11.0 and didn’t have any problems. Then I stupidly did an upgrade to the latest fglrx driver for 11.0 and it wouldn’t come back up in X. Kept giving me a segmentation fault. Now I installed 11.1 hoping that the driver was fixed, only to find that there is no fglrx kernel or driver from ATI. Machine appears to be running in 3D mode using supplied Radeon driver from suse, but still hangs machine occasionally.

I have tried running the installer from AMD and everything compiles ok, but I keep getting a segmentation fault when trying to run aticonfig.

Is there a way to install the 8.42 driver under 11.1?


What am I doing wrong?

I used the same method as deathstar and never had any problems with the released version of 11.1.
It could be that there is a problem with the beta package and it may be worth installing from the release version.
In addition to the kernel source/development package selection, I also installed some of the programming development packages.
I couldn’t start X so I did everything from a non gui login and it worked fine.


I tried this on the 32bit version of 11.1 with an ATI card.

setup the headers/sources followed by make cloneconfig, make modules_prepare.

Download the 8.12 ATI fglrx driver and do the default install.

This fails with an fglrx… file already exists error message.

trying to run aticonfig after this has failed results in a segmentation fault.

modprobe fglrx results in cannot allocate memory error and terminates.

setting the devices section to fglrx results in no X, setting it back to radeon and all is well again.

compiling a distribution specific version of fglrx results in the same as above.

From what I have read so far the 64bit version does not appear to have this problem.