ATI Driver Problem

Sorry for my bad english but i’m German.
I’m new in openSUSE.

If got a Sapphire ATI Radeon X1650 Series PRO (AGP)
but the Drivers are the same as the normal ones of the ATI Radeon X1650 Series.

I installed the new openSUSE 11.0 yesterday.
openSUSE does not integrate ATI Drivers, so I didn’t got a 3D Funktion.

I’ve found this driver from Advanced Micro Devices, AMD - Homepage for normal 86/32 Bit Systems from the 18 June:

ATI Catalyst™ 8.6 Proprietary Linux x86 Display Driver

Now I tried to install the Driver on my self with this tutorial:

ATI-Treiber unter openSUSE 10.2 installieren - openSUSE (DE)

The Tutorial is only for 10.3.
After I’ve done it i had to reboot but after LogIn the Screen became black and nothing happened anymore.

Then I took a view on the english version and i noticed that it was a newer version then the german. There was something with an automatic installer.

ATI - openSUSE (EN/US)

How can I install the driver correctly so that i can aktivate the 3D funktion?

Thanks for Help

greetings Cedric

There exists a repository, which includes the newest driver. You could add this within yast or you could use the ATI-current one-click from

So at first I installed the (community) repository with YaST, but it don’t work. After that I installed the drivers with the 1-Klick-easy-install-file, but it still don’t work. Both have installed successfully, but I can’t activate the 3D funktion. :confused:

greetings Cedric

After the ati driver has installed, assuming you used the repository method,

boot into run level 3,
login as root or normal user and become root by typing “su -”

now type “sax2 -r”

after the sax2 config has finished, type


3d acceleration should work after this.

Sorry for this simply question but i’m new to openSUSE.
How can I switch to runlevel 3?

Maybe with typing in ‘# init 3’ as root?

The drivers are easily configured if you use the factory settings ATI ‘aticonfig --initial --output=/etc/X11/xorg.conf’ command, reboot machine, followed by the the ATI control panel, reboot machine, followed by resolution setting using the ‘screen resolution’ applet [which magically appears on your GNOME panel] and you’re set.

Note key problems with:

**1) combined desktop settings
2) suse graphics control panel
3) proper graphics initialisation **

To enable dual screen another screen on one big desktop you have to use the ATI control panel combined with manually editing the xorg.conf file which is definitely not advisable. On Suse 11.0 you may also notice that the screen resets so even if you have a 75Hz setting it reverts back to 60Hz regardless of suse graphics configuration. The initialisation is also problematic and there is no safe default to allow you to fallback and configure your visual.

Does anyone have a solution to the desktop-, panel-, reset- and init problems?


If installed both - the repository and the 1KlickInstall file.

At first i tried FizzyFanta’s idea:
-Changed to runelevel 3 (# init 3)
-Used “sax2 -r” successfully

But nothing changed. I couldn’t activate the 3D Acceleration.

After that i tried the other idea from herbievantetering:
-Logged in as root
-used “aticonfig --initial --output=/etc/X11/xorg.conf” successfully

After that i rebooted openSUSE did nothing after loading up.The screen remained black. The Computer isn’t frozen - but the screen keeps on staying black.

Now it seems like i have to re-install openSUSE

Do I have to note something special with my ATI Radeon X1650 Series?

What can i try else?


install the kernel-source, run the installer and add in xorg.conf in the device-called section fglrx as driver.

Hi …
I still have the same problem - Ati 1950 pro on agp, and if i activate the fglrx-driver, i get black screen.

I tried everything i found here, on the howtos etc - no success yet.

But err… you don’t have to reinstall!
On bootmenu just delete the vga-parameter and enter “init 3” - then you go into console-mode… login as root + password. Then type

sax2 -r -m 0=vesa

After this reboot…

it sets the driver to the default-vesa-driver, wich has no 3d or accelleration for your card, but displays the rest…

Today I re-installed openSUSE 11.0. Now with the KDE 3.5 Desktop. I think the 3.X version is much better then the 4.
I tried all ideas again, but the same problems. At first i couldn’t aktivate the 3D Acceleration and aftet that the screen remained black.

It’s very disapointing… :frowning:

Has Nobody got a Idea?


I has with the same problem… (ati radeon x300)

So… i instaled drives with one click install → ATI - openSUSE

Nothing changed…
now u need to run sax2.

go to console:

Go to console and type: fgl_glxgears

Now works! \o/

I too was having a lot of issues.
This is what I did to resolve w saphire Radeon 3650
I’m a noob too but this worked so I’m typing this from a noobie to noobs :slight_smile:

-update your system first.
-from yast under “software” then “software Repos” click “add” bottom left corner
-click community repository and next
-click “ati repo” then ok

  • in software management in yast filter for repositories click on ati repo and click both “ati-fglrx G01-kmp-pae” AND “x11-video-fglrxG01” (mine were already “pre” selected) Accept to install.
    DO NOT reboot (always black on reboot)

Open terminal

  • su

  • aticonfig --initial (do this first!!! before sax reload)
    (don’t actually need the --input unless keeping some changed xorg.conf config)

  • sax2 -r
    (will start sax and reset it --my “test” crashed every time!!! but just save it and it will work (hopefully))

REBOOT (not restart X … didn’t work on cntlaltback)

ati’s 8.6 didn’t work ever for me… :frowning: black boot.
had to do it this way since 10.3, simple script could fix this

hope this helps.

I’ve tried your idea:

-“ati-fglrx G01-kmp-pae” and “x11-video-fglrxG01”
both were already installed

-opened Terminal:
got root (su)

used aticonfig --initial
and sax2 -r successful

after that the sax2 window opened and the 3D funktion was ENABLED!
aktivated 3d acceleration, set the resolution

I rebooted

But then a got a black screen again.:frowning:

After all, I could aktivate the 3D Acceleration for the current session. :rolleyes:

But the problem was not solved


I’ve had no luck with the ATI driver either after trying a variety of methods outlined in this thread.

If sax -r doesn’t work, you want to specify configuration for the fglrx driver. Use sax -r -m 0=fglrx instead. Also, you shouldn’t be using ati-fglrxG01-kmp-pae unless your hardware requires the pae kernel. Ie, if you do rpm -qa | grep kernel and your kernel is kernel-default, you should be using ati-fglrxG01-kmp-default.

Ack, looks like I can’t edit my post. To elaborate and expand on what philt80 posted:

philt80 outlines the process eloquently. My comments added in blue.

I searched for my kernel module. I’ve got the pae kernel installed.
I tried it with your ideas but the same ending: black screen.

i have ati x1950

same problems.

finally i understand than in linux i will never work an ati card.
it seems that isnt a guide with instructions that will work for sure but with a bit of luck. :frowning:

I can report that, with an ATI 200 I ran the process above and it works. I did make sure I deleted the current drivers from the machine, then reinstalled through YAST from the ATI repo. Getting a clean install was key for my success. I had tried it several ways before but had to go all the way back.

BTW, for what it is worth, when I ran sax2 from the terminal mode, I accepted the configuration it gave me without trying to mod it. Whenver I tried, I ended up screwing soimething up so taking the defaults I guess worked.

last point is a “thank you”. I have been running Suse Linux for a while, and I could never get this card to work under any of the 10.x revs. Nice to see if come up under 11 with minimal heartache. Now, off to play with configuring compliz…


first download the driver at ATI Catalyst™ 8.6 Proprietary Linux x86 Display Driver

install the Kernel Header from repository

then install the driver and run ‘aticonfig --initial’,

run apps you want.

if you got black screen or hangs(it may or may NOT mean the driver fail to install),check the logs.