ATI driver for 11.1 openSuSE

I have ATI card Radeon x1300 PRO and i dont know how to install drivers. I was trying normal and from RPM file. Both failed. Now i get error when i type fglrx as root.I dont paste it right now because i use other comuter with Windows (it dont suck - im not on OS war).And what settings of partitions you prefer for 80 GB PATA ?
EDIT: I forgot i have 64 bit OS :).

I gave up on installing 11.1 on my ati graphics system and went back to 11.0.
To get ati installed on 11.0, go to yast and add the ati repository. Now go to software install, select the ati repo and install the ati driver and reboot
When you boot, select the debug kernel and then login on the terminal screen, and run sax2 as root.
Once you have completed updating the system, the later kernels will work with the driver.
I should imagine installing the debug kernel could work on 11.1.

The installation should work and configure Vesa driver display, which I find perfectly acceptable for 2D use, browsing, email etc etc, it’s 1600x1200 on my box.

11.1 is just too newly out, for the ATI repository. So either wait a little while for it to get sorted.

Or go to ATI site and download the driver from them, and read their documentation.

You’ll need kernel-header files or full kernel-source, and certain development tools installed to build against, but it’s automated.

There may be problems with the driver, caused by the new kernel version, 2.6.27 used in 11.1; if that’s the case then you’ll have to wait until ATI release in January, or someone’s found a work round, or patches go into SuSE kernel.

Like robopensuse says, opensuse 11.1is just too new for the ati driver. One correction to his post is that the default install should configure your ati card with the opensource radeon driver, rather than vesa. The driver works perfectly well and unless you’re playing non native games, you won’t run into any issues.↲↲If you’re dead set on installing the fglrx driver, install the bin file from ati’s website. You’ll have to delete /usr/lib/dri/ and replace it with a simlimk to /usr/lib64/dri/

So you’re saying that the normal install procedure using the ATI proprietary driver (AKA “the hard way”) won’t work with 11.1?

What if you generate an RPM with the installer? Does that work?

Do you mean, if you gen the RPM and then use YAST to install it, relying on the dependency checker of YAST to gather the proper prerequisites, does that result in a good driver install?

If so, the answer is: yes, up to a point. As a previous poster has pointed out, you must symlink the 32 bit module file. Of course, the usual* aticonfig* and sax2 incantations apply, and there is no end to the /etc/X11/xorg.conf entries you can experiment with.


I have the ATI driver working with the work around /usr/lib/dri/ -> /usr/lib64/dri/

The rpm wanted to build with libstdc++33.

Please help… ATI Driver problems! - openSUSE Forums

I’m running 64bit opensuse 11.1. Tried doing it this way, with the symbolic link, as described in How To: ATI Drivers OpenSUSE 11.1 - Ubuntu Forums, but no luck (kernel crashes when the driver loads). I’m going to wait for ATI to upgrade their repositories.

With Opensuse 11.0 my driver was working fine.

This is how i get it working:

ATI 3D onder OpenSUSE 11.1 64 bit

ok, it’s in dutch, but i hope it can help you make it work

Tried it, but still crashing.

This may be because I have not installed the various 32bit compatibility packages ? (As mentioned in ATI - openSUSE)

I’m giving up for the moment, hoping that the ATI repositories will be updated soon.

dont give up here is what i did somebody else put this together but don’t remember who

  1. Download the driver installer from ATI.

  2. Run the installer, don’t choose custom, agree to everything.

  3. Log out, and Switch to the first terminal (Ctrl+Alt+F1)

  4. Login as root.

  5. run init 3 to switch to commandline linux with no Xwindows.

init 3

  1. Check the X session (Ctrl+Alt+F7) and make sure the login page isn’t there. If it is, Sax2 will fail. If this happens, reboot, switch to Ctrl+Alt+F1, login as root again and run init 3

  2. Init 3 will hang on “init 3 has been …”. Just hit enter and it will return your # prompt.

  3. move your existing xorg.conf file to a backup.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001

The reason you do this is to get rid of your existing X configuration file. Don’t worry, you will be creating a new one soon.

  1. Generate a new xorg.conf for ATI radeon by running:

sax2 -r -m 0=radeon

if you are using NVIDIA, check the NVIDIA instructions for the specific set. If Sax2 says it can’t access the display, check the X session (Ctrl+Alt+F7) Is it still running? Did you run init 6? Did you reboot? If you need to reboot again at this point (I did) you will get a ton of errors about gdm, X, etc. Ignore them. Login as root, init 3, carry on.

  1. Now that there is a new xorg.conf, run

aticonfig --initial --input=/etc/X11/xorg.conf

This adds the specific ati schmeck to the xorg.conf file. I don’t think you have to do anything in this step for nVidia, but I will test it at home on problematic XPC box.

i added this from another post i found:
rm /usr/lib/dri/ && ln -s /usr/lib64/dri/ /usr/lib/dri/

  • This is for 64-bit users as the Driver will fail to work as it will try to use the 32-bit DRI
  1. Now run:

sax2 -r -m 0=fglrx

This tells Sax2 you want to use the cool 3d schmeck.

  1. REBOOT! Other directions insist you can just init 5 to restart X, or whatever, but I’m telling you, if you are a n00b and you just came from windows, go with your comfort zone and give your computer one last three finger salute.

after following this to a T i’m running fglrx

Couple of things about the last tutorial.

sax2 doesn’t work properly if an X server is not already running (for me at least). So working in runlevel 3 doesn’t work so well.

Either way I have managed to get around it and try several things. I never get it to work. (3D that is…basic 2d drivers run [although could be default drivers for all I know])

When running the installer I get two messages reguarding a failure to write to the driver location a .so file (library).

Otherwise the installer says it is successfull and if I delete the mentioned files and run the installer they are created. I’m assuming the messages don’t mean a whole lot.

I have also tried installing by creating an rpm with the kernal source…I get the same result.

Two questions:

  1. Any thoughts on how to fix my issue. Brand new card Radeon 4870
  2. What does it take to get the drivers added to the repository. Considering ATI (AMD) is trying to support linux and they even have suse as a supported distro it would be nice to return the favor. (not trying to rag, I work in opensource myself and understand that it is people’s own time)?