ATI Driver broke GUI?

Hi, I’m new here and to linux in general.
Earlier today I installed openSUSE 11.3 on my 64-bit system. It seemed to work and I logged on and installed flash player, etc.
I downloaded the proprietary ATI drivers from the wiki page because I wanted compiz effects and all that good stuff. It appeared to work.
Unfortunately, after I installed the driver desktop effects crashed whenever I tried to open it.
So, I did the logical thing and restarted.
Now, when I try to start my openSUSE OS it looks like it starts to load and then stops and starts loading the command line in grub or something.
sooooo does anyone have any ideas? :stuck_out_tongue:
Thanks for the help in advance

System specs:
intel core i7 x920 (2.0ghz)
8gb RAM
ATI Radeon HD 5650 1gb
dual booting openSUSE 11.3 with windows 7

again, i’m a complete noob with linux so i apologize for any lack of knowledge i might have
thanks :slight_smile:

Its possible you have been unlucky, as from what I have read, a security update to the kernel has broken the ATI proprietary graphic driver: ATI Catalyst graphics driver install failure in SuSE 11.3
… whats worse (in my view) is it is the sort of break that I suspect we may not see a fix fast coming. There is a work around available, but some claim the work around is a security risk, and its not clear to me how easy it is to apply the work around, as I could not understand the work around update instructions.

You may be best trying to use the opensource radeon driver.

Some graphic card theory: openSUSE Graphic Card Practical Theory Guide for Users

My apologies if the above gives too little, or too much (and hence insulting) information. Its very difficult at times to assess a user’s knowledge level.

Hi, thanks for the reply.
It seems like that might be my problem, as I installed a security update right before installing the ATI driver (lol)
I just tried booting into my system using the failsafe mode and it allows me to get into the GUI, if that helps identify the problem.

I’m too tired to read that entire thread at the moment (it’s 2am :P) but will it tell me how to replace my drivers? I’m assuming it will be made easier because I CAN get into my GUI
My linux knowledge is limited to the ls and cd commands but I’m decent with computers.

thanks for the help

It provides general knowledge such that you will better understand recommendations given, but it will not provide step by step advice.

What you may need to so, is to reconfigure your openSUSE to use the opensource radeon driver, instead of the proprietary fglrx driver. To do that you could search for any rpm with fglrx in the rpm name, and remove that rpm. In addition, specify ‘nomodeset’ as a boot code, and in addition in the /etc/X11/50-device.conf file, remove the comment ’ # ’ in front of the ‘Radeon’ driver entry. Then try a reboot so as to use the radeon driver.

BUT FIRST, read that theory link so that the above advice makes a bit more sense.

okay XD

how exactly do i search for an installed rpm?
the man pages in konsole tell me this:
rpm {-q|–query} [select-options] [query-options]

but i do nawt understand

edit edit: is rpm -q fglrx the proper format?
if so apparently it is not installed
so… what happened to my computer?
i’m guessing it’s booting into level 3 for some reason?

To search for an rpm with fglrx in the file name, type this:

rpm -qa '*fglrx*'

connor@linux-oww8:~> rpm -qa ‘fglrx

is what comes up
im assuming these are two separate drivers, and if so how exactly do i remove them safely
pardon my ignorance, i just don’t want to damage anything haha

also if you wouldn’t mind letting me know what exactly the ‘nomodeset’ boot code does, i’d appreciate the info. a google search pulls up little useful information

i dont seem to have a /etc/x11/50-device.conf file
i do have an xorg.conf is that equivalent?

here are the contents of said xorg.conf file

Section “ServerLayout”
Identifier “aticonfig Layout”
Screen 0 “aticonfig-Screen[0]-0” 0 0

Section “Files”

Section “Module”

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
#BusID “PCI:1:0:0”

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24

what im getting is that the proprietary driver is infact driving my computers graphical stuff

unfortunately i have no idea how to change this :stuck_out_tongue:

edit edit: i’m currently doing all these thangs in failsafe mode, which works i’m assuming because of the nomodeset boot code
unfortunately the nomodeset dealie seems to make everything look like ****
after i fix my drivers will i be able to get rid of the code?

thanks a lot for the help

You looked in the wrong place. The file is /etc/X11/xorg.conf.d/50-device.conf.

Note Linux is case sensitive. ie it is X11 not x11.

You need to REMOVE the two rpms with fglrx in them.

Also, if you have an /etc/X11/xorg.conf file, you need to change the line

Driver "fglrx"


Driver "radeon"

sorry, that was your bad though just saying haha :slight_smile:


but i think im good
thanks a lot for the help ill let you know if things go awry

how exactly do i remove the files? i’ve tried rpm -e filename but it just says the package is not installed


so the edit button seems to have disappeared but i appear to have been successful

unfortunately i still dont seem to have any compositing or 3d effects with my current driver
will the radeonhd driver be better for this kind of thing?
i really want wobbly windows lol

sorry that ****ed edit button seems to keep eluding me

but anyway would you be able to help me get the radeonhd driver working? or set up 2d/3d acceleration and compositing with the radeon driver if possible?

ive tried to change the value in the xorg.conf file to radeonhd but that just made my system boot into level 3 again
ive also tried changing the value “radeon” in the 50-device.conf file to “radeonhd” and replaced the # but my system still did not boot
any suggestions?

also all my desktop effects seem to have vanished
ive also managed to get transparency working by changing the compositing type to xrender but my gut tells me opengl works better

The radeonhd driver is not as supported as much as the radeon driver. But to get the radeonhd driver working, you just replace ‘radeon’ with ‘radeonhd’ in the /etc/X11/xorg.conf (and/or /etc/X11/xorg.conf.d/50-device.conf file) and reboot, knowing of course there is a risk this could break your graphics and you may need to edit those files from a full text mode next time with a text editor (do you know how to do that ? ) …

Sorry, I can’t help with 2d/3d acceleration … I’m not a big user of such fancy graphics as the eye candy simply slows down my system.

I don’t think removing KMS (using nomodeset) is a good idea as you lose a lot of the 3D capabilities even with the opensource radeon driver. You need 3D capabilities in order to use desktop effects using OpenGL. XRender is slow so I don’t recommend it.


yes i know how to do that and unfortunately when i tried this my system booted into runlevel 3 again :frowning:

i also switched the compositing type to XRender (in X, obviously) from the desktop effects settings app and it won’t let me change back to openGL

CDClock, you can try this if you have the time. Assuming you have a fresh install, this should finish in maybe less than an hour.

Getting Catalyst 10.9 to Run on openSuSE11.3 x86_64 (kernel


  1. Fresh standard install of openSuSE 11.3 x86_64, with KDE Graphical Desktop Environment.

  2. You have already verified that your graphics card is supported by ATI’s Catalyst drivers.

Prep Stage

1. Determine your installed kernel flavor.
Issue this command from the terminal: ‘uname -r’
Output is something like: 2.6.x.y-pae or 2.6.x.y-smp or 2.6.x.y-desktop depending on your system. Let’s call this your kernel flavor. You will need this info when you get to Step 3 below.

Note the default video drivers loaded/used by KDE.
Click on “My Computer” on the default plasma folder. Note the details provided in the ‘Display Info’ section, particularly the 2D and 3D drivers currently used by X.

2. Get needed packages.
Make sure the following packages are available: {gcc, make, patch, kernel-devel, kernel-flavor-devel,kernel-source, kernel-syms, module-init-tools, glibc, glib-devel, zlib*, libstdc++, libgcc}

3. Update your openSuSE sytem to install all NEEDED patches.
You will be asked to reboot, and your kernel will become or something similar.

4.Get the latest Catalyst Display Driver (Rev 10.9) from ATI’s website.

5. Remove any pre-existing fglrx modules running on your system.
Ignore this step if no fglrx modules are running and loaded in your system.
(Command to list existing fglrx modules) rpm -qa | grep -E ‘fglrxG01|fglrxG02’
(Command to remove existing fglrx modules) zypper rm 'rpm -qa | grep -E ‘fglrxG01|fglrxG02’ ’
(You can also use YaST to remove the existing fglrx modules if you want, instead of zypper)

Install Stage

6. Go to runlevel 3, log-in and become the superuser. (init 3 / telinit 3)

7. Get Sebastian Siebert’s script.
This script will simplify and automate patching of compat_alloc_user_space() which if not done will break the compile process for ATI’s Catayst Display Driver with kernel
This script will also check for needed packages and get them for you automatically. It then runs ATI’s installer to automagically set things up for you! (Thanks and credit to Mr. Sebastian Siebert).


8. Get download checksum and verify integrity of downloaded file.


sha1sum -c

Screen output should be like: OK

9. Change file ownership and permission of downloaded script file.

chown root:root
chmod 744

10. Finally, run the script.

./ -i

That’s it. Reboot your machine and check the display drivers loaded by KDE in ‘My Computer’.

And oh, Sebastian Siebert offers an optional but highly recommended step to ensure that the system will build the fglrx kernel module before starting the desktop GUI environment in case another kernel update becomes necessary. (./ -irs)

[Thanks to Google Translate which allowed me to understand Mr. Siebert’s instructions in his website]

Let me know if this solved your problem.


hi i tried those steps
i forgot to download all of the stuff in step two but i think the file got them all for me because it downloaded a bunch of stuff
according to the program it was successful but upon boot my graphics effects were going slower than usual, and my display driver is still radeon but the 3d swrast driver is no longer listed (there’s no 3d driver at all)
also my desktop effects applet is crashing again :S

thanks for the help anyway and i appreciate any further input you might have

EDIT: here is the crash report developer dealie stuff:

Application: System Settings (systemsettings), signal: Segmentation fault
[KCrash Handler]
#5  0x00007ff4ea72d0be in XF86DRIQueryVersion () from /usr/X11R6/lib64/
#6  0x00007ff4ea72d259 in XF86DRIQueryExtension () from /usr/X11R6/lib64/
#7  0x00007ff4ea72cb6c in ?? () from /usr/X11R6/lib64/
#8  0x00007ff4ea70c4af in ?? () from /usr/X11R6/lib64/
#9  0x00007ff4ea708861 in ?? () from /usr/X11R6/lib64/
#10 0x00007ff4ea708a3e in glXChooseVisual () from /usr/X11R6/lib64/
#11 0x00007ff4d9a5c94a in ?? () from /usr/lib64/kde4/
#12 0x00007ff4d9a5e768 in ?? () from /usr/lib64/kde4/
#13 0x00007ff4d9a60366 in ?? () from /usr/lib64/kde4/
#14 0x00007ff4d9a60c4c in ?? () from /usr/lib64/kde4/
#15 0x00007ff4f69cca1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/
#16 0x00007ff4f69ca22e in QObject::event(QEvent*) () from /usr/lib64/
#17 0x00007ff4f755d4d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/
#18 0x00007ff4f7565aca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/
#19 0x00007ff4f8181c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/
#20 0x00007ff4f69b8e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/
#21 0x00007ff4f69e40c9 in ?? () from /usr/lib64/
#22 0x00007ff4f69e0fd4 in ?? () from /usr/lib64/
#23 0x00007ff4f3bc8a93 in g_main_context_dispatch () from /usr/lib64/
#24 0x00007ff4f3bc9270 in ?? () from /usr/lib64/
#25 0x00007ff4f3bc9510 in g_main_context_iteration () from /usr/lib64/
#26 0x00007ff4f69e167f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
#27 0x00007ff4f75fe14e in ?? () from /usr/lib64/
#28 0x00007ff4f69b8292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
#29 0x00007ff4f69b8495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
#30 0x00007ff4f69bc88b in QCoreApplication::exec() () from /usr/lib64/
#31 0x000000000040fc86 in _start ()


i also ran the rpm search for fglrx and nothing came up :S

connor@linux-oww8:~/Downloads> rpm -qa | grep -E ‘fglrxG01|fglrxG02’