ATI 9000 RV250

I wasn’t sure where to post this or what to use as the title.

Therefore, I tried to have everything as specific as possible.

The machine that I have the issue with is a laptop. To be even more specific, a Thinkpad T41 with the following graphics card:

IBM ThinkPad T41 , model 2373THD
VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)

Issue: Cannot enable 3D effects or 3D effects results in lockup
OpenSUSE 11.2 - KDE - cannot enable XRender - receive a message that it can’t be enabled and to check my configuration file; enabling OpenGL results in the screen going black and a white cursor showing - laptop is totally locked up and requires a hard restart i.e. power off/on

Is this a bug or a familiar state? I’m just curious what the situation is. Does it require an edit of xorg.conf and if so, what should be there?

I’ve only used live media to test so far so if I can solve it via live media for now, that would be great.

I guess my machine is quite old for using 3D but it would still be interesting to learn whether this issue could be solved.

Thanks for reading!

Numerous threads on this topic within these forums. Sadly, I think your hardware is consigned to using the (limited) radeon driver now (as is my X300) should I choose to ‘upgrade’ to openSUSE 11.2 version.

I’ve had success on one machine using the ATI proprietary driver. This thread has patches. I’ve followed directions for the patches and built an RPM. It worked on one machine, not another.

What was the general consensus then of what to do? Was there any?

I understand that the open source radeon driver is the main (only?) choice. However, as I previous stated, it works but only in 2D mode. That is, the default setting works since no 3D effects are enabled. When I enable 3D, I have issues presented that corrupt X. The last time I tried, one of the settings (OpenGL or XRender) makes the screen go ‘black’ with a frozen/locked white cursor displaying.

I recently tried a few things using an Ubuntu Live CD. I edited xorg.conf and had some success at getting 3D to work. I chose Ubuntu since it gave the worst experience OTB. Would this edit apply to OpenSUSE, too? I suppose so, huh? I should try it.

Anyway, I can post what I tried. Can anyone give me any feedback on what it is doing and why it ‘helps?’:

Section "Device"
     Identifier      "Radeon 9000"
     Driver          "ati"
     BusID           "PCI:1:0:0"
     Option        "BusType" "PCI"
     Option         "AGPMode" "1"
     Option          "AccelMethod"   "EXA"

Section "Monitor"
     Identifier      "InternalLCD"
     Option          "DPMS"

Section "Screen"
     Identifier      "Default Screen"
     Device          "Radeon 9000"
     Monitor         "InternalLCD"
     DefaultDepth    24
     SubSection "Display"
             Depth           24
             Modes           "1440x900" "1024x768"

Nevermind. It didn’t work anyway.


Refer this > Radeon - openSUSE

I have IBM ThinkPad T60 with Ati Radeon x1300 graphics & encountered similar problem. I beleive above link will be definitely useful to you.

I just followed tutorial and it worked!

  • ran Sax2
    -It created xorg.conf file under /etc/X11
    -Did vi to xorg.conf
    -renamed radeonhd to radeon as my chip set is not hd
    -saved the file
    -logged off and logged in back
  • ran rendering test and got output as YES.


The open source driver has a lot of features off by default, because not all of them are stable on all configurations. By explicitly providing an xorg.conf, you override those default settings and can get better performance. Also, in my case, HAL didn’t seem to properly detect my card bus type; by explicitly setting it things became a lot more stable.

I wouldn’t just copy that config from wherever though, since a lot of the settings are very specific to your machine (i.e. “BusID” has to be whatever the BusID of your actual card is). Also, the driver name is wrong in that config; it’s supposed to be “radeon”. I’d follow the instructions in the wiki page that sco1984 posted a link to, because I wrote it. lol!

One problem is that this program, Sax2, is unreliable.

I was able to start it initially but when I wanted to modify a setting, the icon just bounces and then disappears. Nothing starts.

When I was able to run it the first time, I could enable XRender but not OpenGL. It’s an improvement but not useful if you can’t run the utility. The xorg.conf generated is quite extensive, though. That part in interesting.

Other than that, it’s disappointing.

Is there no update with this issue yet?!?

I was just curious: what bus type should be set for my card, RV250? I tried both but there was no real difference in result.

You have a few issues here, which ones are still bothering you?

RV250 is your chipset, not your card. You need to find out what your card is, and find out what bus type it has.

Using Google, I found this:
ATI Mobility FireGL 9000 - ThinkWiki

Assuming the same card is inside your Thinkpad, you should probably set BusType to “AGP”, and if you want a little more performance, set AGPMode to “4”.

I wouldn’t use SaX2 for anything other than generating an initial xorg.conf. It will not let you configure many of the driver settings.

Are you using KDE? I’m pretty sure that’s a bug with kdesu not starting, and not directly related to SaX2. I’m not sure what causes it or how to fix it (there are probably other threads about this that I have not read), but you can start SaX2 by running it in a terminal window as root.

Let’s make sure OpenGL is working… type “glxgears” in a terminal window. A new window should pop up with spinning gears if it’s working. If that doesn’t happen, tell us what you see.

I followed and ran the tests. glxgears ran okay. glxinfo gave interesting info. Everything seems to check out okay but what about this?:

OpenGL version string: 1.3 Mesa 7.6

I followed this:
Radeon - openSUSE

but, on that page, ‘OpenGL version string: This should have something like “1.5 Mesa 7.6.1” or something similar.’

1.5 v.s. 1.3?

Testing 3D effects and there is no change. Black screen after you select ‘Desktop Effects’ and a white arrow cursor frozen there.

So, I am wondering if there is any update to this problem in OpenSuse?

I do not know if this will help you, but it worked for my wife’s PC with openSUSE-11.2 and an RV280 graphics from ATI.

In essence, some openSUSE-11.2 users with “legacy” ATI hardware have found they get better behaviour on openSUSE-11.2 from the open source radeon and radeonhd drivers if they use the updates from the X11 : XOrg repository. That repository is here:

… and the rpms that some of us found gave better behaviour are these apps:

  • mesa
  • xorg-x11-driver-input
  • xorg-x11-driver-video
  • xorg-x11-driver-video-radeonhd
    and possibly ( ? ) others for a 64-bit openSUSE ? … (I tried them on a 32-bit PC). One caution - that tends to be a cutting edge repository, so there is always a risk it will make things worse when a cutting edge release has a bug.

Do you need help in doing this? or is the above enough guidance for you to go on?

If the download goes okay, I think I can manage but thanks.

I’ll try it on my own and post again if I need any guidance.

Thanks for that idea. Btw, Lucid (only tried LiveCD of Alpha2 stage though) seems to have fixed the ‘kinks’ that caused me problems in Ubuntu 9.10 so maybe that ‘cutting edge repository’ is doing the same thing. I hope so. :slight_smile: