At shutdown both splash background and text are shown ...

Hi valuable friends
I’m running openSUSE 11.2 kde on msi wind u123. Everything runs fine except that whenever i try to shutdown or restart system i see both splash background and the rolling text. I think i should only see the splash with the progress bar until shutting down finishes. But for no apparent reasons i see both which is very annoying.

It might help that i changed the splash screen to a custom one. Here is the one i use and i followed every single instruction.

I’m confused i need help please. Thank you all

Welcome here to the forums.

While waiting for advice (and may be checking if your own splash is not the cause of this), please try not to shout at us. Everybody here seems to be able to use the default font. No need to use that alarming font for the whole of your post. It may shy people away and that is definitely not what you want.

I’m sorry it was my first post and not on purpose. I just though small font would not be good
I apologize again. Thanks for the note.

No hard feelings. Youa are welcome indeed.

I hope somebody who did what you did with the splash screen will join here. But it could take some time. Remember that we are all over the world and some of us need sleep from time to time.

The exact problem is that the system forces verbose mode on shutdown/restart …
The question is how to force splash on shutdown/restart …

Thanks in advance for any contributer

For the splash screen it is in the Grub configuration where the kernel parameters are. By default the splash is witched on (no splash parameter in the entry in grub) and


switches it off (there are some more options).

Thanks for the reply. But do you mean there are two triggers? one in grub (menu.lst) and another somewhere else? sorry its my first time to use opensuse.

By the way, the system boots fine with the splash. its just the shutdown/restart

Boot is (re)start. and the oposite is shutdown.
And it is a kernel parameter. The default way to get kernel parameters to the kernel is having them in the grub entry. I know of no other place.
You can of course overwrite the default by typing kernel parameters in the grub screen.

Thanks Henk but i still have problem in shutdown its too ugly. Any other suggestion?

My shutdown is OK and that is the original installed one. When you say you changed your shutdown picture and after that you got a problem, imho you should thouroughly inspect that picture and the way you replaced the bootsplash. I supposed you did something within /etc/bootsplash/themes/ and changed /boot/message.
When you want help on that, maybe publishing of the picture and more about what you did might help people here might have suggestions. They can not when you do not give something to look at.

OK. Here it is:

The system was working very good until i wanted to change the bootsplash. I head over “”](
I found good bootsplash in this page: “”]( I downloaded it, direct links are there.
After that i followed the steps:

  1. Make the following as root user
  2. Unpack the *tar file
  3. Copy the folder SuSE-Elegant to /etc/bootspash/themes/
  4. Open the file bootspash on /etc/sysconfig/
  5. Change the line THEME=“openSUSE” to THEME=“SuSE-Elegant”
  6. On a terminal type mkinitrd
  7. reboot

Since then the system boots fine with the nice bootsplash but shutdown process have both new splash (without progress bar) and console text.

I restored the original bootsplash and every thing returned to normal. So i suspect the downloaded bootsplash is the one with problem. Am i right? If so, anyway to fix it?

I wish i can upload a picture but i don’t know how to capture one from my netbook during shutdown.

I understand that that is a problem. Can only be soved by using a camera :wink:

I also think your description about what you did is clear now. Thanks for that.

Let us wait and see if anybody here did about the same.

On 2010-07-02 16:00 GMT funkymido wrote:

> Thanks for the reply. But do you mean there are two triggers? one in
> grub (menu.lst) and another somewhere else? sorry its my first time to
> use opensuse.



(If you change grub directly, it will not survive an update.)

I don’t know how to change/modify it, I never do: I prefer verbose
boot/halt, full of cute text messages flashing by >:-P

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

I’ve uploaded a clip to the boot/shutdown process if it helps (Thanks Henk for the idea)


Obviously some sort of transparency is being set. But where I don’t know look in the config files for this theme. It is possible that the designer spent a lot of time getting that effect. :slight_smile: I think it is neat myself. LOL

You are runner up for an Oscar with that one. Very nice. rotfl!

And yes, it is very strange. I can not say very much more than gogalthorp about it. Except: why isn’t the same effect shown during boot?

LOOOOL. I Wish to have that Oscar YES !

Ok, Problem solved. First of all great thanks to Henk and gogalthorp. Your help was very valuable.

Second i toke a look at the theme folder looking for the problem and comparing with the original theme provided by openSUSE.

Each theme mainly has this structure:
Folder [config]: this holds a configuration file per resolution
Folder [images]: in this folder there is two images per resolution. One is called bootsplash-[resolution] and the other is silent-[resolution].

bootsplash-[resolution] would be the background in verbose mode. And silent-[resolution] is the background in silent mode (no console text here)

All that was fine but i found that the config files of the new theme are missing some lines that does exist in the original theme. Those are:

  • trigger “isdown” quit
  • trigger “rlreached 5” toverbose
  • trigger “rlchange 0” tosilent
  • trigger “rlchange 6” tosilent

I searched the web and i knew that these four lines are responsible for telling the bootsplash when to switch to silent mode. While those are missing; The bootsplash wont change to silent mode at all as when the system send terminate signals the default is verbose mode.

For Henk question that is why isn’t the same effect shown during boot, I (think) it is because that i have the option splash=silent in my /etc/sysconfig/bootloader which activates silent mode at GRUB level before calling the bootsplash. Hence when bootsplash is loaded its already in silent mode so i see no problem.

That’d be all, Thanks for every one posted here to help me.

YES, you got it. Well done! It is often the case that asking stupid questions brings an OP to check for things he did not until that point in time. This is such a case. This is one of the big advantages of a forum like this one.

Nice you sorted it out and thank yo for reporting the solution here. I have learned from it also. And your conclusion about the kernel param overruling is correct imho.

Again well done. And visit again