asus xonar essence stx 2 ----> NO SOUND

hi all i have stx 2 and yast detect asus stx 2 but there is no sound. anyone can help me

this is the output

habernir@linux-j190:~> cat /proc/asound/cards
 0 [II             ]: AV200 - Xonar STX II
                      Asus Virtuoso 100 at 0xd000, irq 16
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 44
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17

What things have you tried to get your sound working ? Have you tried to configure and test your sound with YaST ? Does the test sound work there ? Have you tried to install pulse audio volume control (pavucontrol) and use it to configure your sound ? There is guidance here on a blog how to do that :

Have you checked your mixer to ensure sound is not muted ?

If you have tried all of that, and sound does not work, then could you then provide some more information ?

To provide more information, do so with your PC connected to the internet, and open an Xterm/Konsole and as a regular user in that xterm/konsole enter:


that will run a diagnostic script. Select the SHARE/UPLOAD option, and let the script run to completion. When the script is complete it will upload the configuration information on your PCs audio to the internet and it will provide the address/link in the konsole/xterm as to where that information is now located. Please post here that address/link/URL. I can take a look at it and see if it provides any clues as to why your PC’s asus xonar essence stx 2 has no sound.

thanks for your reply. the problem was that the power cable wasn’t well connected.

Glad to read its working now. Thanks for sharing your solution.