Asus UX31a OpenSUSE 12.2

Hi,

I installed OpenSUSE 12.2 on an ASUS UX31A (Zenbook Prime).

For Ubuntu (https://help.ubuntu.com/community/AsusZenbookPrime) and ArchLinux (https://wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A) detailed informations are available.

Whats working well out of the box:

  • installation worked well (I used the 64bit DVD installation)
  • speaker
  • microphone
  • webcam
  • WLAN
  • SD Card Reader
  • Touchpad! The Clickpad functionality is activated in 12.2 (right mouse button is working)! Great! You can also add horizontal and vertical scrolling using the synaptics/touchpad menu.
  • sleeping (powersafe) modes
  • external VGA (HDMI not tested) using a second display

Whats not working:

  • FN keys for brightness, keyboard backlight and volume

Observations:

  • keyboard backlight is always on but after closing and opening the notebook lid, the light is off
  • brightness and volume can be also controled with the powermanagement applet and mixer applet
  • automatic connection to router using WLAN made problems (networkmanager). The access point was often not found when the automatic connection was enabled. When the automatic connection was switched off, the access point was always shown. Strange :.
  • the touchpad is too big. When typing, I’am often coming on the touchpad and the cursor is moving to somewhere and you are writing somewhere in the document.

Improvements:

Open:

  • I have still three “bad” points in powertop: VM writeback timeout, Autosuspend for USB device USB2.0-CRW [Generic], Autosuspend for unknown USB device 2-1.6 (8087:07da)
  • Switching off the touchpad when typing on the keyboard

Perhaps other Zenbook Prime users can add their experiences, improvements and tips.

Best wishes

Michael

Update:
Using the script /etc/udev/rules.d/10-runtime-pm.rules (linux - Powertop reports “Bad” “Runtime PM for PCI Device” - Server Fault) leads to switching off the USB ports in battery mode (not when connected to power supply).
Today, I recognised this when I tried to use a pointer or a mouse on battery mode.

I suggest not to use this script.

Michael

I had the same problem with an X53e and used the synaptiks package to “Automatically switch off touchpad on keyboard activity.” You can specify the length of time after the last keystroke before the touchpad becomes active again. I use 2 seconds.

Hi,

thanks for your answer! This is working. I reduced the time to 0.5 seconds.
Interestingly, this point is missing in the touchpad configuration menue (in systemsettings, input devices). You have to start “synaptics” and you will get the same touchpad configuration as under systemsetting and in addition the menu touchpad administration which is missing in the systemsettings. Here, you can switch off the touchpad :-).

Michael

Addition:
Screen brightness can be controlled by keys:
System Settings (german: Systemeinstellungen) > Shortcuts and Gestures (Kurzbefehle und Gestensteuerung) > Global Keyboard Shortcuts (Globale Kurzbefehle) > KDE Daemon (KDE Komponente: KDE-Dienst). Press on Increase Brightness (Bildschirmhelligkeit erhöhen) the button behind user defined (Benutzerdefiniert) and choose your key combination. I have choosen Ctrl + F6 for increase and Ctrl + F5 for decrease (because on these keys you would find also the symbols for increase/decrease screen light). Choosing FN + F5 or F6 is not possible.

I found this tip in following thread: http://forums.opensuse.org/forums/english/get-technical-help-here/laptop/478677-cant-manage-brightness-opensuse-12-2-a.html

Michael

What is battery life like with openSUSE?

Hi 6tr6tr,

It’s about 5-6 hours. I could be also more, if you adjust the screen brightness below 60%.

Michael

I’ll post my experience with my Asus Zenbook UX31E in this tread as I think the are very similar in hardware configuration.

I’v just installed 12.2 on my Asus UX31E and I must say that the result was a pleasant surprise. When I first got this machine I tried 11.4 on it, but that turned out to be a very bad experience. After a ram suspend with 11.4 the machine was unreliable - so I changed to Ubuntu until now. Now with OS 12.2 all problems has been ironed out and the machine is even better.

The install was not without challenges: I have full infrastructure on my network for PXE boot and install and with no drive in the machine, that seem to be the way to go. But after I succeed to PXE boot the machine I was stuck with a kernel without wired network support so the actual install would not start. Fortunately the install kernel did support the wireless network so I continued installation using wireless.

First to make PXE boot work:

  • make sure PXE is enabled in bios
  • Connect adapter in left side
    USB port and connect to a active network connection - boot and press ESC several times during power uu, to bring up the boot device menu

If your network adapter does not show up, recheck all above.

Immediately after the install: Run a full update. After this there is no need for special kernel or adjustment to make softkeys work.

After install every thing I have tested yet have work directly out of the box, including suspend to ram. (I forgot to make the swap partition big enough to enable suspend to disk). Battery time without any fine-tuning at all is in the area of 3 to 4 hours of light use (surfing non-animated pages and using terminal).

I had some problems that power unplug sometimes made the machine freeze completely, but after a bios update this problem seem to be solved.

Only problem left is that I cant find a way to disable the touchpad when I type. I simply cant find the setting caprus describes :’(

Well after posting I found the program to use is called syndaemon, so I created a small script as /etc/X11/xinit/xinitrc.d/pausepad.sh


#!/bin/sh
/usr/bin/syndaemon  -i .7 -d

adjust the delay value (the number after -i) after you preference and make the script executable.

Made good progress with 12.2 on my UX31A, but single biggest annoyance I have at present is with the USB ethernet dongle (kernel module asix.ko for AX88772B), which does not bring the network connection back up after a hibernate/resume. The only way I can get this working is to manually “rmmod/modprobe asix.ko” after resuming. Has anyone else seen this issue and/or come up with a solution ?

Otherwise it’s a lovely combination of hardware and OS :slight_smile: