Asus laptop AMD Ryzen™ 9 5900HX /NVIDIA® GeForce RTX™ 3050 Ti can't boot with GUI 

My New laptop **ROG Strix G15 G513QE (R9-5900HX,RTX3050Ti)
No any error notice during installation but I sure nouveau driver has been install.

But first boot can’t load KDE GUI, shows below

Wellcome to openSUSE Leap 15.3 - Kernel 5.3.18-57-default (tty1).
eth0: 192.168.XX.XX

localhost login: _

Any solutions to fix it ? many thanks for kindly help.

Try to boot with “nomodeset” and install the Nvidia Driver.

If you have Internet, you can do this also by:

zypper ar -f nvidia
zypper in -f x11-video-nvidiaG05

That should install all 4 nvidia packages.

“zypper inr” should automatically install suitable driver. At least that is how it is supposed to work.

Thank you!!

After install Nvidia driver and reboot.

shows below

failed to start X Display Manager.
welcome to openSUSE leap 15.3 - Kernel 5.3.18-59.19-default (tty1)

Do you think I have to install AMD and Nvidia driver ? as R9 cpu has a internal GPU

Thank you and install well Nvidia driver
after reboot I got below message …

failed to start X Display Manager.
welcome to openSUSE leap 15.3 - Kernel 5.3.18-59.19-default (tty1)


/sbin/lspci -nnk | grep -EiA3 'display|3d|vga'


cat /var/log/Xorg.0.log

Last one maybe on

/sbin/lspci -nnk | grep -EiA3 'display|3d|vga

got nothing.

cat /var/log/Xorg.0.log


If you have Internet, install susepaste:

zypper in susepaste


/sbin/lspci -nnk | grep -EiA3 'display|3d|vga' | susepaste -e 604800

Post the getting URL here.
You will get something, otherwise you have a false written command…
also post the URL:

cat /var/log/Xorg.0.log | susepaste -e 604800

Maybe its an AMD and Nvida graphics system…
Can you disable the AMD card in Bios/UEFI?

Sorry for my typo



Thank you for your suggestion.

Unfortunately, I don’t found the option to disable AMD card in Bios/UEFI.

You missed the pipe |

cat /var/log/Xorg.0.log | susepaste -e 604800

In words:
cat /var/log/Xorg.0.log Pipe susepaste -e 604800

/sbin/lspci -nnk | grep -EiA3 'display|3d|vga' | susepaste -e 604800

/sbin/lspci -nnk | grep -EiA3 ‘display|3d|vga’ Pipe susepaste -e 604800

And I think its a Problem between both graphics cards…
Disable the AMD.

Thank you

You can try to create a /etc/X11/xorg.conf.d/driver-nvidia.conf:

Section "Device"
        Identifier "Card0"
        Driver     "nvidia"

well, created the file and reboot.

then got a black screen…

Remove it.

Also if your Computer is starting without Nvidia drivers, revert it also…

Ok and tried to install Leap 15.2 but after install Nvidia driver got same result.

as well as Leap 15.3 with gnome and install Nvidia driver got same result alos.

Finally, I reinstall 15.3 with KDE plasma again without Nvidia and Mesa Nouveau driver
It will be able start GUI and try cat /var/log/Xorg.0.log | susepaste -e 604800 and /sbin/lspci -nnk | grep -EiA3 ‘display|3d|vga’ | susepaste -e 604800

it seems that this problem is caused by the Nvidia driver.



Finally installed well Tumbleweed.

Thank for all the friends who helped me.

what about helping others who may read this thread and explaining what you actually did to fix this problem?