Asus eeePC 1015PEM - Sound Problem

New eeePC 1015PEM netbook, 2GB RAM, 250GB HDD. Came with Win 7 Starter; I retained this and installed openSUSE 11.3 alongside.

Everything works well in Win 7. Most things also work well in oS 11.3, but there is a knotty problem with audio from the built-in speakers. Headphones are OK, but the speakers don’t work reliably. Others have reported this on similar machines, and a number of “fixes” have been proposed in a wide range of forums, but so far I haven’t found any that work.

I’ve actually installed oS 11.3 twice. After the first install I had no speaker sound at all, but after a day or two fiddling around it started to work of its own accord for no reason I could point to. For unrelated reasons (a silly mistake by me in Win 7) I then had to re-install oS 11.3 from scratch. This time the speaker sound worked after install, but then it dropped out again a couple of days later. Headphone audio has remained OK throughout.

I’m aware of and have applied the acpi_osi=Linux kernel parameter to enable the Fn keys on the machine (including sound volume and mute/unmute), so it’s not that. I’ve combed the forums and Google extensively for other suggestions, and have tried them - including installing alsamixergui. I’ve also installed a properly matched ALSA KMP which changed some of the alsamixer controls but didn’t cure the problem.

Since it all works very well in Win7 and works sometimes in oS 11.3, I conclude that the problem is not with hardware but is something in software. The question is, what have I missed?


I would like to help, but I am not familiar with this hardware. Hence I would need some more information.

First, from what I understand, you obtain sound from headphones, but NO LONGER from speakers. Is that correct ?

Second, please provide the information recommended to be provdied from our multimedia stickie: Welcome to multimedia sub-area and I’ll quote the relevant part to make this easier for you:

please post in this … sub-forum, providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](ImageBam)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](ImageBam)

followed by this (where in RED is the URL).](ImageBam)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on []( and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

I’d missed the sticky, but had seen some of this stuff elsewhere in bits and pieces. Thank you for making it so coherent.

Here goes …

The output of has been uploaded to

rpm -qa ‘alsa’ gives :


(Advice in another forum suggest3ed trying the kmp. It didn’t help.)

Output from rpm -qa ‘pulse’ is:


(Yast tells me pulseaudio is not installed, only those libraries, which is consistent with two other oS 11.3 systems I run here.)

rpm -q libasound2 gives:


uname -a gives:

Linux #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux

… and cat /etc/modprobe.d/50-sound.conf yeilds:

options snd slots=snd-hda-intel

u1Nb.TkKxqDmvYl9:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

Thanks again for your interest.


If you are going to install the ‘kmp’ then you should also update the alsa apps that go with it. The repository is here:

and that means update your alsa-utils, alsa-plugins, alsa, alsa-firmware, alsa-oss, and libasound2.

Note since these are on a different repository, you need to ensure you update and do not get confused by yast and fail to update (and this occurs to many openSUSE users). There are pix here trying to show you how the update is done: SDB:Alsa-update - openSUSE

Restart afterward and test.

Thank you again for your interest. I have updated the alsa packages as above; rpm -qa ‘alsa’ now yields:


There was a moment of hope when the speakers kicked in, but it only lasted for one boot, after which they reverted to silence which has persisted ever since. So I’m back at the starting-line.

I assume the sound card itself is working, since there’s no problem in Win 7 with the speakers; and in openSuSE 11.3 the headphones continue to work OK. Without knowing an awful lot about the technical details, that suggests to me that the problem lies somewhere in the connection between the card and the speakers, but only under Linux (and not always then, which is doubly confusing!)

I’m very happy to try any other suggestions …


I don’t see libasound2 in that list. Did you update that also ?

Sure did. Should have mentioned it - sorry. I’d updated to libasound2-1.0.23-78.1.i586

I said originally that I couldn’t see any sort of pattern in this behaviour that would point to the source of the problem and help solve it. That’s now changed.

Just to remind, the machine is an ASUS 1015PEM netbook, dual boot Win 7 Starter and openSuSE 11.3. The problem has been no sound from the onboard speakers (or, more accurately, sound from the speakers only sometimes) under openSuSE.

I’ve now discovered that if I boot to Win 7 and then restart (warm boot) to openSuSE, sound from the speakers fails. If on the other hand I shut down from Win 7 and cold boot to openSuSE, sound from the speakers is OK. Warm boot from openSuSE to openSusE is also OK, and from Win 7 to Win 7. The problem only arises in the case of warm boot from Win 7 to openSuSE.

In lay language a conclusion seems to be, therefore, that something in Win 7 retains a grip on something in the sound system that survives through a warm boot and which openSuSE can’t then handle, but that does not survive a shutdwon and cold boot.

Curious. But what is it? And can I do anything about it?


After another week I can now confirm the above, for whatever it is worth.

If I warm boot into openSuSE 11.3 by “restarting” from Win7, the onboard speakers do not work. If I cold boot into openSuSE 11.3 from a closed-down state, the onboard speakers work. This behaviour is 100% repeatable.

I’m not seeking further help with this, since there doesn’t seem to be any. But I thought the information might be useful to anyone else with this model EeePC who has encountered the phenomenon.


I’m having similar issues with linux in general on my eeepc 1015P. I’ve found that if I don’t have sound then I can quickly put the machine into standby mode and then restore it and sound comes back from the speakers.

It’s not isolated to OpenSuSE, as I had this problem on mint, ubuntu, crunchbang, and fedora. It’s 100% predictable, as you said in your earlier post.