ask for help on NetworkManager after the latest upgrade, Leap 42.1

Hi all,

My laptop is Thinkpad T550 with an Intel Wireless 7265 net card. My
system was upgraded from opensuse 13.2 and it worked smoothly for half
years after upgrading to Leap 42.1. Yesterday I did a upgrade as usual
and after that my wireless network did not work. I tried to figure out
the problem, and found that the NetworkManager might be the reason. The
reason I draw this conclusion is that not only using the plasma applet of
NetworkManager but also using nmcli as root user I cannot scan the
wireless net, as show below:

nmcli device wifi rescan

Error: Scanning not allowed while unavailable or activating.

Meanwhile, when I use iwlist scanning I got the output like this:
ThinkSuSE:/home/ibex # iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 8C:21:0A:BA:C0:7C
Frequency:2.437 GHz (Channel 6)
Quality=59/70 Signal level=-51 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Extra: Last beacon: 12ms ago
IE: Unknown: 00076875616E676A69
IE: Unknown: 010882848B960C121824
IE: Unknown: 030106
IE: Unknown: 0706555320010D14
IE: Unknown: 2A0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32043048606C
IE: Unknown:
IE: Unknown:
IE: Unknown:
IE: Unknown:
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown:
IE: Unknown: DD0900037F01010000FF7F
IE: Unknown:

(the output is length, I only paste the first cell here.)

I even can use wpa_supplicant and dhclient to get an ip address on my
wireless card, as:
wpa_supplicant -i wlan0 -c ./wpa_config
dhclient wlan0

however, after all this I still cannot ping any address in WWW, while by
the wired net card it works as before.

I also checked the log of systemd by

systemctl status

and find the NetworkManager complains as :

NetworkManager[1108]: <error> [1456047017.557955] [supplicant-manager/nm-
supplicant-interface.c:737] interface_add_cb(): (wlan0): error adding
interface: Timeout was reached
NetworkManager[1108]: <info> (wlan0): supplicant interface state:
starting -> down

Is there any one who can give me some suggestions? Thanks.


i cannot help but i have the exact same problem on Tumbleweed (/etc/issue “Welcome to openSUSE 20160223 “Tumbleweed” - Kernel”, Kernel 4.4.1-1-default


Hi again,

i solved it after reading this post

Turns out i somehow fetched wpa_supplicant v2.5 from the hardware repo. In the official repos v2.4 is available. Changing back to v2.4 solved my issues.