Asian mirrors downloads blocked due potential security risk

Atleast half of asian mirror downloads getting blocked by Firefox due potential security risk in each openSUSE distro download.

It helps to describe a problem as detailed as possible so that others may be able to help you…

  • which Firefox version from where?
  • what is the exact error message and where do you see it?
  • what do you try to download? The installation ISO or a single rpm?
  • what is an example URL which is “blocked”? “Half of the asian mirrors” is as unprecise as it is possible…

Iso file tumbleweed mirrors cqu.edu.cm and nju.edu.cn before I switch to Europe mirror now there is more mirrors yesterday same error in Firefox saying file not downloaded: Potential security risk

Firefox version 127.0.2 flatpaks

Yesterday same error different servers downloading kalpa and aeon so mostly now using Europe mirrors and no issues

Seems like a flatpak issue then. MozillaFirefox-127.0-1.1 from openSUSE OSS repo works flawlessly with these two named mirrors.

Or have a look here:
https://support.mozilla.org/en-US/questions/1419499
But a short test with the openSUSE version shows, that these setting is not required, as the download URLs for the ISOs are all https.

1 Like

Thank you so it is pretty much flatpaks issue

Neither of these is listed on openSUSE mirrors page. There is mirrors.nju.edu.cn which works. The nju.edu.cn host name does not even exist.

You are correct on web it shows that as mirror.nju.edu.cn

Flatpaks download side with error it shows only nju.edu.cn