Article: How to Install Dropbox (Gnome)

How To Install Dropbox in openSUSE (Gnome)

Updated Decmber 2013 for openSUSE 13.1

Add the repo for your openSUSE version:

**No repos need be added in 13.1, just run the following:

su -
zypper in dropbox nautilus-extension-dropbox

**Now go to part 2

As for 13.1


Now do this in a user terminal:

dropbox start -i

This should start this:

Then OK this and:


Just follow the prompts to create the account entering your email address and a password for your dropbox account: Install/drop4.png

Logout and back in and you are done.

Thank you for writing this article! I had tried to install this software by building the dropbox in 11.4, and encountered some unresolvable deps … for instance, the config asked me for an EARLIER version of the nautilus-extensions package than I’d on my machine …Is there a place, by the way, where information about such softwares is available?Thank you, again.Tom R

Thanks so much for this. Clear, concise and it f*****g works just as you describe. I wish all how to’s in Suse were this straightforward. Much appreciated. Matthew

after downloading the dropbox daemon i get following messages…

dropbox start -i

Starting Dropbox...Traceback (most recent call last):
File "/usr/bin/dropbox", line 365, in handle_data_waiting
File "/usr/bin/dropbox", line 375, in unpack_dropbox
name, i, total =
File "/usr/bin/dropbox", line 267, in unpack
if not verify_signature(StringIO.StringIO(DROPBOX_PUBLIC_KEY), signature, self.local_file):
File "/usr/bin/dropbox", line 200, in verify_signature
with gpgme_context([key_file]) as ctx:
File "/usr/lib64/python2.7/", line 17, in __enter__
File "/usr/bin/dropbox", line 184, in gpgme_context
ctx = gpgme.Context()
gpgme.GpgmeError: (32, 176, 'Not operational')

how i can move this python-gpgme to working?

Same message as Martin1986. x86_64, openSUSE 12.1-3.1.0-1.2. Installed nautilus-dropbox is 0.7.1-1.1, prompted to install gpgme before continuing install to add signature services. Installed gpgme is 1.3.1-19.1.3. I have not used any PGP signature services yet, is it looking for some missing configuration steps?

I can’t test this right at the minute, so I started a bug report


having problems with this. i have run the commands as directed above but zipper doesnt find the required packages. Can anyone advise where i might be going wrong?

linux-spv2:/home/graham # zypper ar -f [Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1]( contrib
Adding repository 'contrib' [done]
Repository 'contrib' successfully added
Enabled: Yes
Autorefresh: Yes
GPG check: Yes
URI: [Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1](

linux-spv2:/home/graham # zypper in dropbox nautilus-dropbox
Retrieving repository 'contrib' metadata \]
** (process:10543): WARNING **: The connection is closed

** (process:10543): WARNING **: The connection is closed

** (process:10543): WARNING **: The connection is closed
Retrieving repository 'contrib' metadata [done]
Building repository 'contrib' cache [done]
Loading repository data...
Reading installed packages...
Package 'nautilus-dropbox' not found.
'dropbox' not found in package names. Trying capabilities.
No provider of 'dropbox' found.
Resolving package dependencies...

Nothing to do.

The repos has been changed to
Index of /repositories/network/openSUSE_12.1

So just for clarity until I edit the guide properly. You should remove the contrib repo (unless you need it for something else)

zypper rr contrib

Add the new repo (lets call it dropbox so you know why you added it)

zypper ar -f dropbox

zypper ref
(a) to accept

zypper in dropbox nautilus-dropbox

Thanks! There is the solution of this problem: just remove package python-gpgme
So I have installed the dropbox!!!

Correct .

Thanks, it works also for me. For the dummies like me I would like to remember that the python-gpgme package must be remove leaving gropbox and nautilis-dropbox. rotfl!

I understand this issue is now resolved. It is at my end anyway.


Many thanks for the updated instructions. Worked a treat!