Ark unable to open .rar?


I tried asking this on IRC channel, but I got no reply so trying my luck here.
I’m using fully updated Tumbleweed with added KDE frameworks, KDE applications and KDE extras repos.
I have both rar and unrar packages installed on my system. When I try to open a rar archive, I get:

Ark was not able to open archive.rar. No suitable plugin found.
Ark does not seem to support this file type.

If I launch ark from terminal and try to open rar archive I get this terminal output:

ark.kerfuffle: Could not find a plugin to handle "/some/random/filename.rar"

I had no issues with opening rar until recently, so I’m suspecting a regression in one of the recent updates.
Could anyone please verify?

Thank you

where did you get the rar and unrar packages as you didn’t mention packman
post the output of

zypper info rar unrar

I do have packman. Here’s the output you requested:

Information for package rar:
Repository     : Packman Repository                       
Name           : rar                                      
Version        : 5.4.0-1.1                                
Arch           : x86_64                                   
Vendor         :            
Installed Size : 1,6 MiB                                  
Installed      : Yes                                      
Status         : up-to-date                               
Summary        : Compression and decompression program rar
Description    :                                          
    Compression and decompression program.

Information for package unrar:
Repository     : openSUSE-Tumbleweed-Non-Oss                      
Name           : unrar                                            
Version        : 5.4.5-1.3                                        
Arch           : x86_64                                           
Vendor         : openSUSE                                         
Installed Size : 342,2 KiB                                        
Installed      : Yes                                              
Status         : up-to-date                                       
Summary        : A program to extract, test, and view RAR archives
Description    :                                                  
    The unRAR utility is a freeware program distributed with source code
    and developed for extracting, testing, and viewing the contents of
    archives created with the RAR archiver.

that looks right
I’m on leap with plasma 5.7.5 ark 15.12.3, and Frameworks 5.26.0
all is fine
I’d suggest you start ark from a console try to open a rar file and see what the console prints out
it could be a tw issue

I’ve already stated what happens if I start ark from console in the OP.

I suspect the cause is the update to shared-mime-info package.
This might be relevant:

“Have you updated to shared-mime-info 1.7-1? If so, that might be causing the problem. It looks like they changed the mimetype naming for rar (from “application/x-rar” to “application/vnd.rar”) and that apparently breaks some applications that open rar files.”


I don’t think so I opened a cbr file from a console, ark printed out an warning that I wasn’t opening a application/x-rar (it’s a renamed rar) but still opened it, from your error

ark.kerfuffle: Could not find a plugin to handle

it looks like the rar plugin has issues with calling or finding the rar/unrar executable
I’d try a test, rar an image file and rename it to somefile.cbr does okular open it?
why to be sure that it’s an ark not a (un)rar issue.

ps I think this is a bugzilla moment

I’m happy to report that today’s update fixed it. Updated packages were:

  • libkerfuffle16 16.08.1
  • ark 16.08.1

Thank you

shared-mime-info has been updated to 1.7 in Tumbleweed 3 days ago.

We added the fix to our ark package, but it is not in Tumbleweed yet (has to go through staging and review first).

You can get the fixed version from KDE:Applications already.

Though normally you should not have a need to use KDE:Applications and KDE:Frameworks5 on Tumbleweed, you will get exactly the same from the standard repos, just some days later (because of staging, review and testing)…

I am resurrecting this thread because I now have the same problem with Leap 15.

After I upgraded from Leap 42.3 to Leap 15 the tool unrar was no longer available with the distribution.

I have the rar package installed from the Packman repository.

Ark no longer recognizes an RAR archive.

If I install the Leap 15 available tool unrar_wrapper, then Ark is able to recognize it as an RAR archive, but it reads it as an empty archive.

You have a similar problem, perhaps, but it is not likely the same problem.

Forum Rules discourage resurrecting threads. Please start a new thread with your issue that is not Tumbleweed, and give error messages.

This thread is now closed.