apple bluetooth wireless keyboard and mouse

couldn’t wait to get 12.1 now that it’s finally out i have installed on a dell inspiron 531 that has been upgraded for performance. i have a nice 23" lg monitor connected and the install screens looked awesome as they did on my imac 20". on to the issue, during install my apple bluetooth wireless keyboard and magic mouse worked during install i only had to click the mouse a couple times and it connected, on the keyboard i hit a key a few times until it was recognized. once i got to the login screen neither device worked. i found a usb keyboard & mouse and got logged in. when i try to use the mouse it says a pin is needed i tried 0000 & 1234 but neiter worked. the keyboard doesn’t do anything at all when i press the keys, opensuse doesn’t even see it. can anyone help? pleeeeeeeeeeeeeeeeeze:disapointed::disapointed::disapointed::disapointed:

update somehow the bluetooth manager decided to work and accept the pin for the mouse then i had to connect and move the mouse to get it to recognize it. still no keyboard :frowning:

I realize it’s horribly documented by apple as I went through this frustration as well. The pin is set by you, ie. type in the pin upon setup on your computer ie. 1234 and click “ok/submit”… right after that on the keyboard type 1234 and “Enter” <— on the keyboard.

and you’re good to go.

Now let me know if you get that darned fn key to work.