AppImages stopped being executable after update


Disclaimer: I am a new openSUSE TW user, I just installed it on wednesday.

This morning, I had a notification that I had 178 updates, and I updated through the gui. The update was successful, but now I get an error when I try to launch any AppImage.

The error I get says:

"Cannot mount AppImage, please check your FUSE setup.

You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
for more information "

I have tried to reinstall FUSE with Zypper and I get a message saying I have the morst current/up to date version.

Do you have any insight to why this error is happening? The error happens with all of my appimages so it isn’t a bug in one AppImage in particular. The AppImages were working fine yesterday, before the update.

Any help is appreciated in advance.

Hi, welcome

What GUI? YaST? That’s a no go. Some updater applet?
Best is to use

sudo zypper dup

as per documentation.

Hi Knurpht,

thanks for the reply, yes, the applet in the KDE system tray, in the bottom right hand corner, that had a notification pop up.

I was messing around and was able to re-chmod +x the appimages and try running them from the command line with ./random.AppImage, and 2 of the 3 appimages I use can be run from the command line, just not by clicking them in Dolphin file manager like before the update.

The 3rd appimage still throws the same Fuse error, even from the command line.

I will only update with zypper dup from now on.

The good thing about it, at least, is that my appimage for Bitwarden, my pw manager, still can be run from command line.

This was the major inconvenience caused by this issue, I was having to repeatedly manually type long passwords from looking at them on my other computer, which sucked. I can use it now, which is the most important thing.

Hi wasie,

I know it’s a bit too late to reply after a year since the last post on the thread,
but I think I can suggest something for those who happened to struggle with this issue.

I’ve just encountered the same problem on OpenSUSE Tumbleweed, but I saw some error messages when I try to run an .Appimage file.
It urged me to check the FUSE system repository wiki on GitHub ( ),

so I checked that out and found that under the ‘SECURE’ file permission on YaST, the user executing the .Appimage file MUST be a member of “trusted” group.
(the file permission setting can be found at “YaST Control Centre” > “Security and Users” > “Security Centre” > “Miscellaneous Settings”)

Then I tried running

 sudo usermod -a -G trusted `whoami` 

as on the GitHub page, and logged out and back in, which finally did the trick for me.
Now I can execute the .Appimage file from both command line and GUI.
I tried this with balena’s Etcher appimage file, but I think this will work for issues with other .Appimage files as well.

I have the same issue, and none of suggested solutions solved my problem. Weird thing is - some AppImages work well (Cryptomator, Bitwarden, PrucaSlicer…), some won’t start (FreeCAD, Tutanota, Wire…)
Here’s FreeCAD output for example

libGL error: MESA-LOADER: failed to open radeonsi: /tmp/.mount_FreeCAxBfYW9/usr/bin/../lib/ version `GLIBCXX_3.4.29' not found (requir
ed by /usr/lib64/dri/ (search paths /usr/lib64/dri, suffix _dri) 
libGL error: failed to load driver: radeonsi 
libGL error: MESA-LOADER: failed to open radeonsi: /tmp/.mount_FreeCAxBfYW9/usr/bin/../lib/ version `GLIBCXX_3.4.29' not found (requir
ed by /usr/lib64/dri/ (search paths /usr/lib64/dri, suffix _dri) 
libGL error: failed to load driver: radeonsi 
libGL error: MESA-LOADER: failed to open swrast: /tmp/.mount_FreeCAxBfYW9/usr/bin/../lib/ version `GLIBCXX_3.4.29' not found (required
 by /usr/lib64/dri/ (search paths /usr/lib64/dri, suffix _dri) 
libGL error: failed to load driver: swrast 
/tmp/.mount_FreeCAxBfYW9/AppRun: line 41:  1206 Aborted                 (core dumped) ${MAIN} "$@"

And here’s for Wire

(node:1661) UnhandledPromiseRejectionWarning: Error: ERR_INVALID_URL (-300) loading '' 
    at rejectAndCleanup (electron/js2c/browser_init.js:205:1493) 
    at Object.failListener (electron/js2c/browser_init.js:205:1706) 
    at Object.emit (events.js:315:20) 
    at NavigationController.reload (electron/js2c/browser_init.js:205:2748) 
    at BrowserWindow.n.reload (electron/js2c/browser_init.js:33:2136) 
    at App.<anonymous> (/tmp/.mount_Wire.A690eWw/resources/app.asar/electron/dist/main.js:267:18) 
    at App.emit (events.js:315:20) 
(node:1661) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function witho
ut a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use th
e CLI flag `--unhandled-rejections=strict` (see (rejection id: 1) 
(node:1661) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will te
rminate the Node.js process with a non-zero exit code. 
[1661:0930/] GPU process isn't usable. Goodbye. 
Trace/breakpoint trap (core dumped)

AFAIK zypper dup does the same thing as the KDE system tray . It just shows update notifications and when you click update it executes zypper dup