Apache directory listing empty

I’m try to get a apache to display the directory listing of a directory but I only get an empty list.

http://dl.dropbox.com/u/1212789/Capture.jpgHere is my virtual host config.

<VirtualHost *>
    #ServerAdmin ver3.pro-agent.com
 DocumentRoot "/home/joel/Desktop/repo/product/htdocs/site/"
 ServerName v3.devel.example.com
 RewriteLog "/var/log/rewrite.log"
 RewriteLogLevel 0

 <Directory /home/joel/Desktop/repo/product/htdocs/site>
  AllowOverride All
  Order allow,deny
  Allow from all
 ServerAdmin admin@localhost
 <Location /dojo-1.8>
  RewriteEngine Off
  Allow from all
  Order Allow,Deny
  IndexOptions FancyIndexing
AllowOverride None
Options Indexes FollowSymLinks MultiViews
LogLevel debug

Just a wild guess. You are trying to serve files that are owned by some user joel if I interprete correctly.
Did joel create enough permission so that the apache process (running as user wwwrun and group www) can read those files?

Yes all the files are owned by *joel *and the group is *www. *They all have 775 permissions.

Btw, I’m running 12.2 and using Tumbleweed if its any help

Why do all those files have x (execute) permission?

IMHO in this case it does not matter much which version of openSUSE you use. But I allways wonder how people can forget to mention this info when they contemplate on how to formulate their problem the best way :(. And of course the fact that you use Tumbleweed is a surprise because we have a Tumbleweed forum.

So if I use Tumbleweed, then I should post all my questions there?

On 09/18/2012 02:46 AM, joelwat wrote:
> So if I use Tumbleweed, then I should post all my questions there?
your apache problems are not related to either an openSUSE problem nor a

i think it much more likely that your problems are directly related to
not reading the apache documentation and/or following a
how-to-setup-Apache guide…

i say that because it is definitely not conventional to mark all files
apache is to serve as 755…

also, it is very unsafe…i’d recommend you not make that site available
to the external net/web until . . .


I think I made all the file 775 just because I was trying anything to get this to work.
But this is a development site, on my home network.

I’ve read the setup guides and searched google for answers.
It seem all I should have to do is add Options Indexes to my configuration.
If you look at the original screenshot you’ll see the directory listing seems to be working but it is empty.
None of the file or directories show up.
I really have no idea what to do

To begin with you should allways post what you use.

And when you use Tumbleweed, some people (amongst them myself) will not try to answer beause they do not use it and do not know what it contains and what not. But if you are 100%+ sure that your problem is a problem not bound to any version, you could try anywhere. But you still have to tell what you use. Some people will even stop reading your thread when you do not provide even that sort of basic information.

And I am with @dd that you first should try to understand the basic things about permissions (users, groups, permission bits). These are very important security items and when you do not understand them, you will have problems understanding why a server deamon like apache can or can not access the files it has to read/write. We can give hints like: "did you check the correct permission. But you should then say: Aha, and then know where to looknfor what. And you can of course open everything for everybody (those bad advises are to be found on the Internet), but then you better do not use Linux at all.

I think your main source of problems is that you do not use the default place to serve files from /srv/www/htdocs.
Running an HTTP server is not something to be done by a mere end-user like joel, let alone from within his home directory.
It is not clear to me why you want to do this. There are two ways of serving: from the system at /srv/www/htdocs (and you can add other places) and/or from user’s home directories at $HOME/public_html. The latter is seen as unsecure nowadays. I do not know why you want to do different. And you must be aware that we can only offer suggestions, because most of us will not have the time to spend in studying all that is needed for your non standard solution.

Important are: who is the user:group running apache (default wwwrun:www) and is that user/group able to have read access (and search for directories) to the files to be served Thus I ask again: do you understand those Unix/Linux permissions?

Yes I understand file permissions in Linux.
Apache is running as the default user/group.
This is my development machine.
I have my repository on my desktop and that’s why the virtual server’s root is pointing there.
I’ve seen many different setups for the DocumentRoot and I think it can point to just about anywhere without a problem.
There are not any restrictions as far as I know.
I thank you for any suggestions you offer since I am stuck on this problem.

There may be some apparmor restrictions if you’re using that. So it might be worth checking. That’s just a wild guess on my side though

Nope. Don’t have apparmor installed. Thanks anyway.

Php, html, js, css all work fine from this virtual server.
Just the directory listing is screwy:\