Anyone ever get Bitwig Studio to work in OpenSuse 13.1

Just wondering if anyone ever got Bitwig Studio]( work inside of OpenSuse 13.1

The Linux package they offer is deb, so you would need to use alien to create the rpm, and then you could install it.


had to dig around the net to find out (being new to linux) how to do the deb to .rpm
got it done and converted…
right clicked the .rpm file …chose install through yast2

loaded alright and it started fine…
Problems started when I went to add directory for the vst in the right panel I realized the popup dialog were not working.

went back to Bitwig forum and they said to install a (gnome) package called zanity …

that worked to fixed the issue with popup dialog …
Now my next thing to figure out is how to install my Ezdrummer so it will work inside of Bitwig in OpenSuse 13.1…
still cant figure it out…
I have wine and wine tricks - but the folder that it loads the vst’s isnt being shown in the folder list inside of Bitwig…
I tried to install Bitwig through wine but it installs but wont operate past the opening logo - it just doesn’t load.

thats as far as i got. :expressionless:

One of the things that separates Linux from Windows is the command line. Don’t fear the command line. Now, since you have the rpm, open up your shell (for example Konsole) and type su and hit enter. It will then ask you for roots password, so you enter whatever your roots password is (please don’t type or paste it here in this forum). Your prompt should change from > to #. From here you can install the rpm by typing rpm -ivh foo.rpm, where foo.rpm is the name of your particular rpm.

Seems to work just fine in openSUSE 13.2

Only caveats is that is complains about missing.
Just tell zypper to break it, and it launches anyway. It does not have a proper icon for some reason though.

Have been using it on OpenSuse 13.1 & 13.2 since Bitwig 1.0, and currently 1.1.7.

Details here:

Hope that helps folks.

Kept working all the way up to 1.3.0 RC, however, the full release of 1.3.0 is giving me grief. Maybe folks here have suggestions?

Okay, all the way up to 1.3.0 RC it was still installing and working. But the full release of 1.3.0 won’t start.

I have been running every version of Bitwig on my OpenSuse system successfully. Even the RC of 1.3.0 worked. But for some reason, the full release I can not get to work. I know they don’t officially support rpm version of their product, but if anyone can please point me in the right direction, it would be very much appreciated.

This is the error I get when trying to start it:
JRE Path: //opt/bitwig-studio/lib/jre
Could not de-obfuscate stack trace: /home/bofh/.BitwigStudio/4624c1b52c2a9f8fa33f537c791263cfa064dd5f-Linux-release.txt not found.
Could not de-obfuscate stack trace: /home/bofh/.BitwigStudio/4624c1b52c2a9f8fa33f537c791263cfa064dd5f-Linux-release.txt not found.
java.lang.UnsatisfiedLinkError: /opt/bitwig-studio/lib/bitwig-studio/ cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at FJe.NrQ(SourceFile:186)
at com.bitwig.x11_windowing_system.X11WindowingSystem.NrQ(SourceFile:20)
at com.bitwig.x11_windowing_system.X11WindowingSystem.<clinit>(SourceFile:14)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(
at com.bitwig.windowing_system.wUd.wCC(SourceFile:151)
at com.bitwig.windowing_system.wUd.<clinit>(SourceFile:42)
at bZB.hcl(SourceFile:73)
at bVY.KOJ(SourceFile:1915)
at bVY.NrQ(SourceFile:142)
at bVY.wCC(SourceFile:1230)
at bVY.NrQ(SourceFile:1188)
at bVY.ToH(SourceFile:870)

I am running 64 bit OpenSuse 13.2
It seems to be looking for this:

And I have libbz2-1-1.0.6-29.2.7.x86_64, which contains:




This thread is more then a year old. Thus the chance that many people will still be subscribed to it is not great. Also the original thread is about differentversion of the software.

I assume that you want to draw the attention of people here that know something about your problem. Thus you should advertize! The best thing is to start a new thread, in the bees fitting (sub)forum, withh a good title that contains keywords that attrackt those that glance through the new threads.

BTW, you posted computer output above. We have a preferred way to do that:
Please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

I know this is an old thread, but in case others find it through web search as I keep finding it, here was the fix:

                                         Many thanks to Bitwig's responsive and helpful technical support through email!

It was just a simple symlink issue (because of being on a different platform than officially supported). I had already tried this under /usr/lib/, but it actually needed it in /usr/lib64 since I’m on a 64 bit version of OpenSuse 13.2
To summarize, on OpenSuse 13.2 64 bit
First made certain that libbz2-1-1.0.6-29.2.7.x86_64 was installed (confirmed). Then add symlink to /usr/lib64/ for /usr/lib64/ ln -s

ln -s


P.S. The “#” button wasn’t viewable in default mode, I needed to click on Advanced features button first, for it to show up. Sorry I missed it before.

Hm, specialy for this feature, the Advanced editor should always be on. Do not know what went wrong there. In any case, the # button and it’s purpose is not very clear to every new member here. That is why we have to tell again and again. But it is of course not your fault that you did not know/see it.

While this thread is old, I’ll add a bit to it as it is still relevant for the 1.3.5 version of Bitwig, and is the only thread returned when I searched for ‘bitwig’.

Bitwig, the current and previous versions, have all run fine for me in OpenSuse, primarily needing only the symlink for created.

I’ve been able to install with the below procedure.

Happy music making.

Installing bitwig 1.3.5 in OpenSuse 13.2 (64 bit)

Install libbsd from:

Download the bitwig-studio-1.x.y.deb package 

As root:

zypper install libbz2-1 alien
alien -r bitwig-studio-1.3.5.deb
rpm -Uvh bitwig-studio-1.3.5-2.x86_64.rpm --nodeps
cp /usr/lib64/ /opt/bitwig-studio/lib/bitwig-studio/
cd /opt/bitwig-studio/lib/bitwig-studio/
ln -s

As user:
cp /usr/share/applications/bitwig-studio.desktop $HOME/Desktop/ 

Thank you so very much for confirming and posting this!