Another MAC address issue

openSUSE 12.3
KDE 4.10.5

This is my problem.
I have one PC with a printer that is servicing the rest of the PCs on the network.
I finally got Cups working just fine by assigning a static IP address to, what I thought was the PC with the printer.
It turns out that the IP address is associated with the MAC address of the wireless adapter and not the PC, and when I swapped out the wireless adapter, the router assigned it a different IP address.
How can I get the IP address to remain the same, no matter what adapter I have in ?

When I read the other thread titled MAC address, where it talked about a cloned MAC address, it seemed like that might be a feature that would solve my problem. Problem is that I have no clue what to do.

It turns out that the IP address is associated with the MAC address of the wireless adapter and not the PC, and when I swapped out the wireless adapter, the router assigned it a different IP address.

Then you didn’t assign the PC with a static IP address - you’re still using DHCP.

That’s interesting deano, because when I was going through the setup and trying to figure out how to do it I was not sure to do it at the PC or at the router.
I did it at the router as you rightfully observed. I picked an address from one of the range generated by DHCP.

Should I pick one outside of the range and assign it at the PC ?

Yes, that’s correct.

BTW, I frequently connect to a SOHO LAN that has a Mac computer with a printer. All machines that connect to it are using DHCP. When I connect with my laptop, the CUPS server (on the Mac) advertises the printer, so no need for any client-side configuration. That is the beauty of CUPS!

That’s very cool and I am going to take a look at it.
Are you saying that a CUPS client will be notified of the IP address change and I really did not need to use a static IP ?
Sweet !

There appear to be a great many unclear statements in this thread.

If your physical network is simple, supports broadcasts and more than likely is running a Workgroup instead of centralized network security and name resolution, then <maybe> Hosts can discover network resources without special configuration.

If you’d like the benefits of DHCP but want the machine to always have the same IP address, if the DHCP server supports you can configure DHCP reserved leases. It’s simply a way for DHCP to see a familiar MAC address and always assign the same IP address. Also, other machines won’t be assigned that IP addressed because <reserved>.

If you manually configure a Static IP address on a network running DHCP, the static address should be outside the scope (addresses) issued by the DHCP server but the Static Address must still be within the subnet defined by the subnet mask. So, this method may require a little bit more know-how than any of the above options.

When configuring a print server (which in this case is a PC the printer is directly attached to) on each Host, it can make a difference if you connect by IP address or by name. If you connect by IP address and the print server’s address changes, then printing services will cease. But, if you configure to connect to the print server by the print server’s Host name and that does not change even if the IP address changes then Hosts will know how to connect (and this is what Deano is describing but is not always how CUPS sets up).


Let me see if I can shed some light.
The network is simple, 5 PCs on one wireless Netgear router, 1 PC wired to the ATT router, which connects to the outside.
The Netgear router is connected via ethernet cable to ATT, LAN to LAN.
ATT runs DHCP, Netgear has DHCP turned off. All PCs are on the same subnet. Mine has a static address of which is outside of the range of the addresses that ATT passes out.
On the PC that I was having trouble printing, I just finished configuring it and it “discovered” my printer. YAYYYY!
I had not told it about so it got the info another way. Pretty smart.

Well, it did after I turned the Firewall off and that is the last thing to solve.
I want to get it back on and still be able to print, so please tell me what I need to do to activate the firewall and still be able to talk to CUPS.
I was pleased to see that it discovered the printer even though I had changed the IP address of My PC.
I still will need to see what happens when I swap out the wireless adapter.


Yes, that is the magic of CUPS. It uses the IPP protocol via TCP. No host or IP configuration is required.

Printer Sharing -

Clients can automatically discover and access shared printers via CUPS browsing, IPP, Service Location Protocol (SLP), and Lightweight Directory Access Protocol (LDAP). DNS Service Discovery (DNS-SD a.k.a. Bonjour®) and SMB browsing can also be used to manually discover and access shared printers.

By default, Mac and Linux OS uses port 631 for IPP communication, so this is the port to open in the firewall.

oppenSUSE12.2 and 12.3 use CUPS 1.5.x by default. CUPS 1.6 introduced some changes to shared printing as outlined here

CUPS 1.6 shaking up Linux printing []

So, a hostname or IP address will then be required AFAIU

Printer Sharing -