Android: adb devices gives empty list

I can’t get adb to show my Android devices. Neither my Sony Xperia2 10.1 tablet nor my Lenovo B phone (both Android 6.0) show up in the list; I’m only getting a “List of devices attached” without entries. However, they are recognized in Plasma when plugged in and are properly mountable via MSC or MTP.

The adb returns immediately; it does not help to become root, so I suppose it is not a permission issue. Tips like adding a udev rule mainly address the issue of permissions and groups, and they actually did not work for me.

# lsusb | grep Sony
Bus 001 Device 022: ID 0fce:e1b1 Sony Ericsson Mobile Communications AB

# cat /etc/udev/rules.d/80-android.rules
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", ATTR{idProduct}=="e1b1", MODE="0660", GROUP="dialout", SYMLINK+="android%n"

# ll /dev/android*
lrwxrwxrwx 1 root root 15  2. Dez 23:15 /dev/android1 -> bus/usb/001/022

# adb devices
List of devices attached 

Have you enabled android debugging in the settings of your Android devices?



I suppose this is important. :slight_smile:

(WTF? About Tablet … hit Build Number seven times? Bad joke. Yes, it worked.)

Easy and common thing to overlook…


Indeed, thanks!

Particularly easy to overlook since they hid the debug mode behind funny touchscreen dances. Next release you’ll have to recite some poem while balancing the device on your fingertips.

I wished adb would output some informational message like “No devices found; check devices for debug mode”. “No news is good news” is definitely not true when you invoke adb, because you most likely expect some device to show up.

Sorry to hijack this thread, but I have USB debugging enabled and get an empty list of attached devices with my essential phone. I tried it with an HTC 10 and instead of a device ID, I get “???”. I guess a bunch of question marks is better than nothing, but it does not inspire confidence.

Any idea what is wrong?

You should start by running the commands in the first post that verify your device is detected and recognized properly, only after that you can try to diagnose connecting to the device.
Of course your device isn’t a Sony device… So you can either grep for your won device identification or not grep and simply scroll through the entire result looking for your device.