Goodmorning everyone
Amule does not install missing this dependency, so it does not work the lib is:, I was 4 hours looking for it on the internet but nothing forgot 64 bit Tumbleweed, thanks

I wrote the following that suggests some tries when you’re looking for a missing dependency
If you’re still unable to find your file, post again…


If you look at the build project you will see it’s failing to build against the current Tumbleweed snapshot;

If you look at the last build binary you can see that not onlt libxml, but also libpnp;

So it needs some work to get it working… just looking for a dependency is not always going to be a win for you…

Do you specifically need aMule or is there an alternative you could use?

Probably no real surprise it doesn’t build and particularly for TW,
The project’s last/latest release was in 2016, more than 2 years ago…

And, even that release was known to have problems with latest versions(in 2016) of several components

Some RPMs were built long ago intended for Fedora 24/25,
I’d guess that anyone that wants amule really badly can try them

By all appearances though,
This looks like a dead project where even its last release had a number of significant problems that were never resolved…

Same thing for emule, I haven’t paid close attention to these projects but remember vaguely that one or the other or both were re-incarnated briefly in a form that tried to resolve some of the issues related to their being deemed illegal but never gained the same kind of acceptance as before.


thanks the strange thing that the antecedent worked well so I should present it to Packman?

Depends on how far back your “antecedent” is…

As I described, if my memory is correct and your working version is based on the previous P-P architecture, it was deemed an illegal way to do file sharing (IIRC client/server where someone has sufficient control over the Server to block illegal activity. Compare that to current bittorent where there is no centralized server, every peer is at once both a client and a server).

I doubt you’d convince anyone to distribute an app that isn’t in any grey area and is unarguably illegal (Based on a court judgement).